Dark Souls: Prepare to Die Edition

Dark Souls: Prepare to Die Edition

View Stats:
Sapphire Feb 10, 2016 @ 7:08am
Weird graphical bug, please help!
EDIT: Using any level of SMAA was causing the issue for some reason, switching to FXAA fixed it.
______

I've been playing just fine with PvP Watchdog and DSFix, none of my settings have been changed at all, but I'm getting this weird graphical problem making everything look foggy, see below on the picture.

http://steamcommunity.com/sharedfiles/filedetails/?id=620807637

I've tried verifying the game and reinstalling DSFix and reconfiguring it, to no avail.
Any help would be appreciated.
Last edited by Sapphire; Feb 10, 2016 @ 9:30am
< >
Showing 1-13 of 13 comments
Psicraft Feb 10, 2016 @ 7:23am 
You may want to prepare a casket for your graphics card.
GLUE Feb 10, 2016 @ 7:26am 
It could be related to hook overlays. Are you by chances using an AMD GPU with Radeon Pro installed? Also, have you tried launching the game without DSfix and Watchdog just to test it out?
Sapphire Feb 10, 2016 @ 7:27am 
I'm using an NVIDIA GTX 970 and it's having no problems on other games.
I'll try launching without DSFix, but if that's the case, I'd have thought reinstalling it would;ve sorted the issue.
Sapphire Feb 10, 2016 @ 7:35am 
Launching it with DSFix on default settings, unconfigured worked fine, which doesn't make much sense since my own configuration was working completely fine just last night. Oh well.. I'll go through it and carefully reconfigure it until I find out what the cause it.
GLUE Feb 10, 2016 @ 7:41am 
It might be another hook on top of DSfix that is causing the problem. In reality, it could be anything, from steam overlay to nvidia shadowplay and such. Try to use the default DSfix settings first, then go from there.

http://steamcommunity.com/sharedfiles/filedetails/?id=494805723

This is what it looked like on my end with an AMD GPU + Radeon Pro. It would trigger at random, whenever steam overlay gets the chance to pop up, be it friends in-game or just browsing the internet.
Last edited by GLUE; Feb 10, 2016 @ 7:44am
Sapphire Feb 10, 2016 @ 7:53am 
Okay, so the issue presents itself whenever I uncap the framerate. I can change any other setting and it'll work fine if the framerate stays capped.

I'd prefer to have my 60fps, and I'm unsure as to why such an issue would arise from uncapping the framerate, especially since it was working fine last night.

Any ideas?
GLUE Feb 10, 2016 @ 8:05am 
Sadly i wouldn't know. There is zero reason not to uncap the framerate, considering the default uncapped framerate forces double buffering, or rather it halves your FPS if you drop a frame below the default 30.

Did you by any chance try to monitor your GPU usage and temp while playing unlocked?
I unlock my framerate but cap it at 30 since my PC can't handle constant 60.
Someone else on the forums might help.
Sapphire Feb 10, 2016 @ 8:09am 
I was putting off doing so incase I could fix it, but I'm doing a total reinstall of the game, I'll set up Watchdog and DSFix again and see how that goes.
Psicraft Feb 10, 2016 @ 8:26am 
Originally posted by Wonderglue:
zero reason

Not zero reason, but enough of a reason despite the game freezing at bonfires if you navigate the menu too fast.
Sapphire Feb 10, 2016 @ 8:40am 
A complete reinstall didn't work.
Sapphire Feb 10, 2016 @ 9:19am 
Default settings but with FPS uncapped doesn't produce the bug, so something else is causing it. I'll check back with my findings as I play around with the ini.
Sapphire Feb 10, 2016 @ 9:29am 
After extensive testing I've found using any level of SMAA was causing the issue. Switching to FXAA sorted the problem. What a weird bug!
Robotlev Mar 9, 2016 @ 5:08am 
Originally posted by Sapphire:
After extensive testing I've found using any level of SMAA was causing the issue. Switching to FXAA sorted the problem. What a weird bug!
Thanks a lot. This helped my friend to fix this bug :)
< >
Showing 1-13 of 13 comments
Per page: 15 30 50

Date Posted: Feb 10, 2016 @ 7:08am
Posts: 13