Offspring Fling! > Genel Başlıklar > Konu Detayları
Codename:Grey Fox 7 Mar 2013 @ 4:50am
Game runs really slow! (on windows)
Well, I decided to make another topic on the matter, since the other one seems to be Mac focused.

Basically, it runs at 15FPS, even when I put the graphics to low (doesn't change at all the FPS). And I've tried disabling the controller too.

Operating System
MS Windows 7 Ultimate 64-bit SP1
CPU
AMD Athlon 64 X2 5600+
Graphics
ATI Radeon HD 4890

Anyone has any ideas?
Thanks for the help!
En son Codename:Grey Fox tarafından düzenlendi; 7 Mar 2013 @ 4:51am
18 yorumdan 1 ile 15 arası gösteriliyor
< >
kpulv  [geliştirici] 8 Mar 2013 @ 11:57am 
Sorry about the issues! I'm guessing the main bottleneck here is the CPU. The minimum recommended specs for Offspring Fling are a CPU that is near the speed of a q6600 or so.

Does the demo run the same way for you? http://offspringfling.com/demo/

Offspring Fling runs solely off of the CPU since it is all software rendering. I have been looking into options to fix this in the future though, but I can't make any solid promises for the time being. I know some people are suffering performance problems and it's really at the mercy of Adobe AIR and their system configurations. Sorry! :(
D-Ryu77 8 Mar 2013 @ 1:15pm 
I'm using an i5 2500 k and a 670 GTX and the game has weird fps drops.
Codename:Grey Fox 8 Mar 2013 @ 3:17pm 
Oh, bleh. The demo runs fine though.
Thanks for the reply.
En son Codename:Grey Fox tarafından düzenlendi; 8 Mar 2013 @ 3:17pm
kpulv  [geliştirici] 10 Mar 2013 @ 5:55am 
Hmmm so there's something about Adobe AIR that runs very slow compared to just the browser version... I'll try my best to figure this out!

D-Ryu77: what does your fps drop down to? (You can hit ~ to show your fps in game)
Codename:Grey Fox 10 Mar 2013 @ 6:28pm 
Sorry, just so you don't go having any unnecessary work, let me clarify: It runs better, but it still doesn't run perfect!
kpulv  [geliştirici] 11 Mar 2013 @ 3:05am 
I see... can you email me at hello@offspringfling.com ? I might be able to make a new build that runs better on your computer, but I would need it tested first.
Codename:Grey Fox 11 Mar 2013 @ 4:45am 
Done.
proXy 4 May 2013 @ 8:01pm 
The game runs slow for me too, but when I put it on low, it runs well. Does it use so much processor power? :S

Windows 7 Ultimate 64-bit
AMD Phenom II X4 N950 2.1GHz
AMD Radeon HD 6650M
4 GB DDR3
kpulv  [geliştirici] 7 May 2013 @ 1:36am 
The game is mostly on the CPU, yes, so the processor has a huge effect on if it runs well. Sometimes the controller support causes issues on some computers, so disabling that might bring your frame rate up slightly.
ShinjiKnox 4 Haz 2013 @ 10:06am 
Same here, 8fps with

Windows 8 Pro (64bits)
i5 3570 (no overclock)
8gb DDR3 1600Mhz (Corsair Vengeance)
XFX ATI Radeon HD 7770 (also no overclock)
kpulv  [geliştirici] 5 Haz 2013 @ 12:22pm 
Sorry about that :( If you're experiencing frame rates below 10, I would assume that it's actually being caused by the controller extension freaking out. This happens on certain hardware configurations -- the way around it is to disable the in game controller support and use something like joy2key to play instead. Try using the instructions in the readme to disable the controller extension in the game: http://offspringfling.com/ReadmeOnline.html#controller
ShinjiKnox 5 Haz 2013 @ 12:42pm 
Tried removing the controller, no luck. Same FPS, no more or less.
Updated Adobe Air and tried the DRM free version, still no luck.

The game looks really cool, sad that I can't run it. :(

Edit: good news! I actually misunderstood what you said. Setting enableController=0 solved my problem. 60fps now. :)
En son ShinjiKnox tarafından düzenlendi; 5 Haz 2013 @ 12:47pm
kpulv  [geliştirici] 5 Haz 2013 @ 8:03pm 
Oh okay, phew. Glad that it worked out for you!
QQ Bee 21 Haz 2013 @ 4:27pm 
I can also confirm a small speedup with controller disabled too, getting 40-56fps in 1x window and scaled. Phenom II X4 830
Shiaoran 18 Tem 2013 @ 4:12am 
enableController=0 solved my problem too. Maybe it should be disabled by default with a lag warning.
18 yorumdan 1 ile 15 arası gösteriliyor
< >
Sayfa başına: 15 30 50