Lego Harry Potter

Lego Harry Potter

lakesideguy Sep 10, 2013 @ 6:22pm
Windows 8 users trying to run Harry Potter years 1-4 and black window fix (video issue)
Hello,

I thought i'd share that I ran into a weird issue in Windows 8 64 bit that when trying to run the game I got a smaller window in the upper left that was black that was titled "Harry Potter Years 1-4" on launching the game. So I moved the mouse cursor to it and left clicked it. I noticed my 3D TV trying to do a resolution switch and the TV gave me an error quickly saying it failed.

The black windows went away but the game was still running in the background. Each time clicking it did not work. I researched this issue thoroughly and countless people advising me to change my audio sampling rate. That didn't work. This was clearly a video issue.

It appears there are two issue here. One is the audio one which is a black screen a just a crash. And the endless loop of a windows in the left of the screen and clicking it and the game still running in the background after the resolution switch failure. Thankfully, my TV, led me to the cause when it reported the failure in a message on the screen saying "Unsuported mode".
Gotta love them new SMART 3D TV's best eva!

Anyway, I changed the desktop resolution to many modes. All failed but ONE.
1024x768 and I got the whole screen as a window with the game title. It still didn't do anything until I left clicked then the video came up! I then went into the games video optionis and switched it back to my desktop resolutioin to 1920X1080P @ 60Hz.

The game dropped back to the desktop with the game running in the background again. I just right clicked the ICON and closed it. Then I switched my desktop BACK to 1920x1080P and re-launched the game and instead of it in the upper left as a black window it filled my entire TV screen. I left clicked the game launched and went on my way to enjoying the game.

And I have the audio sampling rate running at 24 bit 48Khz Studio Quality and it's fine.
So while there's two issues it appear sin Windows 8 for myself it was a video issue and what I did about by switching the desktop res to 1024X768 worked. I couldn't get it to initally work at any other res but that one either.

If you follow these instruction in detail if the audio fix doesn't work this may very well be your answer. It fixed it for me and no more crashes. Would be nice if they patched the game but I doubt it to be able to change options before launching it. But this worked as well.

Good luck. I pulled my hair out but persistence prevailed and it works fine on Windows 8.
< >
Showing 1-1 of 1 comments
Counterfeit Spy Mar 1 @ 4:36pm 
I just want to stop the game from crashing every now and then. It's done it to me 3 times and I'm on Year 2. I've have Windows 8.1 but I don't have 3D TV or anything like that.
< >
Showing 1-1 of 1 comments
Per page: 15 30 50