Lego Harry Potter > 一般討論 > 主題細節
sourgrapesnape 2013 年 01 月 13 日 @ 下午 1 時 12 分
Main Executable not Working--I've tried Everything.
I am running Windows 7 on a Mac via Bootcamp. I had no problem playing Lego Harry Potter Years 1-4 until recently, when my computer crashed while in windows. After logging back on, I tried playing the game and it crashed right before the loading screen with the "Main Executable not working" error. I have tried uninstalling and reinstalling and changing my speakers settings, but nothing has helped. I have Lego Star Wars, and that works perfectly fine.
顯示 1-12,共 12 則回應
< >
therese_forsberg 2013 年 05 月 9 日 @ 上午 8 時 31 分 
I have the same problem. I´ve tride changing audio settings, screen resolution an changing the pcconfig file. Game still crashes and "main executable not working" message pops up. Any one with a fix to this problem?
Prophet Candy 2013 年 05 月 22 日 @ 上午 9 時 11 分 
Same here, I've only just bought the game for PC, my computer specs are above minimum and mostly above the required. I get the exact same issue. Help!
Jondawg 2013 年 05 月 24 日 @ 下午 5 時 52 分 
I also have this issue, wish I could figure out what it is.
Jondawg 2013 年 05 月 24 日 @ 下午 5 時 59 分 
http://forums.steampowered.com/forums/showthread.php?t=1344121

That page describes in detail how to fix the problem.
Prophet Candy 2013 年 05 月 25 日 @ 上午 8 時 10 分 
Yeah, the changing volume Hz thing worked for me, thanks!
direcorwin 2013 年 11 月 3 日 @ 下午 3 時 59 分 
Changing the sound frequency also worked for me. Thanks!
Malwin 01 月 31 日 @ 下午 3 時 17 分 
Hi everyone, a little refresh oh this issue. I got the same "Main executable" error. Once I managed to go through this thanks to the solution where you change the sound parameters to 48 kHz but it did happen again some levels later :(
Any new solution ?
hispongebob 03 月 25 日 @ 下午 5 時 37 分 
i got the error on my windows xp after it showed the xmas tree cutsene hagrids hohoho killed the game
Dogposture 04 月 4 日 @ 上午 4 時 34 分 
I was still getting crashes every 10-15 minutes with the volume hz changes on Windows 7 SP1. Changing the game to use Vista SP2 compatibility mode seems to reduce the frequency of the crashes massively for me.

i.e. Open Explorer - Find Steam directory -> <Steam>/steamapps/common/LEGO Harry Potter
Right click on LEGOHarryPotter.exe and then properties.
Go to compatibility tab and click "Run this program in compatibility mode for"
Select "Windows Vista (Service Pack 2)"
Click Apply and then OK.

Now i'm only getting a crash once every 3-4hrs which makes the game playable.

fernie 05 月 17 日 @ 下午 5 時 50 分 
hispongebob 發表:
i got the error on my windows xp after it showed the xmas tree cutsene hagrids hohoho killed the game

I'm having the exact same problem at that cutscene. Any answers to how to sort this? Trying changing the volume hz but no joy.
|FMP|Arya 05 月 17 日 @ 下午 10 時 33 分 
fernie 發表:
hispongebob 發表:
i got the error on my windows xp after it showed the xmas tree cutsene hagrids hohoho killed the game

I'm having the exact same problem at that cutscene. Any answers to how to sort this? Trying changing the volume hz but no joy.
time to get a new PC, you two.

Windows XP was marked as an unsupported OS Last year.
最後修改者:|FMP|Arya; 05 月 17 日 @ 下午 10 時 33 分
Malwin 05 月 21 日 @ 上午 10 時 20 分 
I doubt the problem comes from XP : I play on Windows 7 and it doesn't work either.
顯示 1-12,共 12 則回應
< >
每頁: 15 30 50