Lego Harry Potter

Lego Harry Potter

sourgrapesnape Jan 13, 2013 @ 1:12pm
Main Executable not Working--I've tried Everything.
I am running Windows 7 on a Mac via Bootcamp. I had no problem playing Lego Harry Potter Years 1-4 until recently, when my computer crashed while in windows. After logging back on, I tried playing the game and it crashed right before the loading screen with the "Main Executable not working" error. I have tried uninstalling and reinstalling and changing my speakers settings, but nothing has helped. I have Lego Star Wars, and that works perfectly fine.
< >
Showing 1-12 of 12 comments
therese_forsberg May 9, 2013 @ 8:31am 
I have the same problem. I´ve tride changing audio settings, screen resolution an changing the pcconfig file. Game still crashes and "main executable not working" message pops up. Any one with a fix to this problem?
Culinarius May 22, 2013 @ 9:11am 
Same here, I've only just bought the game for PC, my computer specs are above minimum and mostly above the required. I get the exact same issue. Help!
Jondawg May 24, 2013 @ 5:52pm 
I also have this issue, wish I could figure out what it is.
Jondawg May 24, 2013 @ 5:59pm 
http://forums.steampowered.com/forums/showthread.php?t=1344121

That page describes in detail how to fix the problem.
Culinarius May 25, 2013 @ 8:10am 
Yeah, the changing volume Hz thing worked for me, thanks!
direcorwin Nov 3, 2013 @ 3:59pm 
Changing the sound frequency also worked for me. Thanks!
Malwin Jan 31 @ 3:17pm 
Hi everyone, a little refresh oh this issue. I got the same "Main executable" error. Once I managed to go through this thanks to the solution where you change the sound parameters to 48 kHz but it did happen again some levels later :(
Any new solution ?
hispongebob Mar 25 @ 5:37pm 
i got the error on my windows xp after it showed the xmas tree cutsene hagrids hohoho killed the game
Dogposture Apr 4 @ 4:34am 
I was still getting crashes every 10-15 minutes with the volume hz changes on Windows 7 SP1. Changing the game to use Vista SP2 compatibility mode seems to reduce the frequency of the crashes massively for me.

i.e. Open Explorer - Find Steam directory -> <Steam>/steamapps/common/LEGO Harry Potter
Right click on LEGOHarryPotter.exe and then properties.
Go to compatibility tab and click "Run this program in compatibility mode for"
Select "Windows Vista (Service Pack 2)"
Click Apply and then OK.

Now i'm only getting a crash once every 3-4hrs which makes the game playable.

fernie May 17 @ 5:50pm 
Originally posted by hispongebob:
i got the error on my windows xp after it showed the xmas tree cutsene hagrids hohoho killed the game

I'm having the exact same problem at that cutscene. Any answers to how to sort this? Trying changing the volume hz but no joy.
Arya May 17 @ 10:33pm 
Originally posted by fernie:
Originally posted by hispongebob:
i got the error on my windows xp after it showed the xmas tree cutsene hagrids hohoho killed the game

I'm having the exact same problem at that cutscene. Any answers to how to sort this? Trying changing the volume hz but no joy.
time to get a new PC, you two.

Windows XP was marked as an unsupported OS Last year.
Last edited by Arya; May 17 @ 10:33pm
Malwin May 21 @ 10:20am 
I doubt the problem comes from XP : I play on Windows 7 and it doesn't work either.
< >
Showing 1-12 of 12 comments
Per page: 15 30 50