SolidFlam 31 de Oct, 2012 a las 12:24
Speeding up the game
After watching a gameplay video I realized I'm basically playing the game in slow motion - it doesn't seem choppy like with a low framerate, everything is just somewhat slower, which makes the game a bit tedious.
Any ideas on how I can speed it up? I'm playing windowed and without parallax (?) scrolling.
My laptop is a Turion X2 2Ghz with 3GB RAM and a Radeon 3100 (yeah not amazing, but I figured it'll be enough for a game like that).
Última edición por SolidFlam; 31 de Oct, 2012 a las 12:25
Mostrando 1-15 de 44 comentarios
< >
vittau 31 de Oct, 2012 a las 14:27 
Known problem, but dev has no idea what causes it or how to fix it (check the other thread here called "Slowdown issues in the first couple of minutes of each level").
Wait for the C++/SDL rewrite which should fix this problem (it appears to be caused by some XNA related problem)...
SolidFlam 31 de Oct, 2012 a las 17:00 
Thanks, I'll give it a look.
Cannibox 31 de Oct, 2012 a las 18:38 
Well, at least you can actually play the game, unfortunatly it seems it doesn't wan't anything to do with my graphics card.
SpookyAndrew  [desarrollador] 31 de Oct, 2012 a las 18:41 
Hi all, new Halloween level and patch is live. Patch may interest you. Has the added options of turning scrren-effects off separate from parallax and the ability to toggle v-synch. Don't know, this may help.
Galaxy Swift 31 de Oct, 2012 a las 22:45 
Go into the video settings and turn off Screen FX.
vittau 1 de Nov, 2012 a las 13:14 
The new Screen FX and V-Sync options didn't help with this problem at all...
ShinjiKnox 1 de Nov, 2012 a las 16:18 
Same problem here. Deactivated a couple of things but the game still plays slow.

Also, it would be good to change the resolution. I can't play any 1280x720 fullscreen here because my TV is 1366x768.
Última edición por ShinjiKnox; 1 de Nov, 2012 a las 16:21
Snippety 1 de Nov, 2012 a las 21:29 
So after running some tests I found out that the game runs at normal speed for me as long as at least one of the three video options is disabled (Paralax, Screen FX and V-Sync). Doesn't matter which one. Can anyone relate to this?
ShinjiKnox 1 de Nov, 2012 a las 23:00 
AMD Athlon X2 5200+ / ATI Radeon HD3200 / Windows 8 Pro reporting:

Everything on: 22 FPS
Only Parallax off: 24 FPS
Only Screen FX off: 23~25 FPS
Only VSync off: 22~23 FPS
Everything off: 27 FPS
Última edición por ShinjiKnox; 1 de Nov, 2012 a las 23:10
SolidFlam 2 de Nov, 2012 a las 10:06 
I tried turning everything off, closing and restarting the game, and I think there's a slight improvement, but it's still considered slow motion. It's interesting that the checkpoint creation animation looks fine (in my opinion, it's hard for me to say what's right), but moving and hitting an enemy (without any scrolling going on) is in slow motion.
SarelFox 2 de Nov, 2012 a las 14:51 
Same problem here. Rather annoyed, as I bought this to play on my laptop (Not a bad Radeon Mobility 4250 HD) and the game runs at about 66% of what I've seen at best. Waiting for the re-write, but am disappointed in XNA's rather problematic usage of the system. For reference, however, Bastion runs as sweet as anything on this thing.
Boby 2 de Nov, 2012 a las 15:28 
you guys have update your drivers? I'm runing a 4895 hd and the ggame is smooth as silk, I know it is not the same as the mobility.

make suere your pc is optimized
SolidFlam 2 de Nov, 2012 a las 16:04 
Followed your advice just now, Boby - still no change...
vittau 2 de Nov, 2012 a las 19:54 
Publicado originalmente por SarelFox:
Same problem here. Rather annoyed, as I bought this to play on my laptop (Not a bad Radeon Mobility 4250 HD) and the game runs at about 66% of what I've seen at best. Waiting for the re-write, but am disappointed in XNA's rather problematic usage of the system. For reference, however, Bastion runs as sweet as anything on this thing.
Maybe Bastion doesn't use a fixed time step, which is the case here. When a fixed time step is used, XNA is responsible for calling the Update method, and it's probably screwing up with the timing (possibly related to HPET?).
Hence, the game has no idea it's actually running in slow-motion as evidenced by the in-game fps graph (press F11) showing a straight line as if the game were running just fine...

To be precise, it seems .NET itself is responsible, because the dev uses System.Diagnostics.Stopwatch to draw the fps graph, and it's also affected.
ShinjiKnox 2 de Nov, 2012 a las 19:54 
Lastest Catalyst drivers here, Boby.
I think it's clearly a XNA problem. There's no way a game this simple could not run here. If that was the case, Super Meat Boy would never run here.
Mostrando 1-15 de 44 comentarios
< >
Por página: 15 30 50