They Bleed Pixels
Smorpheus Aug 8, 2013 @ 11:31pm
Game Crashing on Start...
I've seen other threads about this, but I think I have an unique issue.

The game was working fine until this afternoon. I was about 3/4 of the way through "The End" (yes, really, I'm so close!) when the wife came home, so I Save and Quit. Went to load it back up, and it won't launch.

I've had the .NET issue where it initializes each time. I've read all the threads, here's what I tried in order:
-Verifying Game Integrity
-Manually running the .Net files
-Deleting the .Net Files
-Running TBP directily
-Running TBP as Administrator
-Uninstalling all .Net and XNA things I had installed.
-Uninstalling and reinstalling TBP from steam
-Reverting to a System Restore point from where it did work.

None of that did anything except eventually Steam stopped trying to run .Net when I launched. System Restore brought it back to how it was, it's running the .NET again.

I also have a temp.txt file that's telling me the following:
System.IO.EndOfStreamException: Unable to read beyond the end of the stream.
at System.IO.BinaryReader.FillBuffer(Int32 numBytes)
at System.IO.BinaryReader.ReadInt32()
at Bleed.RW.LoadConfig() in C:\Documents and Settings\Rio\My Documents\Visual Studio 2010\Projects\They Bleed Pixels PC\They Bleed Pixels PC\They Bleed Pixels PC\TBP_ReadWrite.cs:line 138
Done - this is a test
trying ...

Anything I missed trying? I'm guessing this is a save game problem? If I have to start The End again, I'm going to be a sad, sad man.
Last edited by Smorpheus; Aug 9, 2013 @ 1:17pm
< >
Showing 1-15 of 30 comments
Taurinensis Aug 9, 2013 @ 2:19am 
Also having this issue. It worked fine last night, then Steam updated when I woke up this morning and now it wont work
Taurinensis Aug 9, 2013 @ 4:39am 
OK! After asking around with my friend a bit, he solved it for me. On my steam settings I had opted into the beta stuff. So I opted out using the little drop down box, restarted steam and BOOM! game works again. Hope that works out for you =D now I can continue my speed running attempts
Smorpheus Aug 9, 2013 @ 11:08am 
Yep, that fixed it. Going to report the bug to STeam. Thanks so much!
Gerbick Aug 9, 2013 @ 12:11pm 
Having the same issue, but the opt-out beta fix didn't help. Reinstalled everything as well.
Smorpheus Aug 9, 2013 @ 1:16pm 
Did you try all the stuff I listed above?
Gerbick Aug 9, 2013 @ 1:25pm 
yep. reinstalled game, and all exe/msi in game folder. nada. was working yesterday without problems
Smorpheus Aug 9, 2013 @ 4:11pm 
Is it doing that thing where it's installing .Net everytime you try to launch?
Gerbick Aug 9, 2013 @ 5:27pm 
yeah it is. although it was doing that when it was working too.
Lord JoJo T. Aug 9, 2013 @ 5:51pm 
I have this issue too, game was working fine with no hiccups 36 hours ago, then I try and launch it 12 hours ago and crash at startup with this error:

Problem Event Name: APPCRASH
Application Name: They Bleed Pixels PC.exe
Application Version:
Application Timestamp: 50b18016
Fault Module Name: StackHash_4274
Fault Module Version: 6.1.7601.17725
Fault Module Timestamp: 4ec49b8f
Exception Code: c0000374
Exception Offset: 000ce6c3
OS Version: 6.1.7601.
Locale ID: 5129
Additional Information 1: 4274
Additional Information 2: 427448d2267027014fc8e1f80a64fd97
Additional Information 3: 4139
Additional Information 4: 41393b3573d581f4f2050b4a372b0482

Not in any beta for it, tried re-installing, tried all the .net etc. installers, nothing. I was close to finishing it too :(

EDIT: Also tried installing the multilingual version of .NET 4.5 which I saw reccomended, didn't help.
Last edited by Lord JoJo T.; Aug 9, 2013 @ 6:13pm
Smorpheus Aug 9, 2013 @ 10:43pm 
Hmm.. Not sure guys. Hopefully the developer will chime in. He's on Steam now, but I dont' think I can direct message him.
Gerbick Aug 10, 2013 @ 4:17am 
seems to have coincided with a Steam update.
d.Tox508 Aug 10, 2013 @ 5:47am 
having the same issue, wont start. initiates .NET and then nothing
Sucy Chocowitch III Aug 10, 2013 @ 12:54pm 
same here this maybe is related to steam update since before the update works fine
Spooky Squid  [developer] Aug 10, 2013 @ 2:08pm 
Hi folks,
Sorry for the slow response. Andrew who usually checks the forums regularly has been sick all week so may have missed this. Sounds like a problem on Steam side with the last update but we're going to look into it. Hopefully have TBP up and running for you all soon!

Also please do make sure that you are not checked into the Beta, we use that for testing updates so it may not always run correctly and you could corrupt your saves.

- Miguel
Gerbick Aug 10, 2013 @ 2:09pm 
Thanks for the response! Fingers crossed we'll get it working again.
< >
Showing 1-15 of 30 comments
Per page: 15 30 50