Sanctum 2
Sanctum 2 > General Discussions > Topic Details
CheckSix Sep 28, 2013 @ 10:52am
Solved: Sanctum 2 Won't Start
Edit: I thought I would put this at the top of the thread. If Sanctum 2 isn't starting correctly for you, and you have Adobe's Creative Cloud client running - try exiting CC. Alternatley, updating to the latest version of the CC client has solved the problem for me.

I've made no changes to my system and have played Sanctum for a few hours without trouble. Now, every time I start Sanctum 2 the splash screen comes up, the game goes full screen, then Sanctum minimizes itself and kicks me back to the desktop. I click on it. Goes full screen (all black), and minimizes itself again. I've verified the game cache, ensured that it isntalled its required components, and restarted my system. Anyone have any ideas of what I can try next?
Last edited by CheckSix; Dec 20, 2013 @ 4:09pm
< >
Showing 1-15 of 25 comments
Migz - DH Sep 28, 2013 @ 11:56am 
Do you have the Windows Language Bar running? Or anything else unusual in the system tray?
CheckSix Sep 28, 2013 @ 11:58am 
No, standard stuff. Same stuff that has always been there for 12 hours of game play. I added '-d3d11' to the start-up options. It now loads to the main menu. However, when I attempt to select anything from the main menu it minimizes to the desktop. I have just tried updating my NVIDA drivers to the latest revision, and still have the same issue.
CheckSix Sep 28, 2013 @ 12:15pm 
Update, I can run it in windowed mode. I guess that will have to do. I think there might be something up with the cursor overlay or something. Not sure what could all-the-sudden break it like this, but who knows.
Karpet Terbang Oct 3, 2013 @ 3:39am 
restart your steam
Minerne Oct 25, 2013 @ 7:08pm 
I've hit the same issue. Restarting Steam and restarting my system didn't work. The game starts and I can hear music for about 2 seconds then it drops to the desktop. I'm running a GTX780.
Right click the game in your library. Go to properties, and then verify the game cache. Sometimes an update might put your game data out of whack. Hope it helps.
Minerne Oct 25, 2013 @ 8:50pm 
Nope. Was a fresh install. I managed to get it started and then any time I used the mouse it forced to the desktop. Ended up using the -windowed flag and that let me play for a while.
ĿīνоЯΕ Oct 27, 2013 @ 9:03am 
same problem
kn00tcn Oct 27, 2013 @ 3:50pm 
do you have a lowered firefox window open? windows alerting you that it's disabled aero? things like afterburner open? overlays on 3d games? xsplit/OBS?
[CSS] KConny  [developer] Oct 28, 2013 @ 1:01am 
Hi all, I might have a solution. But it involes loosing all of the settings you've made in the game.

Go to your Libraries or My Documents and find MyGames. Then Sanctum2/SanctumGame/Config and remove the contet of the folder. Try to start the game again.
Minerne Oct 28, 2013 @ 7:28am 
Originally posted by kn00tcn:
do you have a lowered firefox window open? windows alerting you that it's disabled aero? things like afterburner open? overlays on 3d games? xsplit/OBS?

None of these.

Originally posted by KConny:
Hi all, I might have a solution. But it involes loosing all of the settings you've made in the game.

Go to your Libraries or My Documents and find MyGames. Then Sanctum2/SanctumGame/Config and remove the contet of the folder. Try to start the game again.

Doing this causes the issue to reappear. If I use the -d3d11 flag then I can get to the main menu but as soon as I click anything it drops to the desktop. Without any flags, I can never get the game to leave minimized mode. With windowed mode it works fine.
Migz - DH Oct 28, 2013 @ 10:26am 
On other UE3 games where this happens (BioShock Infinite and Borderlands 2 for instance), there has been some other program which is causing Windows to unfocus that game.

http://steamcommunity.com/app/8870/discussions/0/828934913224834623/
http://steamcommunity.com/app/49520/discussions/0/864976115608490820/
http://steamcommunity.com/app/8870/discussions/0/864975632811390114/

That's why I asked about the Windows Language Bar. Adobe Creative Cloud's systray launcher has also caused this problem.

If you don't have either of those running, just start turning off every other non-core-windows process one by one, then startup Sanctum 2, and see if it works then. Eventually, you will find the problem program.... assuming something new in the OS isn't causing the problem. (Or, if you don't want to spend that much time, try running the game while in Windows Safe Mode to see if there is another program interfering.)

---------------------------------------------------------------------------------------

What OS are you guys running?
Last edited by Migz - DH; Oct 28, 2013 @ 10:57am
Minerne Oct 28, 2013 @ 10:37am 
Originally posted by Migz - DH:
On other UE3 games where this happens (BioShock Infinite and Borderlands 2 for instance), there has been some other program which is causing Windows to unfocus that game.

http://steamcommunity.com/app/8870/discussions/0/828934913224834623/
http://steamcommunity.com/app/49520/discussions/0/864976115608490820/
http://steamcommunity.com/app/8870/discussions/0/864975632811390114/

That's why I asked about the Windows Language Bar. Adobe Creative Cloud's systray launcher has also caused this problem.

If you don't have either of those running, just start turning off every other non-core-windows process on by one, then startup Sanctum 2, and see if it works then. Eventually, you will find the problem program.... assuming something new in the OS isn't causing the problem. (Or, if you don't want to spend that much time, try running the game while in Windows Safe Mode to see if there is another program interfering.)

---------------------------------------------------------------------------------------

What OS are you guys running?

Thank you! It was Adobe Creative Cloud. I shut that down and now it works fine in full screen. I don't have issues with Borderlands 2 though, so no sure why Sanctum would be impacted. In any case, my issue is resolved so thanks again.
Migz - DH Oct 28, 2013 @ 10:57am 
Originally posted by Minerne:
Thank you! It was Adobe Creative Cloud. I shut that down and now it works fine in full screen. I don't have issues with Borderlands 2 though, so no sure why Sanctum would be impacted. In any case, my issue is resolved so thanks again.

Glad that helped.
CheckSix Oct 30, 2013 @ 4:48pm 
I know it may seem funny, but I've actually had things broken by the company I work for more than once. The good news is that we feel everyone's pain. The bad news is that it happened in the first place.

Updating the CC desktop app to the latest version fixes the issue for me. I can't speak officially, of course, but I'm sorry this happened. I don't work on the CC team.
< >
Showing 1-15 of 25 comments
Per page: 15 30 50

Sanctum 2 > General Discussions > Topic Details
Date Posted: Sep 28, 2013 @ 10:52am
Posts: 25