Sanctum 2 > General Discussions > Topic Details
Tai Apr 22, 2014 @ 6:31am
Dead horse: Failed to create d3d9 device
I can play Sanctum 2 just fine...once per reboot. Once I load a map, I have to restart my computer to re-launch Sanctum 2 if I close the window. This issue only exists when my computer uses the 670M: if forced (or whenever the comp decides not to turn on the 670M) to use the Intel graphics the d3d9 error doesn't happen.

I've already tried:

¢ -windowed, -d3d11, -dxlevel 81, -dxlevel 90 in various combinations and alone in properties > gamelaunch options
¢ various resolution changes (I always get the error if my OS resolution is 1920x1080, but Sanctum launches (once) when I dial it back to 1280x768)
¢ running dotnetFx40, vcredist_x86_vs2010sp1, DXSETUP, windows update, and NVIDIA's driver updater
¢ verifying game cache
¢ updating drivers via 3dp Chip
¢ restarting / killing Steam
¢ clean installing, then uninstall/reinstalling, then using Display Driver Uninstaller on the 670M driver
¢ changing bSmoothFrameRate from true to false in sanctum/sanctumgame/config/sanctumengine.ini
¢ changing bInitializeShadersOnDemand from false to true in sanctum/sanctumgame/config/sanctumengine.ini

I'm on a Sager NP9130:
¢ i7 3610QM
¢ 8 GB RAM
¢ NVIDIA GTX 670M
¢ Win 7 Pro

Interestingly, L4D2 also throws a d3d9 error if I've started up Sanctum 2 in the same boot.

Any ideas would be appreciated :3
Last edited by Tai; Apr 29, 2014 @ 1:08pm
Showing 1-5 of 5 comments
< >
AceOfAces Apr 22, 2014 @ 2:41pm 
Can't help that much, but I'm suspecting that NVIDIA Optimus (or your power settings if there isn't availabe) may not switched to the NVIDIA Card. Assuming that it is supported, try to edit the Optimus settings (I don't own a laptop with dual GPU config. You better use GeForce Experience app). I'm telling this since a friend of mine had issues with a Dell laptop which had an AMD Radeon HD8XXX card and Intel Core i5 (4th generation) which in many games (at least when running at the first time) had FPS below 10.

Do you mind to post the dxdiag report so I (and others) can have a better idea? Open it up by typing on start menu's search bar "dxdiag" and on the new screen click on save all to save it. It will be a txt file.
Tai Apr 22, 2014 @ 3:49pm 
The Optimus thing had a little merit since my computer was running sanctumGame.exe on the intel graphics by default, but setting it to always run on the NVIDIA card didn't help. My FPS is excellent when I do get in Sanctum, even with settings mostly on high.

Here's my dxdiag: http://pastebin.com/j6aLLybh

AceOfAces Apr 23, 2014 @ 4:38am 
Try to clean install both GPUs drivers (uninstall and install).

https://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Laptop+graphics+drivers&ProductProduct=3rd+Generation+Intel%C2%AE+Core%E2%84%A2+Processors+with+Intel%C2%AE+HD+Graphics+4000 <- Drivers for Intel HD Graphics 4000

Before that, have the OEM drivers in handy should this fail.
Last edited by AceOfAces; Apr 23, 2014 @ 4:43am
Tai Apr 29, 2014 @ 8:57am 
Clean installed, then uninstalled/reinstalled, and tried Display Driver Uninstaller - none of these worked. Also tried beta drivers.

Started looking into it, the problem only exists when the 670M kicks in. The intel graphics can handle things without throwing d3d errors, but my temps/fans skyrocket and performance suffers.

AceOfAces Apr 29, 2014 @ 1:47pm 
1. It's obvoious that Intel's GPU will cause it to overheat since they are intergrated to the CPU starting from the very first generation Intel Core.
2. The only thing I can recomend is to either set the NVIDIA GPU as the default one or tinger with the power options. Do a little search on Google, maybe you'll find the answer.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Apr 22, 2014 @ 6:31am
Posts: 5