7Lava Oct 10, 2012 @ 5:24am
Problems with connection or punkbuster?
Started playing this game in the open beta, loved it but stopped due to constantly going back to the logon screen mid-game with the message 'lost connection to server'. Someone told me this was a common problem caused by punkbuster, but had no idea how to fix it. So I've come back after a long break hoping this issue would have been resolved by now, but no, after about 3 mins in game I get kicked back to the logon screen. Does anybody know how to fix this?
Showing 1-6 of 6 comments
< >
TBAGtv Oct 10, 2012 @ 10:44am 
Get a better pc?
7Lava Oct 10, 2012 @ 3:38pm 
Awesome. Cheers you've been a big help, but just for arguments sake lets say it's running smoothly in 1920x1080 with all options on their high settings (as with every other game I play) and I get a ping around 25-50. I don't think it's beyond my PCs limits. I suppose I should try dropping the settings right down though just to rule that out.
Vermin "Verminium" Supreme Oct 10, 2012 @ 3:55pm 
You can maybe update punkbusters from http://www.evenbalance.com/index.php?page=pbsetup.php then get the windows version. Add BL:R to the game list and then navigate to it's install directory. (C:\Games\Steam\steamapps\common\blacklightretribution) or something similar by default then click update.
It should be v2.293 after updating.
Last edited by Vermin "Verminium" Supreme; Oct 10, 2012 @ 3:56pm
7Lava Oct 10, 2012 @ 5:12pm 
Yeah, I tried that once before, didn't solve it. I've done it again anyway and it seems to have worked this time. Cheers.
Vermin "Verminium" Supreme Oct 12, 2012 @ 1:16am 
Originally posted by 7Lava:
Yeah, I tried that once before, didn't solve it. I've done it again anyway and it seems to have worked this time. Cheers.

Always happy to help! I've had this problem in other punkbuster based games as well, it was very annoying trying to get it fixed until the released this updater tool.
/dash Apr 26, 2013 @ 9:55pm 
I need some help, I've done what you've said Vermin and it still makes me keep losing the connection.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Oct 10, 2012 @ 5:24am
Posts: 6