Darknoodles Apr 6, 2013 @ 5:36pm
Xbox controller going crazy
My problem is that every button on my xbox controller are gone crazy
It seems that X became B, A became Y and so on, and i have to shoot with Start button, and that's for sure unplayable that way.

I noticed that i had this problem since i reinstalled windows, but i have not problem with other game, and i tried desinstalling reinstalling SSZ and also deleting config files, but it didnt fix :(
Showing 1-15 of 24 comments
< >
RandomTiger Apr 8, 2013 @ 4:35am 
Is this a 360 or xbox 1 controller? Make sure its set to a joypad and not joystick in the options menu.
Darknoodles Apr 8, 2013 @ 4:39am 
360 and it's set to gamepad, but it doesnt change anything :( tried every input mod also
Baldrickk Apr 8, 2013 @ 6:04am 
You could just remap all the buttons correctly / to your preference - it's there in the settings menu.

Sounds odd that the key mapping would just change like that, is someone playing a practical joke on you?

On the other hand...

If the controller is the problem (in other games etc too) have a go uninstalling the gamepad and re-installing the drivers again. If the driver has had it's config mixed up this could fix it.

Have a look in the game-controllers settings panel (in Windows) and see if the buttons match up to the correct response.
Darknoodles Apr 8, 2013 @ 6:55am 
I tried in every game supporting controller, and it works perfectly. In SSZ the problem is right from the start, and i tried to change control but it seems like overwriten, and i cant change the menu binding.

Here is the message i sent to SSZ group on facebook:

"Hi SSZ team.
I'm sorry to write you here but i have not found official forum, and nor an answer to my question on google, and have no response on steam.
I can't play strike suit zero anymore because it seems the controller inputs are corrupted. B becam X and A became B, so right in the menu it becomes a bit weird but it's worse ingame. I tried to uninstall-reinstalling the game, xbox controller drivers, putting it in another usb port, reverting SSZ settings to default, editing xml files, but on the last one, everything seems correct.

So my only hope is to cross the finger for this to work, and deleting the game saves, but i really dont want to restart from the beginning. So i contact you guys to know if you have a solution.

Best regards"
Last edited by Darknoodles; Apr 8, 2013 @ 6:55am
Baldrickk Apr 8, 2013 @ 6:29pm 
'official' forum is the steam one, they don't have one of their own.
The support email is support@bornreadygames.com

You can't change the key bindings in game? very odd...
Darknoodles Apr 9, 2013 @ 3:49am 
Even if i can change the keybinding in game, i would have to remap the whole controller, and it wont affect the binding for the menu, as their is no binding option for the menu.
I however watch inside the xml, and all the button were writen as their original function... but once the game is launched...
Darknoodles Apr 10, 2013 @ 6:13am 
Problem fixed, i desinstalled xbox controller's driver a second time, and this time it worked... Weirdest behavior ever ^^
Thanks anyway for your help
Baldrickk Apr 10, 2013 @ 7:11pm 
no problem. good to know you've fixed it
Darknoodles Apr 28, 2013 @ 2:44am 
The problem came back, so i retried the "fix" previously done but this time it doesnt work...
Also tried to switch usb port, unplug my G13 and my TrackIR to see if they were conflicting, also uninstalled TrackIR drivers, but didnt fix that. Tried to rollback controller driver - nothing.
And i dont find anything on google similar to me.
So i will have to play with keyboard and mouse (not a big problem) but as it also occure on trackmania, it sure is device or device driver related, and may occure in another game i may have not played since this problem arrived.

I really need help this time :-/
Baldrickk Apr 28, 2013 @ 2:16pm 
if it happens in another game, then it probably isn't a problem with this game... Does anyone you know have a controller you can borrow and test with?
you did the right thing by unplugging other controllers as this can have an effect. unplug everything that isn't needed as there could be some driver (or even bus level conflicts causing packet corruption) and give it another go.

good luck
Darknoodles Apr 28, 2013 @ 2:47pm 
I thought about borrowing a controller, and also i try to find a way to totally remove the drivers even from registry but found nothing.
I doubt it is hardware side as the problem appeared when i reinstalled windows, but i'll give it a try, it cost nothing.
takashi_K May 29, 2013 @ 2:47am 
The same thing he's talking about happens on mine as well, both in Strike Suit Zero, and Strike Suit Infinity. The same wrong button mapping that the original poster mentioned.

It does NOT happen in other games, every single other game that supports the 360 controller works perfectly, only when I try to play Strike Suit Zero (or Infinity) does this aweful wrong-remapping happen.

Developers, please do something about this. Just as with this other customer, removing and reinstalling both the game and the controller drivers has had no effect.
Stanith  [developer] May 29, 2013 @ 3:00am 
Could you drop us an email at support@bornreadygames.com explaining the problem please? Someone on our team can hopefully figure out what's going on.
takashi_K May 29, 2013 @ 4:17am 
Ok, wierdly, removing Comodo Internet Security (my Firewall/Antivirus program) and replacing it with just Comodo Firewall seems to have solved the issue. I thought to try this after doing some pretty extensive google searching. I noticed that even though the issue was only occuring for me in SSZ, other players were having the issue universally. Some of them mentioned that removing Comodo solved it.

So, presumably there's some kind of driver conflict going on between the 360 controller drivers for Windows and the drivers that Comodo Internet Security uses.
Darknoodles May 29, 2013 @ 4:36am 
Ha, you stated a good point, i got this issue since i reinstalled windows, and had the genius idea to install an antivirus. And that one is also Comodo. But the weird thing compared to you is that it works well with SSI. Did you have to completely remove (uninstall comodo) or just turned it off ?
Showing 1-15 of 24 comments
< >
Per page: 15 30 50