Anthony817 Apr 2, 2014 @ 10:13am
Windows 8.1 Pro 64 Bit
I had problems running the game. I couldn't even start it at all until I went to the exe folder and ran in Windows XP Service Pack 3 compatibility mode and I ran as admin just for good measure.

Just a heads up folks.

I also had to disable Steam Overlay as well and also verify game integrity.
Showing 1-2 of 2 comments
< >
MrHanMan Apr 8, 2014 @ 9:52pm 
I'm running Windows 8.1 Pro x64, and I didn't have to do any of that. It ran normally from steam with the overlay on.
Kim Wong Dong Apr 12, 2014 @ 7:52pm 
Potatoe
Showing 1-2 of 2 comments
< >
Per page: 15 30 50