The Witcher 2: Assassins of Kings Enhanced Edition

The Witcher 2: Assassins of Kings Enhanced Edition

yuvi Aug 19, 2014 @ 12:17pm
won't start under linux, please help
I was very excited to see The Witcher 2 being ported to linux. So I bought it, but after installing, the main menu shows up and I click "launch game", and it crashes. It showed me an error report, and I sent it (details below), but I also thought of coming here and asking. I also saw I wasn't the only one having trouble with it, but the other threads don't have any useful information, so I'm opening a new post. I tried validating the game cache but that didn't help.

I have some experience in messing around with wine installations to make them work, and I'm not shy of using command line or whatever'll make it work.

I'm running Ubuntu 14.04.01 LTS 64-bit on a Dell Inspiron 3537 laptop, graphics card is AMD Radeon HD 8850M, and the computer has an Intel Core-i7 processor (if that means anything). Other steam products worked fine till now.

Anyway, here's the error report: (I tried including it here inside a code tag, but I guess the report was too long because there was some error. So here's a link instead[codeshare.io])
< >
Showing 1-11 of 11 comments
[VPLTD] Peter Mulholland  [developer] Aug 19, 2014 @ 1:48pm 
It looks as if the AMD Radeon is not being used - instead the Intel MESA driver is loaded.

Currently, the Intel driver is not really capable of running the game well, and you need a really up to date driver (ie, from http://01.org/linuxgraphics or via "oibaf" repository) to get the game to run at all.

It currently looks as if dynamic switching to the AMD GPU is not catered for under Linux...
yuvi Aug 19, 2014 @ 2:18pm 
So what do you suggest? Ask for a refund or wait for an update anytime soon? Will downloading the beta version of steam client help in anyway?
[VPLTD] Peter Mulholland  [developer] Aug 19, 2014 @ 4:33pm 
The game is not faulty in this case. Intel GPU's are simply not up to the job of running it, under any OS.

The best advice i can give you is to reconfigure your system so that the AMD GPU is being used.
yuvi Aug 19, 2014 @ 10:31pm 
But my system is using the AMD GPU (I checked "Additional Drivers" and also ran
lspci | grep VGA
and confirmed this). Are you sure the game is not at fault here for trying to use the wrong one?
Last edited by yuvi; Aug 19, 2014 @ 10:33pm
[VPLTD] Peter Mulholland  [developer] Aug 20, 2014 @ 2:26am 
what does "glxinfo" say?
yuvi Aug 20, 2014 @ 1:27pm 
Here's the output of "glxinfo": link[codeshare.io]
[VPLTD] Peter Mulholland  [developer] Aug 21, 2014 @ 1:41am 
Glxinfo also says that the Intel GPU is in use. Our game simply loads libGL.so and uses it - so whatever graphics driver is providing that is what will be used.
KiselXimik Aug 21, 2014 @ 1:59am 
3йыв
yuvi Aug 23, 2014 @ 2:45am 
So.... How can I provide libGL.so form the AMD GPU? Is there a package I can install that will fix it?
Edwin Aug 23, 2014 @ 5:59am 
It's not quite that simple. If you have a newer system that won't allow you to disable the integrated cpu, then the system must be told by software to use the discrete GPU for rendering. For NVIDIA/Intel hybrid systems the Bumblebee/Optirun project achieves this. I have read that this project was also aiming to support AMD GPUs, but I'm not entirely sure what the status is. There may also be other solutions, but since I don't need it, I don't know everything about it.

To summarise, getting your AMD GPU to work will require a bit of research.
mrmangosir Aug 24, 2014 @ 11:40pm 
One other thing, check your Bios. Sometimes you can swich off Intel graphics and tell it to use your AMD instead. Otherwise you may struggle.
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Date Posted: Aug 19, 2014 @ 12:17pm
Posts: 11