Sparta 5 nov, 2013 @ 12:26pm
Direct3D Device::Present Failed (Device removed): DXGI ERROR DEVICE HUNG
Is anyone else getting this error? It seems to be totally random. It can happens 2 minutes or 30 minutes into a game.
Visar 1-13 av 13 kommentarer
< >
Minion [VTG] 10 nov, 2013 @ 12:05pm 
I have the same problem. I dropped my refresh rate to 60hx, and that helped a little, but I
m still getting the error later in the game.
Satoru 10 nov, 2013 @ 12:31pm 
What are your system specs
Minion [VTG] 10 nov, 2013 @ 2:50pm 
I tried this on GTX 580 card and it got me through the single player mode with very few crashes.

Hi all,

I was getting the same error, until I made a few changes.

1. Go to Options >> Video Options >> Optimal Video.
2. Go to Options >> Video Options >> Advanced >> Set refresh rate to 60Hz.
Also, in the same menu, set terrain detail to "OFF".

3. If you are running MSI Afterburner, make sure it is closed. I had to install MSI Afterburner due to the last COD development nightmare that came out last year.

(There were some overlclock settings in there that could get you around the black ops 2 freezes. Apparently, it's a liability for this game just by running it.)

4. Download and install a clean version of Direct X.
http://www.microsoft.com/en-us/download/details.aspx?id=35

My game still crashed a few times, but nothing like before I made these changes.
The fact that minor teaks of the audio/visual settings can get you through the gaming experience, but still not achieve consistent results means that this game was not thoroughly tested by the developers. For a game of this magnitude to not be able to run on a high-end Nvidia card for 2 years in a row is unacceptable. I know that not all problems can be accounted for, but these show-stopping errors are not emblematic of a professional outfit.
Satoru 10 nov, 2013 @ 4:14pm 
Post your system specs
Rabidpanduhs 18 nov, 2013 @ 12:35pm 
I FOUND A FIX. ******************FIX*****************

Follow my steps and it should work, because I tried EVERYTHING and it's finally running perfectly.

1) Restart your computer.
2) Go to Command Prompt and RUN AS ADMINISTRATOR. Then type in: bcdedit /set increaseuserva 4000. Then Restart
3) Download MSI Afterburner. Unlock voltage control in settings, and slightly increase, and then DECREASE (Yes, underclock) the other two. Restart.
4) Disable your antivirus completely. Avast I believe is the source of the problem.
5) Once you can get your game up and running to atleast the settings, change Ambient Occlusion to HBAO+, SYNC EVERY FRAME (Put the check), and change your monitor refresh rate to 60Hz if not already there. Then turn off terrain detail and anti aliasing completely.
6) While in game, ALT+TAB to go to task manager, and set the priority to NORMAL, not high.
7) A clean directx install never hurts.

I even reloaded my entire OS trying to fix this son of a ♥♥♥♥♥, but once I did all of these steps, I no longer crash halfway through a round. I don't know which specific one fixed it, so do them all. You're welcome to anyone who finds this useful!!!:D

I haven't crashed yet so good luck to everyone who can't find a fix that works for them!
✶Ninja✶ 18 nov, 2013 @ 12:53pm 
crashing OP...
Senast ändrad av ✶Ninja✶; 18 nov, 2013 @ 12:53pm
Fuzzy Dunlop 2 dec, 2013 @ 11:16am 
Exact same problem;

Ive tried the Latest AMD Beta Drivers and now im on the 13.9 catalyst drivers it hasnt crashed yet (touch wood) its ruined the game for me and io only wish i had never bought the game in the first place. It has constsalty crashed since i bought it.

Specs:
Amd FX 4350 Quad Core 4.2 ghz
Amd Radeon 6870 i gig
8 gigs DDR3 Ram

Senast ändrad av Fuzzy Dunlop; 2 dec, 2013 @ 11:22am
Firulo 2 dec, 2013 @ 11:27am 
thank you tmoore.prof!
just I try steps 4 and 5
and also play disconnect from steam and turn off the wifi in my notebook.
Also, few minutes later, after playing, I increased the AA and everything runs ok!

Ursprungligen skrivet av tmoore.prof:
I FOUND A FIX. ******************FIX*****************

Follow my steps and it should work, because I tried EVERYTHING and it's finally running perfectly.

1) Restart your computer.
2) Go to Command Prompt and RUN AS ADMINISTRATOR. Then type in: bcdedit /set increaseuserva 4000. Then Restart
3) Download MSI Afterburner. Unlock voltage control in settings, and slightly increase, and then DECREASE (Yes, underclock) the other two. Restart.
4) Disable your antivirus completely. Avast I believe is the source of the problem.
5) Once you can get your game up and running to atleast the settings, change Ambient Occlusion to HBAO+, SYNC EVERY FRAME (Put the check), and change your monitor refresh rate to 60Hz if not already there. Then turn off terrain detail and anti aliasing completely.
6) While in game, ALT+TAB to go to task manager, and set the priority to NORMAL, not high.
7) A clean directx install never hurts.

I even reloaded my entire OS trying to fix this son of a ♥♥♥♥♥, but once I did all of these steps, I no longer crash halfway through a round. I don't know which specific one fixed it, so do them all. You're welcome to anyone who finds this useful!!!:D

I haven't crashed yet so good luck to everyone who can't find a fix that works for them!
Slotcar 2 dec, 2013 @ 1:00pm 
Are people sure that the fixes suggested are not just temporary? I find that if I do a "Verify integrity of game cache" via steam, the crashes stop for an hour or so, which could lead me to beleive that it was fixed until it once again started crashing.
rayminator 18 nov @ 5:46pm 
i had the same problem i was getting this direct3d device: present failed: dxgi_error_device_hung -2005270523

if you had of look in the window event lops you would of seen this

Faulting application name: iw6sp64_ship.exe, version: 1.0.0.1, time stamp: 0x542b2dc4
Faulting module name: d3d11.dll, version: 6.3.9600.17041, time stamp: 0x5318189b
Exception code: 0xc0000005
Fault offset: 0x00000000000f7274
Faulting process id: 0x1b4c
Faulting application start time: 0x01d0033d545c7fa6
Faulting application path: D:\Steam\steamapps\common\Call of Duty Ghosts\iw6sp64_ship.exe
Faulting module path: C:\Windows\SYSTEM32\d3d11.dll
Report Id: bbb880df-6f30-11e4-828b-54271e1af7d8
Faulting package full name:
Faulting package-relative application ID:

downgrade your video card driver

it is the video card that causes the error
Senast ändrad av rayminator; 18 nov @ 5:47pm
kimianks 19 nov @ 11:11am 
Still having the Problem..Stuck at the End of the Line mission when you take a left turn. Sometimes get the Fatal Error sometimes it stops working. Tried a host of fixes including driver rollback. Game Cache Verified too. Please help.

Specs : Intel Core i7-4710MQ, 16gb DDR3, GeForce GTX880M
Senast ändrad av kimianks; 19 nov @ 11:12am
ShinobiXplay 20 nov @ 1:05pm 
Eu também estou no mesmo lugar que você por favor alguem nos ajude!
Ursprungligen skrivet av kimianks:
Still having the Problem..Stuck at the End of the Line mission when you take a left turn. Sometimes get the Fatal Error sometimes it stops working. Tried a host of fixes including driver rollback. Game Cache Verified too. Please help.

Specs : Intel Core i7-4710MQ, 16gb DDR3, GeForce GTX880M
SEHUN 21 nov @ 9:36am 
Ursprungligen skrivet av kimianks:
Still having the Problem..Stuck at the End of the Line mission when you take a left turn. Sometimes get the Fatal Error sometimes it stops working. Tried a host of fixes including driver rollback. Game Cache Verified too. Please help.

Specs : Intel Core i7-4710MQ, 16gb DDR3, GeForce GTX880M

me to;; End of the Line mission i can't pley game 팅김 하;;; 빡친다
Senast ändrad av SEHUN; 21 nov @ 9:38am
Visar 1-13 av 13 kommentarer
< >
Per sida: 15 30 50