Froztiez Oct 25, 2013 @ 12:31pm
Shiva's Test of Worth. I am stuck
So I just got to where you meet Shiva and get her "most wanted" missions. The first one you receive is called Shiva's Test of Worth and in it yo have to save an innocent man. So I go over where the mission is and enter the building the man is inside. I find him hanging over a tiny pool of water with electrical current running through it. I find out how to solve the puzzle, you have to do something to these fuse looking boxes, but I couldn't do anything to them. I figured you needed a gadget for them, cause I couldn't do anything to them, batarangs and detonators did nothing. So I tried to leave since it was obvious that I couldn't solve this puzzle until after I got some other gadget. But when I try to leave the door is locked and I can't leave.

I've tried restarting to last checkpoint, but that puts me inside the building again. I've reopened the game many times, still no luck. So does anyone know if I can get out without deleting my save or if the puzzle doesn't need a gadget and I'm just missing something.
Showing 1-7 of 7 comments
< >
M I Abrahms Oct 25, 2013 @ 1:31pm 
I think you're supposed to be able to fly the Remote Control Batarangs over the electricity in the pool to charge them up so they can smash the fuse boxes. Unfortunately, this isn't working right now. The RCBs either fly over the water and do nothing, or hit the water and stop flying.

Also, I'm kind of curious about the Remote Grapnel anchors, if they're supposed to do anything and why I can't hit them.
kangstakangsta Oct 25, 2013 @ 3:53pm 
Here's what you do. Look at the police officer. From there look left and use you grapel hook to climb. You should notice that one of the metal grates is broken at the bottom. Climb under and the rest should be obvious.
Spawk Oct 25, 2013 @ 4:02pm 
It took me forever to find that small opening in the gate. They could have used some subtle lighting to indicate that that was a place of interest. The level design is nothing like the other two games. Sometimes you have no idea where you're going or what it is that the game wants you to do.
Credwink Oct 25, 2013 @ 4:17pm 
I made a post with a video on how to do it since there were alot of people that couldn't figure it out.
Froztiez Oct 25, 2013 @ 9:17pm 
Oh! You have to destroy it? I thought you had to use a gagdet or something, I swear that "Destroy" option has literally not come up, I'm going to check it now. I knew you could come up there I was swinging around on the rope between those two rooms for like forever, hopefully I can contiune now, thanks.
sambo.exe Oct 25, 2013 @ 9:33pm 
Go through the cracked fence, interact with the mechanism to destroy it, and prepare for ninja assassin ambush! Then remote claw to the other one and repeat.
Zemenco Oct 26, 2013 @ 5:16pm 
So after entering the ninja assassin ambush room, there's a piece of grate/gate/bars that falls down to lock you in. I am unable to remove it after the fight and also unable to lock on to the remote anchors. Stuck in the room. Reloading does not solve it.

So I just realized I am an idiot. Apparently you don't have to lock 2 points for the remote claw to function.
Last edited by Zemenco; Oct 26, 2013 @ 5:24pm
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Oct 25, 2013 @ 12:31pm
Posts: 7