Johnny Del Monte Oct 25, 2013 @ 6:49am
[SOLVED] Very Low FPS
I have been attempting to play the game since the release but my FPS is extrememly low. I only get around 14 fps during the pre-menu introductions. On the menu I get around 120 fps, but when I go to play the campaign, the framerate drops to 4 to 6 fps and never goes back up. I have tried reinstalling the game and even dropping graphics settings to the lowest. I know my PC is more than strong enough to handle this game, but I cannot figure out what is wrong. I am using an AMD Vishera 8350 processor at 4.0 GHz and running two Radeon HD 7970 video cards. I turned off PhysX since there is usually conflict between AMD and Nvidia's Advanced PhysX but still nothing. Can anyone please help me out?
Last edited by Johnny Del Monte; Oct 25, 2013 @ 1:44pm
Showing 1-13 of 13 comments
< >
LuMooo Oct 25, 2013 @ 6:49am 
Johnny Del Monte Oct 25, 2013 @ 7:05am 
Originally posted by LuMooo:
http://steamcommunity.com/app/209000/discussions/0/792924952458927648/
read up on drivers and DX 11 issues

LuMoo, I read the link you sent me and I went into the games BMEngine.ini file and set the setting AllowD3D11 to False. FPS is back up during intros and around 30 during gameplay. I will tweak with the graphics settings a bit to see if I can get it up to at least 60 fps. Thank you very much for that link!
kbclaudio Oct 25, 2013 @ 8:26am 
Hi! I'm italian, sorry for bad english!
I have the same problem!!! Set allowD3D11 to false, but still low fps :S
I run arkham city at 40 fps, how is it possible? Origins run at 18-20 :S
Johnny Del Monte Oct 25, 2013 @ 10:18am 
Originally posted by kbclaudio:
Hi! I'm italian, sorry for bad english!
I have the same problem!!! Set allowD3D11 to false, but still low fps :S
I run arkham city at 40 fps, how is it possible? Origins run at 18-20 :S

I'm not sure. I dropped all the graphics settings as low as they will go and starting getting 60 fps until I encounter a fight or a boss and then the framerate drops dramatically again. I had to rage quit because it was irritating me so badly. I have barely made it past the first mission and have already encountered numerous bugs and glitches.
Rap Game Wesley Snipes Oct 25, 2013 @ 12:59pm 
I have a similar setup (fx 8350 and 3 radeon 6970s) and was getting the exact same problem as you. 6-9fps in dx11 (until the game crashed), and around 15-30fps in dx10. I saw a few other topics with the same issue as well and noticed the one thing we all had in common was amd crossfire.

After disabling crossfire, I get 70-120fps on a single 6970 with the max dx10 settings. It's not really a true fix but it makes the game completely playable.
Johnny Del Monte Oct 25, 2013 @ 1:28pm 
Originally posted by Rap Game George Lopez:
I have a similar setup (fx 8350 and 3 radeon 6970s) and was getting the exact same problem as you. 6-9fps in dx11 (until the game crashed), and around 15-30fps in dx10. I saw a few other topics with the same issue as well and noticed the one thing we all had in common was amd crossfire.

After disabling crossfire, I get 70-120fps on a single 6970 with the max dx10 settings. It's not really a true fix but it makes the game completely playable.

Really? I never thought of Crossfire being the issue. I will try this and let you know how it works for me.

Vit Oct 25, 2013 @ 1:31pm 
Try these latest beta drivers ( They were just posted a few hours ago ): http://www.overclock.net/t/1437010/amd-catalyst-13-11-beta-6

It fixes Arkham Origins scaling apparrently.
Johnny Del Monte Oct 25, 2013 @ 1:42pm 
Originally posted by Rap Game George Lopez:
I have a similar setup (fx 8350 and 3 radeon 6970s) and was getting the exact same problem as you. 6-9fps in dx11 (until the game crashed), and around 15-30fps in dx10. I saw a few other topics with the same issue as well and noticed the one thing we all had in common was amd crossfire.

After disabling crossfire, I get 70-120fps on a single 6970 with the max dx10 settings. It's not really a true fix but it makes the game completely playable.

Alright, I disabled Crossfire and it is working like a charm now. It's lingering around 100 fps now. I tried reenabling DX11 but my framerate dropped back down to 20 or 30 so you have to keep the DX11 disabled as well as the Crossfire. Thank you very much for the help!
Johnny Del Monte Oct 25, 2013 @ 1:42pm 
Originally posted by Vit:
Try these latest beta drivers ( They were just posted a few hours ago ): http://www.overclock.net/t/1437010/amd-catalyst-13-11-beta-6

It fixes Arkham Origins scaling apparrently.

And I will look into these for good measure. Thank you very much for your help!
Johnny Del Monte Oct 25, 2013 @ 2:13pm 
Ok, so here is what all I did to fix the issue I was having
1) Find your BMEngine.ini file, scroll down to the AllowD3D11 setting, delete TRUE and type in FALSE
2) I disabled Crossfire like Rap Game George Lopez above said and it worked perfectly. But then I downloaded the beta driver given by Vit above and now the game works perfectly with Crossfire enabled

A huge thanks to everyone on this thread who helped me with this issue. Your help was greatly appreciated!
Vit Oct 25, 2013 @ 2:46pm 
Good to hear!
JD2319 Oct 28, 2013 @ 2:25pm 
Originally posted by Vit:
Try these latest beta drivers ( They were just posted a few hours ago ): http://www.overclock.net/t/1437010/amd-catalyst-13-11-beta-6

It fixes Arkham Origins scaling apparrently.

I'm using the Cat13.11b6 drivers, and I have the same cripplingly slow fps during cutscenes when I run in Crossfire mode with my 7950's. If I disable Crossfire I can run on a single 7950 and it's nice & smooth, even with all the DX11 features turned on(sticking to FXAA though, MSAA brings the framerate down a bit too much for me). Not sure what sort of framerates I'll get when the action gets crazy, I haven't played very far yet(too busy working my way through the Assassin's Creed franchise in preparation for Black Flag), but from my experience it appears the performance issues with the opening credits and the cutscenes is more related to Crossfire than to DX11. I tried setting the Crossfire mode to AFR-Friendly and 1x1 Optimized, with no help. I may try setting it to use the Arkham City profile, just in case that helps. Thankfully it appears a single 7950 can play the game pretty well. Despite the graphical improvements, the engine seems like it might be more optimized than Arkham City's.
Johnny Del Monte Oct 29, 2013 @ 1:13am 
Originally posted by JD2319:
Originally posted by Vit:
Try these latest beta drivers ( They were just posted a few hours ago ): http://www.overclock.net/t/1437010/amd-catalyst-13-11-beta-6

It fixes Arkham Origins scaling apparrently.

I'm using the Cat13.11b6 drivers, and I have the same cripplingly slow fps during cutscenes when I run in Crossfire mode with my 7950's. If I disable Crossfire I can run on a single 7950 and it's nice & smooth, even with all the DX11 features turned on(sticking to FXAA though, MSAA brings the framerate down a bit too much for me). Not sure what sort of framerates I'll get when the action gets crazy, I haven't played very far yet(too busy working my way through the Assassin's Creed franchise in preparation for Black Flag), but from my experience it appears the performance issues with the opening credits and the cutscenes is more related to Crossfire than to DX11. I tried setting the Crossfire mode to AFR-Friendly and 1x1 Optimized, with no help. I may try setting it to use the Arkham City profile, just in case that helps. Thankfully it appears a single 7950 can play the game pretty well. Despite the graphical improvements, the engine seems like it might be more optimized than Arkham City's.

Yeah I came to discover that even after disabling Crossfire, I reactivated DX11 and the game still runs perfectly... even with my anti aliasing set to the highest MSAA setting. So one of my 7970's by itself still dominates this game on max graphic settings lol.
Last edited by Johnny Del Monte; Oct 29, 2013 @ 1:14am
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Oct 25, 2013 @ 6:49am
Posts: 13