fgt Mar 11, 2013 @ 8:48pm
I put everything on high and it still looks ugly
The textures look like ♥♥♥♥ and theres no LoD whatsover, and i have everything on high, it looks horrible. I would put a screenshot but I cant since when i try steam crashes and i have to reboot the PC, this is driving me crazy, need help, i have Windows 8 pro legitimate, and i have a good rig, I can run Tomb Raider with Tressfx on, everything on ultra except fro SSAA which I had on 2x.
Showing 1-15 of 16 comments
< >
Rodragus Mar 11, 2013 @ 10:57pm 
You do realize The Witcher came out 6 years ago right?
fgt Mar 11, 2013 @ 11:15pm 
no no, you dont understand i know it came out on 2007 and ive been watcghing videos and it doesnt look ugly, in my pc its like the game ignores what i put it on like textuyre filtering 16, high quality textures (not at all). it completely ignores and looks but ugly. and for eample the the first scene the trees looks disastrous, cant take a screenshot because it crashes, when i save it crashes, dont know whats going on.
fgt Mar 11, 2013 @ 11:16pm 
the trees dont look likethey dont have branches
Ragnarök Mar 12, 2013 @ 1:46am 
Do a manual screenshot. Hit your Print Screen key and then open up paint and push CTRL+V.
Save the file as whatever. Go to Imageshack or TinyPic and upload the screenshot. Post the direct link in here.

I'm willing to put money that Windows 8 is the problem here.
Seseorang Mar 12, 2013 @ 4:48am 
What are your computer specifications? You could be using driver software to conflict with in-game settings.
fgt Mar 12, 2013 @ 7:15am 
Well I have an HD 7870, Intel i7 3770k. This also happened with Mass Effect, put everything on max, but it semeed the textures al blured and no details whatsoever, ugly as ♥♥♥♥ and I know they dont look that ♥♥♥♥ty. Also the texture of the icon to attack someone when you have the OTS camera with TWEE appeared very low resolution, very pixelated, couldnt see anything until i put the High Isometric cmera.


I dont know why this is happening to me? Could it be Windows 8 ? I bought it in the promo Microsoft had, it was verycheap so.

Also, the digital comic that came with the Enhanced Edition? It looked very low res, really low resolution, couldnt see ♥♥♥♥,.
Ragnarök Mar 12, 2013 @ 11:54am 
No way of knowing until you post a screenshot.
fgt Mar 12, 2013 @ 1:52pm 
Sorry thanks for the help, well i delete the witcher, im dowloading it again, but i just downloaded STALKER and this happened http://cloud-2.steampowered.com/ugc/903242769703644277/6085FF2622A5A59750EAEF731CC13AA7AC67208B/

i put everything on max, everything, seriously, why does it look liek this? This seems to happen with every old game I play, I dont know if its because of my Windows 8, but what could it be? Mass Effect 1 had this same thing too, seemed like there were no textures at all, Witcher and also this too. What could it be?
CarlinFan Mar 12, 2013 @ 3:32pm 
What Motherboard/Chipset are you using?
How much RAM do you have?
Are ALL your drivers up to date?
Are you sure the games aren't using the CPU's integrated GPU instead of your radeon?

Are there any games that work properly? I mean, you told us you could run TR on ultra, but how well does it run?
fgt Mar 12, 2013 @ 7:08pm 
It runs perfectly well. Look at my screenshots, I have tressfx put on with 2x Super Sampled AA and it runs at 40-50 fps. Im sure the games are using the GPU and not the IGPU since I wouldnt be able to run TR or Hitman at those settings and those games are really heavy on graphics.

My Catalyst driver is up to date, I dont really know which more drivers I should be checking and HOW to check them. The one from my MOBO is up to date that I can assure.

I have 16GB of DDR3 Ram at 1600mhz. My Motherbord is an ASUS p8z77-m pro.

This only seems to happen with kind of old games, like Stalker, Witcher and Mass Effect.
fgt Mar 12, 2013 @ 7:26pm 
This is a picture of the Witcher, everything on max in my PC http://i.imgur.com/Lcc15uR.jpg
CarlinFan Mar 13, 2013 @ 6:10am 
Good Lord!

It's... I'm... I don't know what to say, really.

Originally posted by Amadeus:
Im sure the games are using the GPU and not the IGPU since I wouldnt be able to run TR or Hitman at those settings (...) This only seems to happen with kind of old games, like Stalker, Witcher and Mass Effect.

Well, I don't know if that's even possible, technically, but maybe it's just the old games going for the IGPU. Just to be on the safe side, have you tried disabling the IGPU in the BIOS?

Originally posted by Amadeus:
The (driver) from my MOBO is up to date that I can assure.

Allright.

Originally posted by Amadeus:
I have 16GB of DDR3 Ram at 1600mhz. My Motherbord is an ASUS p8z77-m pro.

Doesn't sound problematic either. :)

Since it happens to different games on different engines, I really doubt that each individual game is to blame. There just has to be an underlying general problem. Maybe you'd get more feedback by posting in the 'Help & Tips' discussion board?
KiRA Mar 29, 2013 @ 10:07pm 
I guess the older games find it hard to support Windows 8 thats all
fgt Mar 29, 2013 @ 11:32pm 
No i fixed it i had to reinstall Windows but now it looks ok
3Dawg Mar 30, 2013 @ 3:42am 
Windows 8 Pro 64bit, game looks fine here. Doesn't look great (it's old) but certainly much much better than your screenshot :P Even with LOD set to high, shadows under objects don't load until you walk close to them.
Last edited by 3Dawg; Mar 30, 2013 @ 3:42am
Showing 1-15 of 16 comments
< >
Per page: 15 30 50
Date Posted: Mar 11, 2013 @ 8:48pm
Posts: 16