Star Wars: Knights of the Old Republic II
Quitch Oct 26, 2012 @ 12:20pm
Works with Windows 8?
The Windows 8 compatibility site has two votes saying it works and two saying it doesn't, but no comments to help me judge. Anyone tried?
Showing 1-7 of 7 comments
< >
Wompdevil Oct 27, 2012 @ 10:05am 
I have the disc version with the restored content patch installed and since I have upgraded from windows 7 to windows 8 I can not get it to run. It will load up the launch menu but once it tries to boot up the game it just blacks out my desktop without launching the program. The same thing happens when I try another old game, Neverwinter Nights. I have not tried reinstalling the games however plus I don't have the steam version of either of those two games so I don't know if it is unique to the disc versions or not.

Both are running with admins right and under windows xp sp3 mode which is what I had to do to get them to run under windows 7 correctly. I tried unchecking those boxes to no avail. When I try reinstallation I will let you know if I have any luck then. Hopefully someone with the Steam version of this game can chime in for you. I was kind of expecting this with a new OS so if reinstalling doesn't work I might just have to wait until either an OS update or someone comes out with a work around like back in the XP -> Vista/Windows 7 days
rochaeliseo Nov 13, 2012 @ 4:18pm 
I'm running Windows 8 developer preview and the game works fine for me. I have the latest Restored Content mod 1.81 running also. I don't have anything on for the compatibility mode either.
halo32 Nov 17, 2012 @ 6:14pm 
I have the disk version with no mods installed and I can't get it to load past Obsidian. Even in XP SP3 and 7 Compatibility mode it still doesn't go any farther.
Quitch Nov 18, 2012 @ 10:11am 
I bit the bullet and went for it. Was able to start the game and load my save without any special settings.

That's with the Steam version and Restored Content Mod 1.8.1
loz.neo Nov 27, 2012 @ 11:39pm 
I've recently upgraded to Windows 8 and I cannot get it to work either. I launch it from either a shortcut or through the Steam library, and the screen goes blank and shows the message "Star Wars: Knights Of The Old Republic II has stopped working. Windows will check for a solution and notify you if one is available." Looks like I'll have to install that mod to get it working...
Revelator Nov 28, 2012 @ 8:40am 
on my win 8 64 bit works fine
bmaninbama Dec 2, 2012 @ 6:39am 
Have you updated your NVIDIA drivers (if your video card is NVIDIA)? That fixed all of my problems starting and playing the game under Windows 8.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Oct 26, 2012 @ 12:20pm
Posts: 7