Star Wars: Knights of the Old Republic II
Hassat Hunter Sep 9, 2012 @ 1:40am
Why are so many users here not using TSLRCM?
Assumption based of the large amount of "I am stuck at Telos Academy" threads. Isn't is great when patches add such gamebreaking bugs (it wasn't there in the original, but of course Steam users can't use that)...

So, why?
And as for having it hosted on Steam, haven't heard back from Valve about that. Probably never will... :(
Showing 1-15 of 38 comments
< >
|Mar1299| Sep 9, 2012 @ 8:27am 
it wouldn't work for me for some reason.
Hassat Hunter Sep 9, 2012 @ 12:57pm 
What's the problem?
turkybacon Sep 9, 2012 @ 4:09pm 
I WOULD play the Restoration Mod, but I don't know how to apply it to the game...
Will.S Sep 9, 2012 @ 4:51pm 
You shouldn't have to anyway. Re-releasing and selling a product that doesn't work is fraudulent in a sense.
Hassat Hunter Sep 9, 2012 @ 5:06pm 
What doesn't work?
Also, @turky; Just download the .exe from moddb, double-click it and follow the install instructions. You probably have to point it to where you installed KOTOR2 though.
Will.S Sep 9, 2012 @ 5:43pm 
@ Hassat Hunter; Just downloaded / installed it / followed all instructions. Hasn't made the blindest bit of difference. It goes - Lucas Arts - Obisidian - CRASH....every time.
jawzg Sep 9, 2012 @ 7:20pm 
I loaded the mod into the Steam path C:\Program Files (x86)\Steam\steamapps\common\Knights of the Old Republic II and it shows the mod loaded when the game starts and then I lost Keyboard. I could only use the mouse in the game. The game will launch without the mod on one machine, but will crash. I am not sure if it is random at this point.
kellyhelene Sep 9, 2012 @ 7:34pm 
I've been playing with the mod successfully. I've also got the game tweaked to run at 1920x1080, and in a borderless window since I have a dual monitor setup.
This is what I did (sorry.. this will be long, but I promise you, it will work).

In your steam library right click on the game, select properties, and on the second tab turn off auto-updates. So you don't have to redo this every time you play.

Download and install THIS: http://www.moddb.com/mods/the-sith-lords-restored-content-mod-tslrcm
*Sith Lords Restored Content Mod
Make sure it installs to your proper game directory, since the default is for the retail version, not Steam.

Download this and extract to your game directory (...steam/steamapps/common/Knights of the Old Republic II)
http://rapidlibrary.com/files/squizzy-kotor2-resolution-patcher-rar_ulzxben9zyi89on.html
It WILL overwrite your exe, save a backup somewhere. Run the "patcher" program and select your preferred resolution.

Open swkotor2.ini and confirm it updated correctly. It should look something like this:

[Display Options]
FullScreen=0 (You may have this as fullscreen=1. I'm running in borderless window since I have dual monitors)
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=1920 (Your resolution may vary...)
Height=1080
BitsPerPixels=32
RefreshRate=60

And then further down, confirm resolution again:

[Graphics Options]
Brightness=57
RefreshRate=60
Height=1920
Width=1080
V-Sync=1
Anisotropy=16
Frame Buffer=1
Anti Aliasing=8
Texture Quality=2
Grass=1
Soft Shadows=1
Shadows=1
EnableHardwareMouse=1
FullScreen=0
DisableVertexBufferObjects=1

Download this to fix the HUD aspect ratio and pop the file in your overide folder. You only need one, just grab whichever works with your native resolution.
16:9 https://img.wsgf.org/downloads/kotor2-16x9-hud.zip
16:10 https://img.wsgf.org/downloads/kotor2-16x10-hud.zip

If you have an Nvidia card, open Nvidia control panel (just right click on the desktop to get to it)
Under "manage 3d settings" set "Threaded Optimization" to "auto" This will prevent artifacts and keep the game from crashing when you try to load a save.

And finally, the first time you run the game have your task manager open. Toggle over to it while the game is running and right click on it in the processes tab. Select "set Affinity" and then make sure only ONE box is checked. It probably doesn't matter which, but it can only be one. That's telling your computer to use just a single processor core, without hyperthreading. Helps stability a lot.


OPTIONAL, if you want borderless window (such as if you have two monitors.)
Make sure FULLSCREEN=0 shows both times in the INI file.
Download AUTOHOTKEY: http://www.autohotkey.com/

Load this script as is, excluding the asterisks into autohotkey:
********************************************

^!f::
WinGetTitle, currentWindow, A
IfWinExist %currentWindow%
{
WinSet, Style, ^0xC00000 ; toggle title bar
WinMove, , , 0, 0, 1920, 1080
}
return
^!g::
WinGetTitle, currentWindow, A
IfWinExist %currentWindow%
{
WinSet, Style, -0xC00000 ; hide title bar
WinSet, Style, -0x800000 ; hide thin-line border
WinSet, Style, -0x400000 ; hide dialog frame
WinSet, Style, -0x40000 ; hide thickframe/sizebox
WinMove, , , 0, 0, 1920, 1080
}
return
****************************************************

Run the program and, when you're in game, toggle on the Steam overlay and hit alt-ctrl-f. That'll give you a reasonable approximation of a borderless window. (this works for almost any game that allows windowed mode, or can let you force windowed mode by changing the INI file. This borderless window fix also works with Bethesda games, which normally resist all forms of borderless window tweaking).


And you should be good to go!
Hassat Hunter Sep 10, 2012 @ 3:41pm 
@ 08081895: I had that with KOTOR. Removing the intro movies allowed me to pass. Worth a shot.
@ jawzg; Did you disable the automatic updates of the game?
turkybacon Sep 12, 2012 @ 3:28pm 
I did all of that, but I still can't seem to get the mod to work...
Hassat Hunter Sep 13, 2012 @ 5:05pm 
Could you give a step-by-step list of how you installed, and to which location?
dan360a47 Sep 16, 2012 @ 10:11am 
I originally downloaded the Mod from here http://www.moddb.com/mods/the-sith-lords-restored-content-mod-tslrcm and it did not install properly (first time ever playing KOTOR 2 so i didn't realise), when it crashed i uninstalled the game and tried reinstalling it still would not work.

So I tried a different site. I downloaded the mod (1.8) from here http://deadlystream.com/forum/files/ and its worked a charm could be worth a try.

Edit: If you download this version it says it's installed on the main menu so you can know for certain weather it installed
Last edited by dan360a47; Sep 16, 2012 @ 10:13am
Moslin Sep 18, 2012 @ 10:57pm 
I found the restored content patched to be buggy and much of it was just dialoge. there were not many scenes or quests that added any value to the game. Still no fix for the terrible ending either
Hassat Hunter Sep 19, 2012 @ 11:38am 
Moddb and Deadlystream host exactly the same version. So it can't be that.
Both also have already been updated to 1.8.1

Buggy? Any examples? Since 1.8.1 is less buggy than vanilla TSL, over 1000 vanilla bugs were fixed...
KazaaakplethKilik Sep 24, 2012 @ 2:30am 
I've installed 1.8.1 version twice, and Kreia still talks about the ship, and no signs of vibrocutter. Any workarounds?
Showing 1-15 of 38 comments
< >
Per page: 15 30 50
Date Posted: Sep 9, 2012 @ 1:40am
Posts: 38