Star Wars: Knights of the Old Republic II
Kaizerwolf Apr 15, 2013 @ 9:26pm
The Sith Lords: Broken
I'm sad guys. I've wasted my time attempting to get this game to work again, and I'm finally posting for some help.

For one thing, I had the CD version of the game. Even having it already installed, the game would not launch. Thinking it was a problem with the CD's themselves, I decided to buy it on Steam, seeing as it was only $9.99. I'm still having issues.

I know there are other threads about this. But I'm tired of wasting my time. I'll post specs now (since I'm almost certain that Nvidia is the cause, yet no fixes have worked so far). Any help is greatly appreciated.

NVIDIA GeForce GTX 260
Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33 GHz (4 cores)
Windows 7 Home Premium SP1 (64 bit)
8.00 GB RAM

I dunno what else anyone might need but I can provide it. I'm moderately computer literate (better with software than hardware) so i'm not afraid to really dig into the programming if necessary, but a guide would be great. I loved this game when I used to play it. KOTOR 1 works fine, and I would love to play this one again.
Any help is appreciated.
-Kw
Showing 1-14 of 14 comments
< >
Kaizerwolf Apr 16, 2013 @ 9:20am 
Originally posted by S.t.a.l.k.e.r.:
Try the sith lords restored content mod is like a community fix. Oh the standard fix is 'swkotor.ini' file enter under graphical option add the line Disable Vertex Buffer Objects=1

For the retail disc versions.

Run compatbility check it will install as admin as XP2 service pack 2.

Manual patch do not autopatch from the game menu.

'swkotor.ini' file enter under graphical option add the line Disable Vertex Buffer Objects=1

Replace mss32.dll you can copy and paste from kotor1 to kotor 2.

Also run affinty on a single core via task manger

This game is old and broke and even with all the fixes expect CTDs.

I do own the retail version, yes, but I uninstalled it in hopes that the Steam version had at least patches to make it run. Although reading through the other threads, I should have realized that this would be the case. All the same, I have experimented with the .ini file, changed the game to my resolution, switched the value of Vertex Buffer, and even done the Vista fix for mss32.dll. Running in compatability mode does nothing for me.

Again, the game is running in Task Manager, but the game window does not launch. Should I perhaps try again with the retail version?
meisterkreig Apr 16, 2013 @ 10:16am 
Are your drivers up to date? Have you tried running it in window mode?
Kaizerwolf Apr 16, 2013 @ 10:19am 
Originally posted by meisterkreig:
Are your drivers up to date? Have you tried running it in window mode?

When going through the the device manager, the NVIDIA driver tells me I don't need an update. Should I check on the website for one?
Windowed mode does not do anything, game still refuses to launch.
Zarosio Apr 18, 2013 @ 7:20am 
Try the fixes on this website they have quite a few different one and how to implement them http://pcgamingwiki.com/wiki/Star_Wars:_Knights_of_the_Old_Republic_II_%E2%80%93_The_Sith_Lords
\m/(-_-)\m/ Apr 18, 2013 @ 5:49pm 
kaizer try start menu > Computer > Local desk C > Program files > Steam > steam > Games > KOTOR 2 right click it and run it windows 7. Thats what i did and it worked like a charm and i had retail version
\m/(-_-)\m/ Apr 18, 2013 @ 5:50pm 
except i didnt go thru steam of course having retail version
Kaizerwolf Apr 18, 2013 @ 8:06pm 
I'll attempt to try again with the retail version. Granted I've only tried all of the fixes through Steam's version. That was a bit impulsive of me to just give up on the retail version so quickly. I'll keep this updated if anything works through with the 4 disks. Thanks again guys.
Kaizerwolf Apr 19, 2013 @ 2:14pm 
Originally posted by Zarosio:
Try the fixes on this website they have quite a few different one and how to implement them http://pcgamingwiki.com/wiki/Star_Wars:_Knights_of_the_Old_Republic_II_%E2%80%93_The_Sith_Lords

Followed this guide nearly to the exact specifications, other than reading later on that the official patch needed to be installed through Windows XP SP3 (I used SP2). No success. The game still appears in the Task Manager, and the mouse icon turns into the spinning disk for a few seconds. Nothing new happens. NVIDIA card is up to date, Microsoft claims DirectX does not need an update.

I don't want to give up on this game, since I remember it being so great. I'm completely frustrated with this, though. I appreciate the help so far. Is there anything else that can possibly be done?
Kaizerwolf Apr 19, 2013 @ 6:50pm 
The retail version's built in System Information module claims that my Video has "failed". Here is the details:

RDPDD Chained DD 4096 MB
Your current video card drivers are out of date
NVidia cards require Detonator 45.23 drivers or better

After doing some searching, it seems that particular driver is only for Windows XP. I'm going to save myself some trouble by not attempting to download it, since I doubt it would work through Windows 7, or more likely it would replace the existing driver. Any ideas?
Malak101 Apr 20, 2013 @ 3:08pm 
Ignore the system information tool on the retail version; it's over a decade old and not capable of properly detecting today's driver and Windows operating systems. The tool thinks I run Win XP SP2 rather than Win 7 SP1.
Kaizerwolf Apr 21, 2013 @ 7:09pm 
Would anyone recommend trying a patch to get the game to run on 1600x900? In the past, games have crashed or failed to start because of bad resolution (ex. TES4: Oblivion will crash unless I use a bigger resolution). Could that be it?
General Nonsense May 5, 2013 @ 1:47pm 
Yes. I recommend it.
Hassat Hunter May 6, 2013 @ 7:49am 
Considering you have an Intel PC, no I don't recommend that. Considering it will undo a 1.0b fix that's specifically designed to improve the game for Intel (ie. running at all).
AD49613 May 8, 2013 @ 5:42pm 
I got it working by adding "AllowWindowedMode=1" under "[Display Options]" an changing
BOTH "FullScreen=1" to "FullScreen=0" in the swkotor2.ini
To make it not like a window, I also changed the resolution to max in the options before starting the game.
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Apr 15, 2013 @ 9:26pm
Posts: 14