Star Wars: Knights of the Old Republic II
Jimnor Rain Dec 26, 2013 @ 3:52pm
Trouble Getting Kotor to run.
The game crashse upon startup. I've attempted running it in compatibility mode, but it still crashes. I assume that I have to download a mod to fix it. wat do
Showing 1-15 of 21 comments
< >
tracerghost00 Dec 26, 2013 @ 10:45pm 
Like me you might have bought this game thinking the steam version might be better than the torrents or maybe you have bought the game itself from the store with no knowledge of compatibility. But I am here to show you how to set it up no issues. but the downside is resolution. It will be windowed but if you want to change it to be fullscreen I'll show you how.

First go to your game in your library and right click properties. Select the Local Files tab and then Browse Local Files. Click on your swkotor2.ini file and open it up as a text file and it should open up in notepad. Then under Display Options and Graphics Options set Fullscreen from 1 to 0. Also under Display Options set Disable Movies and Disable Intro Movies from 1 to 0.
It should look like this

[Display Options]
FullScreen=0
Disable Movies=1
Disable Intro Movies=1
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=0
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
RefreshRate=60
Height=600
Width=800
V-Sync=1
Anisotropy=4
Frame Buffer=1
Anti Aliasing=4
Texture Quality=2
Grass=1
Soft Shadows=0
Shadows=1
EnableHardwareMouse=1
FullScreen=0
DisableVertexBufferObjects=1

Select file and save to save the changes.

After setting that up go to this website and download the mss32.dll

http://www.lucasforums.com/showthread.php?t=194296

You can go ahead and look around but they do talk alot and I'd rather show you how its done Windows 7 style than let you guys drain your brains on multiple pages of the thread.

Once you've downloaded the file copy the file and paste it in the same file containing the launch application of swkotor2.exe and it shoudl ask to copy and replace and some such other selection but copy and replace it.

Then finally right click swkotor2.exe and select properties. go to the Compatibility tab and make sure its on Windows XP(Service Pack 3). Settings have to have Disable Desktop Composition checked and finally it has to have Run As Administrator checked as well.

Now if you looked at the Graphics Options that I've shown above from swkotor2.ini file you'll see Height and Width. These numbers represent the windowed size you will see for the game. You can change the amount according to your desired screen size but running it in this size usually helps chizel the graphics down. But if you want to do it quick start the game and select the graphics options at the start and set them to what you want. Warning though the game will crash if you change it back.

And extra that I've found lately is disabling movies manually such as the intro logos.
To disable these just go to your movies file located in the same game file you opened up in the second paragraph In this thread and save the files as "bak" instead of "bik".

leclogo.bik; legal.bik; ObsidianEnt.bik
Should look like this
leclogo.bak; legal.bak; ObsidianEnt.bak

Thanks for Reading and enjoy your game guy!
Jimnor Rain Dec 27, 2013 @ 1:21pm 
I've attempted the above. I think it might be because I'm using windows 8. :/
alborn2769 Jan 19 @ 4:07pm 
I have found that if you do everything that tracerghost said and it still doesn't work than there is one more possibility.
Follow tracerghost's instructions but add underneath graphics options
AllowWindowedMode=1 the game will be about a third of your monitor size but I have windowes 8 and it worked awesome for me
Agent Archer Jan 19 @ 6:27pm 
I have windows 7 the game started I set my graphics options to top spec at 60hz now the game just wont open at all, it just sits on the task bar and when I try to maximize it, it wont open. Very annoying. 5th game on steam I have bought that wont work.
funewchie Jan 19 @ 6:36pm 
Originally posted by alborn2769:
I have found that if you do everything that tracerghost said and it still doesn't work than there is one more possibility.
Follow tracerghost's instructions but add underneath graphics options
AllowWindowedMode=1 the game will be about a third of your monitor size but I have windowes 8 and it worked awesome for me

Yep, that's it. That part is critical; along with disabling the movies and disabling the fullscreen, like Tracer said.
(Don't worry, as far as I can tell, the in-game movies still play. But changing the settings just helps with that compatibility issue.)

And I, likewise, can confirm that the game does play on Window 8. The main issue is that Windows 8 can't handle the game's fullscreen mode, so you have to force it to play in windowed mode.
Agent Archer Jan 19 @ 6:50pm 
I have tried everything to get it working. On the store page it says windows 7, It wont work so can I get a refund? Oh wait its steam.
the_last_penfighter Jan 22 @ 7:47pm 
Right, so I've done all of the above (except for one thing) as well as everything that I can find elsewhere (including installing the Restored Content mod) but nothing works.

The only option I have not been able to do is change my .bik files to .bak files. I cannot find a way in Windows 8 to change the file extension. How can I do this?

When I do load the game up, it comes up in a window, but the window background is black and still get the "...is not working" error message and it closes before anything loads up. Definitely frustrated. Any help would be appreciated.
funewchie Jan 22 @ 8:38pm 
Did you set all the entries in the swkotor2.cfg to match what Tracer posted?

Oh, and are you starting the game with it's actual .exe file?
It's important that you use swkotor2.exe to start the game... and not the Rungameid icon they installed on your desktop, or from the Steam library.

And as for the .bik to .bak, personally I've never had to do that.
Last edited by funewchie; Jan 22 @ 8:39pm
the_last_penfighter Jan 22 @ 8:53pm 
Yeah. Just double-checked the config, it matches. I tried running the actual .exe and it got me one stage further: It loaded the KOTOR II moust pointer, but that was it. Screen still went dark and the game crashed.

EDIT: My card is ATI...does that have any bearing on what is happening?
Last edited by the_last_penfighter; Jan 22 @ 9:48pm
funewchie Jan 22 @ 10:07pm 
I'm not sure. I'm afraid I don't know much about hardware.

I'm kinda running out of ideas here. I've been running this game on Windows 8, and haven't done anything else than what's been posted, and yet mine works just fine. (Restored Content Mod at that)

If I had to guess, it might well be a hardware issue like a graphics card.
the_last_penfighter Jan 23 @ 5:11am 
Thanks for your help anyway, funewchie. A new day has begun, and a renewed effort to get this game to work. Any more ideas?
Thorgram Jan 23 @ 6:52am 
Did you follow Tracer's instructions exactly? I was able to get the game running on Windows 8 by doing exactly what he said.

However, modifying the graphics options in game or changing the ini file beyond copying the code that Tracer has posted caused the game to not start, so maybe that's your problem.

Also too, make sure you haven't accidentally removed a line or two of the ini file when you copied the code in; it should only replace the code up to "DisableVertexBufferObjects", not the whole thing.
Agent Archer Jan 23 @ 8:31am 
I still cant get it to run in windows 7, still minimizes itself, ive tried a lot, maybe its my card. Getting a friend over at the weekend to see if she can get it going. Very annoying.
blue Jan 23 @ 11:58pm 
I'm running on windows vista and modifying the .ini did make my game run, but once I try to load my saved file it would crash unless I start a new game. I have a Nvidia card and when I turned off Threaded Optimization for Kotor2 in the control panel, my game is running fine now. For ATI cards the option is called Multithread Optimization, set it off or set the value to 0. My .ini file is the default one now and no problems thus far.

Here's an example for Nvidia card owners: http://img10.imageshack.us/img10/7994/nvidiacp1.jpg

Not sure if it will work for everyone, but give it a try.
the_last_penfighter Jan 25 @ 10:35am 
I've uninstalled the game, reinstalled it on my local machine, and copied his instructions down to the very letter. Still not working. :/ I am extremely disappointed but trying to hang on to the hope that maybe I am just doing something wrong. I'll start from scratch again today, since I see no means of reclaiming my money from Steam. Best option is to try and get it to work.
Showing 1-15 of 21 comments
< >
Per page: 15 30 50
Date Posted: Dec 26, 2013 @ 3:52pm
Posts: 21