STAR WARS™ Knights of the Old Republic™ II: The Sith Lords™

STAR WARS™ Knights of the Old Republic™ II: The Sith Lords™

View Stats:
 This topic has been pinned, so it's probably important
Aspyr-Blair  [developer] Jul 30, 2015 @ 2:17pm
[Windows] Hotfix out today 07/30
Windows hotfix went out today to address the following:

- PS4 controller causing the camera to spin
- Missing audio files for Kreia have been put back in

Important note: This update does not mean that Playstation controllers will be supported for Windows. Windows currently needs third party drivers in order for PS controllers to work and therefore can not be reliably supported. We identified an issue in our code that caused the most common drivers (xinput and DS4Windows) to bug out.
< >
Showing 1-15 of 93 comments
The Human Spider Jul 30, 2015 @ 2:17pm 
Awesome!
fastica Jul 30, 2015 @ 2:21pm 
Do you guys have any plans to update the first KOTOR as you did with this one????
I RuBiiX I Jul 30, 2015 @ 2:29pm 
Sweet. While this update does not effect me as I use the Xbox Controller and have already added the missing files from my GOG version, it is nice to see you supporting the game. I cannot wait for the big patch!
Spangled Jul 30, 2015 @ 2:41pm 
Originally posted by I RuBiiX I:
Sweet. While this update does not effect me as I use the Xbox Controller and have already added the missing files from my GOG version, it is nice to see you supporting the game. I cannot wait for the big patch!

Big patch?
Zmaj_iz_Bosne Jul 30, 2015 @ 2:42pm 
Thank you :)
Aspyr-Blair  [developer] Jul 30, 2015 @ 2:48pm 
Originally posted by Spangled:
Originally posted by I RuBiiX I:
Sweet. While this update does not effect me as I use the Xbox Controller and have already added the missing files from my GOG version, it is nice to see you supporting the game. I cannot wait for the big patch!

Big patch?

This is our last hotfix before a patch plan going forward. We dont know how big that patch will be honestly, but we hope to iron our the remaining prevelent issues AND add crowd sources achievements for fun :)
Originally posted by Aspyr-Blair:
Originally posted by Spangled:

Big patch?

This is our last hotfix before a patch plan going forward. We dont know how big that patch will be honestly, but we hope to iron our the remaining prevelent issues AND add crowd sources achievements for fun :)

I'm so glad to hear this and I can't thank you enough for all the support you've shown thus far. However, I'd still like to know if are you planning on fixing these 2 issues or at least attempting to fix them:

- the skipping dialogue bug (engine bug that seemingly occurs in long playtime sessions - sometimes relatively short sessions too by pressing the ALT+TAB key too many times or the game running out of RAM supposedly?)
- buzzing sound issue when you use a terminal mostly (its related to the "amb_elecwire_A.wav" file in ...\Steam\steamapps\common\Knights of the Old Republic II\StreamSounds\ -- BUT another repeating sound effect occurs a few times throughout Peragus, even when you don't use anything, esp. when playing as the T3 droid in a room just before the Peragus Fuel Depot elevator)

Thanks yet again, and sorry if I've been annoying. These infamous issues are the only thing standing in the way of a flawless experience.
Last edited by -3xA'Lu©κy (idling); Jul 30, 2015 @ 3:00pm
Aspyr-Blair  [developer] Jul 30, 2015 @ 3:03pm 
Originally posted by -3xA'Lu©κy:
Originally posted by Aspyr-Blair:

This is our last hotfix before a patch plan going forward. We dont know how big that patch will be honestly, but we hope to iron our the remaining prevelent issues AND add crowd sources achievements for fun :)

I'm so glad to hear this and I can't thank you enough for all the support you've shown thus far. However, I'd still like to know if are you planning on fixing these 2 issues or at least attempting to fix them:

- the skipping dialogue bug (engine bug that seemingly occurs in long playtime sessions - sometimes relatively short sessions too by pressing the ALT+TAB key too many times or the game running out of RAM supposedly?)
- buzzing sound issue when you use a terminal mostly (its related to the "amb_elecwire_A.wav" file in ...\Steam\steamapps\common\Knights of the Old Republic II\StreamSounds\ -- BUT another repeating sound effect occurs a few times throughout Peragus, even when you don't use anything, esp. when playing as the T3 droid in a room just before the Peragus Fuel Depot elevator).

Thanks yet again, and sorry if I've been annoying. These infamous issues are the only thing standing in the way of a flawless experience.

They are in the DB, but I should note that (IMO) the skipping dialogue bug is unfixable. We are still diving in, but my hopes arent high. Sound issue is squarely in our sights however. What we dont understand is why only certain configs are experiencing the issue.
Originally posted by Aspyr-Blair:
They are in the DB, but I should note that (IMO) the skipping dialogue bug is unfixable. We are still diving in, but my hopes arent high. Sound issue is squarely in our sights however. What we dont understand is why only certain configs are experiencing the issue.

Thanks for being honest, I highly appreciate that.

I'm experiencing the sound bug on this rig (maybe there's a common factor?):
Windows 7 64 bit (professional edition)
Intel Core i7 950 @ 3.07ghz CPU(4 cores, 8 cores logical)
Nvidia GTX 680 4gb vram GPU
16gb DDR3 ram
Last edited by -3xA'Lu©κy (idling); Jul 30, 2015 @ 3:05pm
Vlad Jul 30, 2015 @ 3:04pm 
Originally posted by -3xA'Lu©κy:
- the skipping dialogue bug (engine bug that seemingly occurs in long playtime sessions - sometimes relatively short sessions too by pressing the ALT+TAB key too many times or the game running out of RAM supposedly?)
As I understand it, that bug only happens with TSLRCM installed. So if that's actually the case, we'd have to ask the RCM team to see what they can do. Hopefully it does get fixed either way though.
Originally posted by Vladimir:
Originally posted by -3xA'Lu©κy:
- the skipping dialogue bug (engine bug that seemingly occurs in long playtime sessions - sometimes relatively short sessions too by pressing the ALT+TAB key too many times or the game running out of RAM supposedly?)
As I understand it, that bug only happens with TSLRCM installed. So if that's actually the case, we'd have to ask the RCM team to see what they can do. Hopefully it does get fixed either way though.

I've had it on a vanilla game a fair amount of times. Some say it gets worse or better with TSLRCM installed but I've personally seen no difference either way.
azamen87 Jul 30, 2015 @ 3:06pm 
im having the buzzzz sound bug as well
Biosim Jul 30, 2015 @ 3:06pm 
Baahhh why did you put those audio again? That old woman could be silent, for better xDxD
JK! Many, many thanks for the big update, and the hotfix. (Btw, look for this quest: Zakkeg challenge, i think it is bugged, if you do not complete it after you go to Iziz)
Vlad Jul 30, 2015 @ 3:07pm 
Originally posted by -3xA'Lu©κy:
Originally posted by Vladimir:
As I understand it, that bug only happens with TSLRCM installed. So if that's actually the case, we'd have to ask the RCM team to see what they can do. Hopefully it does get fixed either way though.

I've had it on a vanilla game a fair amount of times. Some say it gets worse or better with TSLRCM installed but I've personally seen no difference either way.
Odd. Well, again I hope we can get it fixed soon. If not, that's fine I suppose.
Originally posted by Vladimir:
Originally posted by -3xA'Lu©κy:

I've had it on a vanilla game a fair amount of times. Some say it gets worse or better with TSLRCM installed but I've personally seen no difference either way.
Odd. Well, again I hope we can get it fixed soon. If not, that's fine I suppose.

I once played 3 hours without experiencing it but I do hope it can eventually be fixed.
< >
Showing 1-15 of 93 comments
Per page: 15 30 50