DOOM 3: BFG Edition > Discussioni generali > Dettagli della discussione
APEXnow 20 ott 2012, ore 15:28
One possible solution to performance issues with Doom3 BFG
I bought D3BFG today, and was immediately stunned at the shear drop in performance on my PC. 2.2Ghz AMD Phenom Quadcore, and running ATI Radeon HD4550. I had previously ran Doom3 original and had no problem running this at all. But this version was very choppy.

So I decided to find out what was going on. Another thread mentions that you must at least get into the game at least once before your default.cfg file is created in the DOOM 3 BFG Edition folder.

If you do get that far, edit the file and scroll right down to the end of the file:

Add the following line:

rs_enable 0

and save the file.

This appeared to completely resolve the choppiness although I have still got some small issues with particles generated from explosions or smoke trails from the Skulls in Resurrection of Evil. Still looking into other settings to see what's causing the lag with these entities.

Any feedback welcome.

Paul.
Ultima modifica da APEXnow; 20 ott 2012, ore 15:34
Visualizzazione di 1-14 commenti su 14
< >
~ÄÄĤKILLYA~ 20 ott 2012, ore 15:54 
Hey mate I am having no issues at all I dont understand peoples problems I played the old version had a great time ! This feels better to me I love it more I have 2.8 Ghz Phenom II 6 Core and MSI Lightning R6970 (Radeon) with 16 GiG of ram my question is do you have enough RAM Windows7 uses a lot do you run GameBooster have you tried IObits Advanced System Care 6?????? Me thinks your problem maybe something else! I just downloaded the game n have already played 8 hours trouble free man!
All the best n good luck with it!
APEXnow 20 ott 2012, ore 17:58 
Hi,

I have since found that these two settings in the default.cfg file, complete resolve my lag problems on this system.

rs_enable 0
r_skipPostProcess 1

Both of these settings makes it all good and smooth!

Any further feedback on why, welcome.

Paul.
Master_Brain_07 21 ott 2012, ore 9:54 
Messaggio originale di APEXnow:
I have since found that these two settings in the default.cfg file, complete resolve my lag problems on this system.

rs_enable 0
r_skipPostProcess 1

Both of these settings makes it all good and smooth!

It works for me (with ATI Radeon HD4870). Now FPS drops are gone and I can activate anti-aliasing, too! The game run smooth!

Many THANKS!
lilbastard 21 ott 2012, ore 10:06 
Thanks Paul!

This fixed my issue with the game and its been bugging the hell out of me all weekend! (Running on ATI Radeon HD6770)
Ultima modifica da lilbastard; 21 ott 2012, ore 10:07
C#Coder.cs 21 ott 2012, ore 19:15 
it works for me! all those having issues this is the Topic to look at!

Thank you so much!
Ultima modifica da C#Coder.cs; 21 ott 2012, ore 19:15
^^o^^ BatCat 22 ott 2012, ore 0:31 
What is this variable?

rs_enable 0

r_skipPostProcess 1 ;easier to turn MotionBlur down. 8)
Skaery 23 ott 2012, ore 8:52 
Thanks for the solution. It worked great.
igotthelife69 23 ott 2012, ore 9:05 
I have a Radeon HD5470 and have been battling this for 4 days. No matter what I do I always get to the same crash, Fault Name: atioglxx.dll. Open GL I assume. How can I get to start the game and obtain a cfg file?
senkus 3 nov 2012, ore 6:25 
What exactly does rs_enable 0 do?
A certain gaming god called John Carmack recommended it to me to stop the game from reducing the horizontal resolution when below 60 fps, so I get the impression that the command would not increase but decrease fps. (The tweet, thanks John: https://twitter.com/ID_AA_Carmack/status/264395983490793472 )
berserkcesar 14 nov 2012, ore 11:18 
Messaggio originale di APEXnow:
Hi,

I have since found that these two settings in the default.cfg file, complete resolve my lag problems on this system.

rs_enable 0
r_skipPostProcess 1

Both of these settings makes it all good and smooth!

Any further feedback on why, welcome.

Paul.


Hi Paul,

Thanks for the great post, this solution solve 80% of my issues with the game. I still have significant lag when my character gets attacked. And I have also notice that glass doesn't seem to render in the game. For example the first time the monster "pinky demon" shows up it breaks through glass, but when i played it in BFG it was if there was no glass but i couldn't walk through it.

So if you know of a quick way to fix the lag with the character getting hurt, please let me know. Thanks

Cesar,
APEXnow 16 nov 2012, ore 12:38 
I have noticed a similar issue when some of the skulls appear in the next mission pack. I think that there are still some issues when certain shaders are being used. I'll try to investigate any further solutions to the problem, but I've found nothing so far ;)

Paul.

TBH, I wish that id would post up some sort of Q&A because I've seen nothing at all yet.
Ultima modifica da APEXnow; 16 nov 2012, ore 12:39
Donnovan 1 dic 2012, ore 4:21 
Hi!

About those setting:

rs_enable 0
r_skipPostProcess 1

They turn steam archievements off?

Thanks!
Syluxguy28O3 17 dic 2012, ore 18:58 
Messaggio originale di berserkcesar:
Messaggio originale di APEXnow:
Hi,


So if you know of a quick way to fix the lag with the character getting hurt, please let me know. Thanks

Cesar,

i had your problem. then i updated my vid drivers,and the problem went away. odd. anyway, if you haven't already tried an update, i would recommend that.
starshine 16 ott 2013, ore 15:09 
Updating video drivers fixed a crash-at-startup problem, but prior to editing default.cfg as suggested by APEXnow, fps=9.

rs_enable 0

After adding this line, fps=20

r_skipPostProcess 1

And now fps=60.

Brilliant, thank you!

Visualizzazione di 1-14 commenti su 14
< >
Per pagina: 15 30 50
Data di pubblicazione: 20 ott 2012, ore 15:28
Messaggi: 14