DOOM 3: BFG Edition > การสนทนาทั่วไป > รายละเอียดกระทู้
Reaper Madness 18 ต.ค. 2012 @ 6:12pm
Fix for the OpenGL issue. Should work for most of you.
Like everybody else, I've been butting my head against the wall trying to figure out a solution to the OpenGL issue. For most of you who receive this error, though you may not have realized it, the problem with Doom 3 BFG seems to be with it running in full screen mode. I found a fix for this, but it takes a few steps. Basically you will force Doom 3 BFG to run in a windowed mode in order to access the game, where you can input the settings that will permanently allow you to run it full screen with the resolution you want. Just follow the directions I will list here:

1. On your computer (in this case Windows 7), go to C:\Users\<Your Name>\Saved Games\id Software\DOOM 3 BFG\base. You will find a file called D3BFGConfig.cfg there.

2. Open this file using notepad (right click and use the OPEN WITH command if you need to, and choose Notepad).

3. Scroll down until you find a command line that says set r_fullscreen "1" . This is going to sound strange, but you want to change the 1 to a 3 (set r_fullscreen "3") and it should work. Save the CFG file and run the game. Within the game, be sure to make any resolution setting changes under "Monitor 3" (For some of you it may only work under "2" or "4". See note below)

In my case I originally set the command line to 0, which "disabled" full screen, and then ran my game in windowed form. Once I accessed the settings, I tooled around a bit until I figured out that Doom would accept my resolution as long as it was under "Monitor 3". Changes under Monitor 1 would immediately crash the game. Afterwards I noticed that the command line I mentioned above now shows as set r_fullscreen "3", which leads me to believe the CFG command line change should suffice for full screen functionality.

From what I've seen of other Steam user's issues regarding OpenGL, this solution should work for most of you. There may be a slight chance the "3" setting may work for me due to the unique video card setup I have (a Nvidia GTX 295 card that the system sees as two cards, plus an integrated video card I do not use) If changing the number to 3 does not work for you, try 2, 4, or at the very least 0 for windowed mode which should positively work. I hope you have success in getting your game to run. Let me know if this works for you.

NOTE: As antibiotic pig has helpfully pointed out, for those of you who are not having any luck using "3", other Steam users are finding success when trying out the other monitor types, mainly "2" and "4". "4" typically being the most common after "3".

EDIT: Some of you are unable to perform this because the CFG file in question is not created until the game has been accessed at least once, which I did not realize. I've moved up my solution to that into this initial posting. The fix, and possible edit-free solution is as follows:

Good news for those of you who are unable to access the game in windowed mode. I have found a way to force windowed mode through via making a desktop shortcut. As a matter of fact, this fix might allow you to fix the issue immediately and bypass the CFG file editing entirely. Just follow the following directions:

1. Go to the DOOM BFG directory in Steam. Typically the path is C:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition

2. Right click on the file executable DOOM3BFG.EXE and create a shortcut to desktop. On Windows 7 it would be under right click, SEND TO, and then DESKTOP (CREATE SHORTCUT).

3. Once you have created a shortcut on your desktop, right click on it and choose PROPERTIES. In the target field, add "+set r_fullscreen 0" to the end of the target path (no quotes). There should be a space right before the +. Your target line should now look similiar to the following:

"C:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition\Doom3BFG.exe" +set r_fullscreen 0

NOTE: You should be able to input "3" instead of "0" in the above command line, which for most users immediately allowed them full screen access to Doom 3 BFG. Other Steam users have mentioned that using "2" or"4" worked in their case, "4" being the most common after "3". Also, the "+set r_fullscreen 0" can also be placed directly in the Steam launch options for your game (minus the quotes). Special thanks to Darth Guybrush for pointing this out. Steam launch options can be accessed by right clicking on Doom 3 BFG in your Steam library and choosing "properties". It will be titled "Set Launch Options".

4. This trick worked on the old Doom 3 and luckily it still works with the BFG edition. Theoretically you should be able to change the "0" in the fullscreen command I just mentioned to a "3", and bypass all the CFG editing altogether though I haven't tested that. I don't see why it shouldn't work though. At the very least, with the "0" it will allow you to run it in windowed mode and make the fixes listed above. Hope this works for those of you unable to run the game to create a Saved Games directory.

EDIT:
Ensuring game runs in fullscreen once you have access to in-game video settings

Don't forget that once you are able to access the video settings IN-GAME, you should be able to choose fullscreen settings that apply to your system. You do not have to stay in windowed mode if you are able to access the in-game settings. If memory serves me, there should be 4 groupings of resolutions available inside the video settings in-game, each set defined by monitor 1, 2, 3, or 4. Only one of these will apply to your computer. You will know if you have chosen the right set because the monitor will change to fullscreen under your new resolution pick. Use process of elimination until you find a working resolution under a monitor set (1,2,3, or 4) that applies to your computer. Remember however that once you find a resolution that works and puts you in fullscreen mode, YOU MUST remember to delete the extra parameters you put in place in order to run the game in windowed mode to begin with (i.e.- "+set r_fullscreen 0") Otherwise the game will continue to load into windowed mode regardless of the resolution you chose. Should you choose a resolution under a monitor set that does not apply, and it subsequently crashes, don't panic. Simply restart the game and it will run in windowed mode, as long as you still have the shortcut modified. Then try the other monitor sets you haven't already. Otherwise, as mentioned above, remove the " "+set r_fullscreen 0" afterwards from your launch or shortcut modification once you have found the in-game monitor resolution setting that works for you.
ได้รับการแก้ไขครั้งสุดท้ายโดย Reaper Madness; 5 ส.ค. 2013 @ 9:02am
กำลังแสดง 1-15 จาก 139 ความเห็น
< >
Seanobi 18 ต.ค. 2012 @ 7:07pm 
My entire folder in C:\Users\<myname>\Saved games\ is completely blank...

When I launch Doom 3 BFG I believe it may be an OpenGL problem, but I also see in the blue box: ERROR: GL_ARB_draw_elements_base_vertex not available.

Either / or ... if I can find, or even create that D3BFGConfig.cfg file, I may be set. I just don't see it. Thank you though for your contributions though!!!
Reaper Madness 18 ต.ค. 2012 @ 7:33pm 
Seanbi777, you make a valid point. It didn't occur to me that Doom BFG may not create a section in Saved Games until you can actually access the game. I managed to do this earlier using my crappy integrated card, but I wanted a solution that worked on my main card. The key would be to run DOOM BFG in windowed mode to access the settings and to create the Saved Games section for Doom BFG, unfortunately that is easier said than done. I was unable to find a way to force a game to run in windowed mode, without access to internal setting or configuration files..

If its of any help to you, I looked up your issue and saw that a few people mentioned the vertex error you are receiving may be due to the graphics card being unable to run it (lacking ability to run certain newer features). You can check if your system meets minimum requirements for running Doom 3 BFG by running a test on the following link. Doom 3 BFG is in the dropdown box to test:

http://www.systemrequirementslab.com/cyri/intro.aspx
MegaTraps 18 ต.ค. 2012 @ 7:54pm 
Much love <3
Reaper Madness 18 ต.ค. 2012 @ 8:17pm 
Did the CFG file solution work for you MegaTraps?
mischa_316 18 ต.ค. 2012 @ 9:39pm 
Thank you so much for this fix. It did finally work for my pc which is a laptop with HDMI. Gotta love it you can play your favorite FPS of all time on your bigscreen!! Thank you so much again.
Reaper Madness 18 ต.ค. 2012 @ 9:49pm 
I'm glad to hear it worked for you Mischa_316. There's nothing as frustrating as looking forward to a game and then having it not work at all after you install. Hopefully Id will patch this peculiar OpenGL issue in the near future.
vault2049 18 ต.ค. 2012 @ 11:11pm 
Your solution works perfectly. Thank you VERY MUCH sir : D
ได้รับการแก้ไขครั้งสุดท้ายโดย vault2049; 18 ต.ค. 2012 @ 11:11pm
FPSCornwall 18 ต.ค. 2012 @ 11:35pm 
Hi all. Was excited to see this post... but no joy yet as game won't launch, hence no saved file as per instructions. I have a Alienware M11X Laptop connecting via hdmi to a benq monitor. I tried disconnecting hdmi and running the game via the non-nvidia card from the laptop but still wouldn't launch. Any further updates / solutions please?
ได้รับการแก้ไขครั้งสุดท้ายโดย FPSCornwall; 18 ต.ค. 2012 @ 11:43pm
RiCh_HaRd1 19 ต.ค. 2012 @ 3:03am 
or you could just change the exe file to compatibility to winxp sp3 and admin privileges...
[3rc] Jeruzalem 19 ต.ค. 2012 @ 3:13am 
this fix sadly enough doesnt work for me as i too have no save file. i cant enter the game as its unable to load default.cff or something similar to that. wait a minute...default.cfg is causing problems for me...
ได้รับการแก้ไขครั้งสุดท้ายโดย [3rc] Jeruzalem; 19 ต.ค. 2012 @ 3:14am
Reaper Madness 19 ต.ค. 2012 @ 4:24am 
Good news for those of you who are unable to access the game in windowed mode. I have found a way to force windowed mode through via making a desktop shortcut. As a matter of fact, this fix might allow you to fix the issue immediately and bypass the CFG file editing entirely. Just follow the following directions:

1. Go to the DOOM BFG directory in Steam. Typically the path is C:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition

2. Right click on the file executable DOOM3BFG.EXE and create a shortcut to desktop. On Windows 7 it would be under right click, SEND TO, and then DESKTOP (CREATE SHORTCUT).

3. Once you have created a shortcut on your desktop, right click on it and choose PROPERTIES. In the target field, add "+set r_fullscreen 0" to the end of the target path (no quotes). There should be a space right before the +. Your target line should now look similiar to the following:

"C:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition\Doom3BFG.exe" +set r_fullscreen 0

4. This trick worked on the old Doom 3 and luckily it still works with the BFG edition. Theoretically you should be able to change the "0" in the fullscreen command I just mentioned to a "3", and bypass all the CFG editing altogether though I haven't tested that. I don't see why it shouldn't work though. At the very least, with the "0" it will allow you to run it in windowed mode and make the fixes listed above. Hope this works for those of you unable to run the game to create a Saved Games directory.
ได้รับการแก้ไขครั้งสุดท้ายโดย Reaper Madness; 19 ต.ค. 2012 @ 4:28am
RiCh_HaRd1 19 ต.ค. 2012 @ 4:26am 
got any fixes to make the game run faster than 3 fps on a top of the line pc?
FPSCornwall 19 ต.ค. 2012 @ 5:56am 
some more tweaking to do..... but you soled it Reaper!! Thanks

p.s. will only run at 1280x720 on 1080 monitor - best it will get? Ive changed config file, but it seems to revert back to 1280x720 with no in game menu options to increase resolution..

thanks again for the fix.
ได้รับการแก้ไขครั้งสุดท้ายโดย FPSCornwall; 19 ต.ค. 2012 @ 6:55am
Hosslogic 19 ต.ค. 2012 @ 7:09am 
So, I noticed my BFG folder doesn't even have a config file... the hell do i do now?
ได้รับการแก้ไขครั้งสุดท้ายโดย Hosslogic; 19 ต.ค. 2012 @ 7:09am
FPSCornwall 19 ต.ค. 2012 @ 7:24am 
Hoss - see Reapers update two posts above :-)
กำลังแสดง 1-15 จาก 139 ความเห็น
< >
ต่อหน้า: 15 30 50