DOOM 3: BFG Edition > 一般的な話題 > トピックの詳細
Haloruler64 2012年10月18日 0時22分
Causes For "Unable To Initialize OpenGL" Discussion Thread + FIX!
I'm sure many of you have experienced this. I have too. I think I have discovered a few possible causes for it.

1. One of the most likely: Problems with Optimus.
I have an Alienware M14x R1. The Intel HD 3000 graphics processor is what controls the internal display. An external monitor plugged in through HDMI is controlled by the dedicated graphics, in my case, a GT555M. External monitor, doesn't work no matter what resolution it's running. Internal display, it starts and runs fine. Possibly a problem with Optimus. If you get this issue, does your laptop have Optimus technology?

2. Dedicated graphics pushing a monitor.
This is a general one. If you have a dedicated GPU pushing a monitor, it might make it fail. It might only run on Intel HD powered displays, even if you have a dedicated GPU. If you have a desktop and have a monitor plugged into a dedicated GPU, and you do get this error, are you using HDMI or VGA or DVI? Tell us more info.

3. Possible problem with HDMI connections?
Not at all sure about this one, bit of a shot in the dark. HDMI could make it fail. If you use a monitor, tell us how it's plugged in.

Let's congregate some info here. Try not to post without reading. Don't post duplicate info unless it hasn't been confirmed yet. And I don't think logs are all that important, copied from the error screen. Just describe your setup a bit. Thank you!

EDIT: User vault2049 has posted a working fix! Worked for us anyway, try it!

1. Navigate to C:\Users\*your username*\Saved Games\id Software\DOOM 3 BFG\base and find file "D3BFGConfig.cfg"
2. Open file with Notepad (I use Notepad++, great program) and edit line r_fullscreen "1" and set it to "3".
3. Go into game and set Monitor 3 resolution to your res.

Hope it helps!
最近の変更はHaloruler64が行いました; 2012年10月19日 1時36分
1-15 / 44 のコメントを表示
< >
Darth Guybrush 2012年10月18日 2時04分 
No joy here. Might try some newer ATI drivers. Stems from RAGE not working at all on anything than aspecific set of drivers (still not fixed?). My DXDIAG (64-bit):

------------------
System Information
------------------
Time of this report: 10/18/2012, 20:02:16
Machine name: COLDGEN
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120830-0333)
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: HP Pavilion dv6 Notebook PC
BIOS: InsydeH2O Version 03.60.48F.1B
Processor: Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz (8 CPUs), ~2.2GHz
Memory: 8192MB RAM
Available OS Memory: 8140MB RAM
Page File: 3325MB used, 12952MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 64bit Unicode

------------
DxDiag Notes
------------
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Sound Tab 2: No problems found.
Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: Radeon (TM) HD 6770M
Manufacturer: ATI Technologies Inc.
Chip type: ATI display adapter (0x6740)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_6740&SUBSYS_1657103C&REV_00
Display Memory: 726 MB
Dedicated Memory: 1008 MB
Shared Memory: 3813 MB
Current Mode: 1600 x 900 (32 bit) (60Hz)
Monitor Name: SyncMaster B2030/ B2055PLUS(Analog)
Monitor Model: SMB2030
Monitor Id: SAM063C
Native Mode: 1600 x 900(p) (60.000Hz)
Output Type: HD15
Driver Name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Driver File Version: 8.17.0010.1070 (English)
Driver Version: 8.830.6.2000
DDI Version: 11
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 4/13/2011 04:02:10, 795648 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Device Identifier: {D7B71EE2-2400-11CF-A277-5D36BEC2C535}
Vendor ID: 0x1002
Device ID: 0x6740
SubSys ID: 0x1657103C
Revision ID: 0x0000
Driver Strong Name: oem45.inf:ATI.Mfg.NTamd64.6.1:ati2mtag_Vancouver_PXAI:8.830.6.2000:pci\ven_1002&dev_6740&subsys_1657103c
Rank Of Driver: 00E60001
Video Accel: ModeMPEG2_A ModeMPEG2_C
Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{3C5323C1-6FB7-44F5-9081-056BF2EE449D}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC1,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC2,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC3,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC4,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(S340,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
{5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(S342,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
D3D9 Overlay: Not Supported
DXVA-HD: Not Supported
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
Haloruler64 2012年10月18日 2時25分 
Darth Guybrush, good to know it's another laptop issue. Does your laptop have GPU switching tech?
Darth Guybrush 2012年10月18日 2時42分 
2. Dedicated graphics pushing a monitor.
This is a general one. If you have a dedicated GPU pushing a monitor, it might make it fail. It might only run on Intel HD powered displays, even if you have a dedicated GPU. If you have a desktop and have a monitor plugged into a dedicated GPU, and you do get this error, are you using HDMI or VGA or DVI? Tell us more info.

>>1600x900 Samsung connected via VGA. Updated to ATI 12.9 beta. No joy. Am going to try RAGE which was always a problem game.

HP Notebook. 8Gb RAM. Win7 Ult 64-bit. Fully patched.

UPDATE: Whoa! RAGE actually launched using the 12.9 beta drivers. Still no joy with Doom 3 BFG.

UPDATED UPDATE! YES RAGE actually works for me under the 12.9 beta drivers. And looks / performs fantastically I must say. Always liked this game so was forever RAGEd by the driver issues SINCE launch!
最近の変更はDarth Guybrushが行いました; 2012年10月18日 2時53分
Darth Guybrush 2012年10月18日 3時15分 
Haloruler64 の投稿を引用:
Darth Guybrush, good to know it's another laptop issue. Does your laptop have GPU switching tech?

Yeah. Like to the basic INTEL on board ♥♥♥♥ that seems to ne the only way to run Carrier Command Gaia Mission. But this is iD Software.

UPDATE: Carrier Command now runs fine after installing AMD 10.9 beta drivers.

This sort of thing makes me wonder if I will upgrade to Windows 8. I love my HP machine. Is ace. Just iD seem to have lost the plot.

As far as switching I think I need to do it through the ATI control panel or right click on Intel HD graphics. Will give that a go (worked or CC: GM but that is not Open GL I think)...
最近の変更はDarth Guybrushが行いました; 2012年10月18日 17時58分
jerrderoche 2012年10月18日 5時12分 
QA Timing INIT: 000109ms
D3BFG 1.1400 win-x86 Oct 5 2012 11:38:38
2700 MHz AMD CPU with MMX & 3DNow! & SSE & SSE2 & SSE3 & HTT
6144 MB System Memory
256 MB Video Memory
Winsock Initialized
Found interface: {FA3DDE4D-E809-485C-AA60-3A786C9FC0B8} NVIDIA nForce 10/100 Mbps Ethernet - 192.168.1.2/255.255.255.0
Sys_InitNetworking: adding loopback interface
doom using MMX & SSE for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded resource file _common.resources
Loaded resource file _ordered.resources
Loaded resource file _sound_pc.resources
Loaded resource file _sound_pc_en.resources
Current search path:
C:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition/base
C:\Users\Jay\Saved Games\id Software\DOOM 3 BFG/base
file system initialized.
--------------------------------------
WARNING: Unable to open resource file maps/_startup.resources
----- Initializing Decls -----
------------------------------
Couldn't open journal files
execing default.cfg
couldn't exec D3BFGConfig.cfg
couldn't exec autoexec.cfg
----- R_InitOpenGL -----
Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
...using WGL_EXT_swap_control_tear
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: NVIDIA GeForce 7900 GS
StateFlags : 0x5
DeviceID : PCI\VEN_10DE&DEV_0292&SUBSYS_037010DE&REV_A1
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{02D65390-AAFB-45BD-B50F-3447EB2C8369}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\VIZ0067\{4d36e96e-e325-11ce-bfc1-08002be10318}\0003
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0003
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1360
dmPelsHeight : 768
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...calling CDS: ok
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: NVIDIA GeForce 7900 GS
StateFlags : 0x5
DeviceID : PCI\VEN_10DE&DEV_0292&SUBSYS_037010DE&REV_A1
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{02D65390-AAFB-45BD-B50F-3447EB2C8369}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\VIZ0067\{4d36e96e-e325-11ce-bfc1-08002be10318}\0003
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0003
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1280
dmPelsHeight : 720
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...created window @ 0,0 (1280x720)
Initializing OpenGL driver
...creating GL context: failed to create OpenGL 3.2 context
created OpenGL 2.0 context
succeeded
...making context current: succeeded
...using WGL_EXT_swap_control_tear

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
freespace_version: 0.6
0 freespace devices
------------------------------------
OpenGL Version: 2.1
OpenGL Vendor : NVIDIA Corporation
OpenGL GLSL : 1.2
...using GL_ARB_multitexture
...using GL_EXT_direct_state_access
...using GL_ARB_texture_compression
...using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_filter_anisotropic
maxTextureAnisotropy: 16.000000
...using GL_EXT_texture_lod_bias
X..GL_ARB_seamless_cube_map not found
X..GL_ARB_framebuffer_sRGB not found
...using GL_ARB_vertex_buffer_object
Couldn't find proc address for: glBindBufferRange
...using GL_ARB_map_buffer_range
...using GL_ARB_vertex_array_object
X..GL_ARB_draw_elements_base_vertex not found
...using GL_ARB_fragment_program
X..GL_ARB_uniform_buffer_object not found
...using GL_EXT_depth_bounds_test
...using GL_ARB_sync
...using GL_ARB_occlusion_query
...using GL_ARB_timer_query
Couldn't find proc address for: glGetQueryObjectui64vARB
X..GL_ARB_debug_output not found
--------- Game Map Shutdown ----------
--------------------------------------
0: Headphones (Realtek High Definition Audio)
2 channels, 96000 Hz
Front Left and Front Right
Default Console Device, Multimedia Device, Communications Device, and Game Device
1: Speakers (Realtek High Definition Audio)
2 channels, 48000 Hz
Front Left and Front Right
2: Realtek Digital Output (Realtek High Definition Audio)
2 channels, 96000 Hz
Front Left and Front Right
Using device 0
********************
ERROR: GL_ARB_draw_elements_base_vertex not available
********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL
grognard66 2012年10月18日 5時49分 
I get the OpenGL error on my Alienware desktop, which is hooked up to a TV using the nVidia GTX555 video card's HDMI output. I also downloaded the game on my HP desktop hooked up to a monitor (not using HDMI and with an AMD processor) and it works fine. Both computers far exceed the recommended specs listed on the product page and all drivers/OS software is up-to-date. I even tried an older nVidia driver from their website specifically for use with OpenGL and got the same error.
最近の変更はgrognard66が行いました; 2012年10月18日 5時50分
Haloruler64 2012年10月18日 10時02分 
So we've gotten reports of desktops using HDMI and DVI, laptops using HDMI and VGA... I see no connection at the moment.
jerrderoche 2012年10月18日 14時26分 
man this is bs
YetiHairball 2012年10月18日 14時33分 
May have something to do with switchable graphics. I get the opengl error when using the ATI Radeon, but when I switch to the onboard Intel chip, it loads up just fine.
Haloruler64 2012年10月18日 14時37分 
I think it's switchable graphics too.
YetiHairball 2012年10月18日 14時48分 
Ok, after getting it to work with the Intel graphics, I switched back to the Radeon card and it started running...except in a 1280x720 window. When I set to fullscreen with any resolution it crashed. This happened with Doom 3 and the others as well. I added a launch option for fullscreen and it gave me the opengl error. I removed the launch option and now it still won't run anymore.
YetiHairball 2012年10月18日 16時01分 
Ok, it's now working. I have switchable graphics Intel + ATI Radeon 6770m on an HP laptop using leshcat lab drivers 12.9 beta. I am running VGA output to a Samsung computer monitor. My BIOS has the graphics on "fixed."

I switched to the Intel chip and launched Doom 3. I started the game and saved it once I could begin moving my character around. I exited the game and switched over to the Radeon chip. I launched Doom 3 again and it started up in 1280x720 window mode. I went to settings, switched to full screen and selected the resolution I wanted on "Monitor 3". The resolution switched without crashing and has been running fine since.

For some reason using monitor 1 or 2 for fullscreen crashed to desktop. I only have my laptop screen and 1 monitor, so I didn't consider using Monitor 3 until I was completely frustrated and trying anything I could.

Hopefully this will work for someone else. The game plays great and lighting is much improved over the original.
最近の変更はYetiHairballが行いました; 2012年10月18日 16時01分
vault2049 2012年10月18日 23時16分 
The "Monitor 3" solution worked perfectly for me:


Reaper Madness の投稿を引用:
1. On your computer (in this case Windows 7), go to C:\Users\<Your Name>\Saved Games\id Software\DOOM 3 BFG\base. You will find a file called D3BFGConfig.cfg there.

2. Open this file using notepad (right click and use the OPEN WITH command if you need to, and choose Notepad).

3. Scroll down until you find a command line that says set r_fullscreen "1" . This is going to sound strange, but you want to change the 1 to a 3 (set r_fullscreen "3") and it should work. Save the CFG file and run the game. Within the game, be sure to make any resolution setting changes under "Monitor 3"
Haloruler64 2012年10月19日 1時26分 
vault2049 の投稿を引用:
The "Monitor 3" solution worked perfectly for me:


Reaper Madness の投稿を引用:
1. On your computer (in this case Windows 7), go to C:\Users\<Your Name>\Saved Games\id Software\DOOM 3 BFG\base. You will find a file called D3BFGConfig.cfg there.

2. Open this file using notepad (right click and use the OPEN WITH command if you need to, and choose Notepad).

3. Scroll down until you find a command line that says set r_fullscreen "1" . This is going to sound strange, but you want to change the 1 to a 3 (set r_fullscreen "3") and it should work. Save the CFG file and run the game. Within the game, be sure to make any resolution setting changes under "Monitor 3"

Holy ♥♥♥♥ dude, that fixed it! Thanks!!!
FPSCornwall 2012年10月19日 1時49分 
Have posted that this doesn't fix it for me in another thread, but have tried switching to non nvidia graphics on my Laptop (M11X) and get:

DeviceID : MONITOR\SEC5441\{4d36e96e-e325-11ce-bfc1-08002be10318}\0005
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0005
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1280
dmPelsHeight : 720
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...created window @ 0,0 (1280x720)
Initializing OpenGL driver
...SetPixelFormat failed
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): failed
...releasing DC: failed
...resetting display
...shutting down QGL
...unloading OpenGL DLL
Unknown command 'vid_restart'
Unable to initialize OpenGL
Shutting down OpenGL subsystem
...shutting down QGL

When I launch via nvidia graphics on laptop OR via HDMI to external monitor I get:

QA Timing INIT: 000000ms
D3BFG 1.1400 win-x86 Oct 5 2012 11:38:38
1729 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & HTT
4000 MB System Memory
1024 MB Video Memory
Winsock Initialized
Found interface: {826394D5-47EE-491D-93D5-B732EFE84268} DW1520 Wireless-N WLAN Half-Mini Card - 192.168.1.66/255.255.255.0
Found interface: {177175EA-C7EC-4A3C-B468-9AF7F72645E4} Atheros AR8132 PCI-E Fast Ethernet Controller - 0.0.0.0 NULL netmask - skipped
Sys_InitNetworking: adding loopback interface
doom using MMX & SSE for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded resource file _common.resources
Loaded resource file _ordered.resources
Loaded resource file _sound_pc.resources
Loaded resource file _sound_pc_en.resources
Current search path:
C:\Games\Doom 3 BFG Edition/base
C:\Users\Steve\Saved Games\id Software\DOOM 3 BFG/base
file system initialized.
--------------------------------------
WARNING: Unable to open resource file maps/_startup.resources
----- Initializing Decls -----
------------------------------
Couldn't open journal files
execing default.cfg
couldn't exec D3BFGConfig.cfg
couldn't exec autoexec.cfg
----- R_InitOpenGL -----
Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
X..WGL_EXT_swap_control_tear not found
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): failed
...shutting down QGL
...unloading OpenGL DLL
Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
X..WGL_EXT_swap_control_tear not found
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): failed
...shutting down QGL
...unloading OpenGL DLL
Unknown command 'vid_restart'
Unable to initialize OpenGL
Shutting down OpenGL subsystem
...shutting down QGL

Amazing to get this in these days of install and go games!
1-15 / 44 のコメントを表示
< >
ページ毎: 15 30 50