midus Aug 7, 2013 @ 6:21pm
nvidia 3d vision not working
hi, ive searched the forums and cant find anything similar. Ive done all the usual things to get this to work like changing it to quad buffer, a resolution at 120 hz ect. when i reset the game to apply changes the nividia 3d dongle activates like everything seems to be fine but when i put on the glasses all i get is a image flicker and double images of everything. i tried another game to be sure and everything works fine there. anyone run into this problem?
Showing 1-15 of 17 comments
< >
d7602002 Aug 9, 2013 @ 7:15am 
I have not had this problem. I set quad buffer, pick resolution (in game) of whatever, with 120hz, then closed the game, and then repoened it and it worked fine. This is all i did.
midus Aug 9, 2013 @ 10:59am 
arrg. ya thats why i cant find this problem on any forums anywhere. Im not sure why its happening to me. like i said i tried the glasses on a few other games i know worked and i get 3d fine on those games. its when i do this game i dont get any 3d at all just wierd flicker 2d images. but when i remove the glasses the monitor looks like it would normally for 3d
neoclerodane Jun 26, 2014 @ 9:57am 
This is an old topic - but I am having the same issue. 3D Vision is working in other titles, but for some reason - it is not working here with the exact same symptoms you describe.

Did you ever get your issue resolved?
Jeff Jul 18, 2014 @ 1:12pm 
Just get a Samsung moniter with 3d on or off with there glasses works with all games and the problems solved.This game on large 55 inch 3D tv is crazy eye candy.
neoclerodane Aug 1, 2014 @ 5:57am 
Originally posted by Jeff:
Just get a Samsung moniter with 3d on or off with there glasses works with all games and the problems solved.This game on large 55 inch 3D tv is crazy eye candy.

But I have a fairly good monitor - and I would love to experience this title in its 3D glory! My current monitor is a BenQ XL2420Z - it's really nice.
midus Aug 1, 2014 @ 12:05pm 
nope still doesnt work for me. and i have the 144hz asus 3d monitor. im not gonna get a brand new monitor just to play that single game in 3d. somehow i dont think its the monitor anyways
Levis Aug 11, 2014 @ 11:16pm 
Same problem for me, I can't get Doom 3 BFG to run in 3D. I am using VG278H monitors in surround and NVIDIA 3D vision 2. I am setting it to quad buffered, tryed multi and single screen resolutions (120hz and 60 hz). The IR emittor and glasses are staying off. That's the only game I have that is supposed to work in 3D that actually don't start in 3D at all. Someone got answers for this?
JC21 Sep 21, 2014 @ 7:45am 
Finally, after trying every possible combination in the settings I got it to work on my ASUS VG278HR with Nvidia 3D vision 2. The solution seems really easy....

1. Open the game and change the 3D VIEW to Quad Buffer.
2. Restart the game.
3. Change your resolution to 1920x1080 @120Hz.

If you already have the resolution set then change it to something like 1024x768 @120Hz (this will activate 3d vision) and set it back to what you want. You will have to do this every time you open the game.... Post if this solved the problem for you.
Levis Sep 21, 2014 @ 7:55am 
Got it for 3D surround people: for 3D, disable surround in NVIDIA control panel. You can have only either of 3D or surround : (
Lone Wolfe Oct 5, 2014 @ 11:44am 
I got a new gfx card and it worked for a while and back to not triggering IR receiver. Id/Bethesda needs to fix this as it is p!ssing us off majorly!
midus Oct 14, 2014 @ 5:40pm 
really you cant have 3d and surround? thats pretty sucky. ive run into more problems with things working with surround then anything. most games have the ui to large or it crashes or any number of problems... ill try that one monitor 3d option and see if that works
Lone Wolfe Mar 24 @ 2:21pm 
Originally posted by midus:
arrg. ya thats why i cant find this problem on any forums anywhere. Im not sure why its happening to me. like i said i tried the glasses on a few other games i know worked and i get 3d fine on those games. its when i do this game i dont get any 3d at all just wierd flicker 2d images. but when i remove the glasses the monitor looks like it would normally for 3d

The date here in Australia is now the 25th of march 2015 and it's still happening to me BIG TIME too. The IR receiver won't trigger only the left eye renders (Or the right one if eye swap is on) the Shoulder lamp beam is opaque and the weapons a♥♥♥♥♥♥uges are garbled beyond the point of unreadability.

$40USD wasted buying doom 3 for the SECOND time just to play it in 3D

Using Nvidia 3D Vision 2 setup on 4Ghz i7-4790k rig with16Gb ram and 4Gb GTX760 OC Edition

I sent a support ticket to Bethesda. They should get back to me in 3-5 business years :(
Last edited by Lone Wolfe; Mar 24 @ 2:25pm
dypsomaniart May 8 @ 6:22am 
same here, but I finally got it to work. After giving up and just playing it through in 2d already.

My solution was to change from 1920x1080 120hz ( my monitors native res) down to lower res. 1680x1050 120hz magically worked, and all lower settings. So That got it working, But the next time I started the game it was broken again. Changed the resolution from 1680 back up to 1920 and it fixed it. Now every time i start it, it's broken, in whatever res it was left in when i last quit it, so I just change the screen res down, the res changes (screen flicks off and comes on again with properly working 3d) and i select "yes" i want to keep that res", then just change it straight back up again (to 1920 which now works fine) BEFORE I leave the pause screen, and it should stay fixed (until you restart). Other settings are: quad buffer 3d, v-sync off, motion blur off, 120fps. This is working for me using the 3d vision 2. Hope that might help some people.
It seems that the nvidia drivers dont realise it needs to be running nvidia 3d until you change the res in game.
My Pc is running gtx780ti sc sli, i74790k
Last edited by dypsomaniart; May 8 @ 6:54am
Jeff May 19 @ 1:40am 
Originally posted by neoclerodane:
Originally posted by Jeff:
Just get a Samsung moniter with 3d on or off with there glasses works with all games and the problems solved.This game on large 55 inch 3D tv is crazy eye candy.

But I have a fairly good monitor - and I would love to experience this title in its 3D glory! My current monitor is a BenQ XL2420Z - it's really nice.
I bought the BenQ 27inch gave the samsung to father in law.Question do you use HDMI and if so do you get 120hrz and is dvi better then HDMI?Thx.
Lone Wolfe May 19 @ 2:13am 
I used to have that issue. Try making sure under nvidia control panel that 120Hz is set in "change resolution" then start the game, select 1920x1080x120Hz, then go to 3D and select quad buffer, then exit the game. then relaunch the game. if that fails, delete the ini file in "Users/YOURNAMEHERE/saved games/id software/doom 3 bfg edition/base" and repeat the first steps again.
Last edited by Lone Wolfe; May 19 @ 10:24pm
Showing 1-15 of 17 comments
< >
Per page: 15 30 50