DOOM 3: BFG Edition > Γενικές συζητήσεις > Λεπτομέρειες θέματος
Living Tribunal (Αποκλεισμένος) 9 Φεβ, 2013 @ 1:19μμ
Having issues like grey screen start up? Here's your fixes!
If anyone has issues launching doom 3 bfg edition here's how you fix the desktop crash issue. A) Radeon users you are required to update your legacy drivers for your graphics card, B) Nvidia users you have to turn off the AA or change it like with RAGE, and you have to update to the most current drivers, and C) Right click on the desktop or launch icon you use, and change the compatibility to xp service pack 2 as any others like sp3, sp1, vista, and so on will not work! Now, try it.

Here's some more fixes, and somethings I already said!

Possible Solution 1: Run the game as ‘Run as Administrator’ by right clicking. If you are using Steam then navigate to:

32bit – C:\Program Files\Steam\steamapps\common\doom3.exe
64bit – C:\Program Files (x86)\Steam\steamapps\common\doom3.exe
Right click on game.exe and select “Run as Administrator”.
"Will be the .exe with the pentagram icon"

Possible Solution 2: Run the game in compatibility with Windows XP SP2[only one that will work full on golden!].

Possible Solution 3: If game doesn’t launch, make sure you’re connected to the internet and try restarting Steam/your computer.

Possible Solution 4: Also, you can try to lower the game’s settings by disabling VSync and multi-sampling and turning down environment detail levels.

Possible Solution 5: Try to Update Your Graphics Cards and Motherboard Drivers

Possible Solution 6: Try different resolution options on your PC.

Possible Solution 7: For NVidia users, go into NVidia control panel and add your game.exe and make it "use NVidia GPU" to resolve this issue. And also try this, go to NVidia control panel and check if game.exe has to instances. If there are two instances, set both to use your specific GPU instead of automatic.
Εμφάνιση 1-10 από 10 σχόλια
< >
MKVLI 11 Φεβ, 2013 @ 11:53πμ 
On my older gfx card it only had 512 dedicated memory and the game started up grey if the resolution was set too high. It went away on lower res like 1024x768. Another way to make the image come back was to minimize the game & bring it back up. I got a new Nvidia card and can now run at 1920x1080.
Τελευταία επεξεργασία από MKVLI; 11 Φεβ, 2013 @ 11:55πμ
Living Tribunal (Αποκλεισμένος) 13 Φεβ, 2013 @ 12:35πμ 
I've seen that before on my friend's laptop.
davidbenko 13 Φεβ, 2013 @ 8:44πμ 
I have the grey screen crash with "Doom 3 BFG edition has stopped working", none of the above worked for me sadly. Apart from the compatibility mode which hung my session forcing me to log out.

I have a Sony Vaio Laptop with ATI Mobility Radeon HD 5145. Clearly this game has been released as a buggy mess. As there's a no refund policy at Steam lets hope they patch it quick. Things should just run these days.
Living Tribunal (Αποκλεισμένος) 13 Φεβ, 2013 @ 12:26μμ 
Αναρτήθηκε αρχικά από davidbenko:
I have the grey screen crash with "Doom 3 BFG edition has stopped working", none of the above worked for me sadly. Apart from the compatibility mode which hung my session forcing me to log out.

I have a Sony Vaio Laptop with ATI Mobility Radeon HD 5145. Clearly this game has been released as a buggy mess. As there's a no refund policy at Steam lets hope they patch it quick. Things should just run these days.

Did you use their tools from AMD here? http://support.amd.com/us/gpudownload/windows/Pages/auto_detect.aspx
Living Tribunal (Αποκλεισμένος) 13 Φεβ, 2013 @ 6:49μμ 
If that doesn't work feel free to add me, and if we are online at the same time at some point I'd be more than happy to help you get it running I run intel/nvidia and amd/radeon rigs and a few other mix and matches lol. Also, the fault isn't on ID, but bethesda who's a bit sloppy with other people's code and even their own...the fixes I mentioned are the normal fixes, so you probably have a different problem...another thing that would help is if you told me more about your setup and if you could possibly try to tell me what Doom3 BFG says when you get that...I mean usually when it goes to that crash...it will bring up an error report message...if you tell me what that message says the best you can or manage to screenshot it/take a pic with your phone, imagebam, and then link the imagebam pic here...I can figure out much faster what your problem is...I did a testing project on the original, and even that had a bit of bugs, but ya...bethesda made it a tad worse on their own...it has been patched, so one more question is when did you install it last? Because there also has been an update to fix the install problem...so, you could also be missing a pack file...if not recently...I'd try to reinstall it, verify the cache as well. The reason I mentioned the above tool is because the AMD tool will give you more recent legacy drivers, and let you know if there is an update for yours....so, just make sure first that the tool is confirming that you are up to date rather than you just claiming...that is the most common problems....also you do have a modern enough card to run it....another thing that can help is going to systemrequirements lab, and seeing if you can run it...with your rig I'm assuming it is going to fail, but that is because they prefer you having modern, so posting your report from that can also help me out understanding your problem.
Living Tribunal (Αποκλεισμένος) 13 Φεβ, 2013 @ 6:50μμ 
That applies to anyone by the way...if none of my listed normal fixes help you out, or you don't understand a step and need help...you can add me and help you out faster, so we can get it running for ya....if there are any in game problems other than that I'd be more than happy to help you with that too.
oranjkrush64 5 Οκτ, 2013 @ 11:04πμ 
Had the same problem running a stock Gateway FX 6840-15e machine with ATI Radeon HD 5750. Tried many different things. This is what worked for me. Updated drivers to latest. Added Doom3BFG.exe to 3D Application settings in AMD CCC. Set "use application settings" in AMD CCC 3D application settings. Started Doom3 in 3D then disable 3D after game is running. Weird.
Living Tribunal (Αποκλεισμένος) 5 Οκτ, 2013 @ 12:02μμ 
Αναρτήθηκε αρχικά από oranjkrush64:
Had the same problem running a stock Gateway FX 6840-15e machine with ATI Radeon HD 5750. Tried many different things. This is what worked for me. Updated drivers to latest. Added Doom3BFG.exe to 3D Application settings in AMD CCC. Set "use application settings" in AMD CCC 3D application settings. Started Doom3 in 3D then disable 3D after game is running. Weird.

That's because of the engine they're running is based off the IDTech5 which is one of the engines that loves to strain many rigs. So, ya that's most likely why that worked for you. Disbaling things from AA, VSync, and certain 3D options.
Kamen8 23 Μαϊ @ 5:57πμ 
GUYS
Living Tribunal (Αποκλεισμένος) 23 Μαϊ @ 6:21πμ 
I completely forgot about this thread I created...
Εμφάνιση 1-10 από 10 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 9 Φεβ, 2013 @ 1:19μμ
Αναρτήσεις: 10