I Want to Believe 30 nov 2012 om 8:58vm
A Likely Solution for People Who Can't Get This Game to Run
Go into your Doom 3 BFG Edition folder that's in your steamapps location, find the folder msvc_2010, open it up, and run the vcredist_x86 manually. Usually the vcredist_x86 is automatically run whenever a new game is launched for the first time through Steam, but for some reason, Doom 3 BFG Edition doesn't do this.

Customer support is completely incompetent, telling people their usual default run of "delete the clientregistry.blob and check your router" which just doesn't work. I even told them EXPLICITLY "I don't even get the standard first-time-run C++ Redistributable window." There's something about Doom 3 BFG Edition's programming that doesn't run the vcredist_x86 program on its first run, and so that might make it unplayable. (For some reason, I could run Doom 3 BFG Edition on one computer despite this problem, but that computer also had normal Doom 3 installed once upon a time.)

Maybe I should apply to work for Valve as customer support.
Laatst bewerkt door I Want to Believe; 30 nov 2012 om 8:59vm
1-15 van 22 reacties weergegeven
< >
nmirosavljevi 30 nov 2012 om 10:21vm 
Oh dear god are they incompetent! They can't even send me one damn email! Anyway, i was hoping you could resolve this for me. Doom 3 is fully capable of running, but the Doom 1 & 2 games don't work. I can enter their menus but that's it. Only the arrow keys work. I tried a lot of stuff: "Graphic uptate whitch enabled Doom 3, Resetting, Starting the vcredist_x86 manually, adding the msvcr100.dll file." Still, nothing happens. It shouldn't be about the too advanced system. The games were revamped for advanced machines. Some of my laptop traits: Graphic card: Nvidia GeForce 150M, 4GB RAM, OS: Windows 7 (x64).
I Want to Believe 30 nov 2012 om 4:49nm 
Sorry; can't help you there, since I'm not having that issue.
jimht 30 nov 2012 om 6:57nm 
My system runs Doom 3 beautifully. I cannot get this version to even start up. I figured out for myself the step you outlined in the top post here, and the game turns the screen black and then crashes out. I'm having a VERY hard time believing that this got a proper amount of QA testing before being released. There's no way.
z_day_24_7 30 nov 2012 om 7:41nm 
Doom 3 doesn't launch for me. The solutions presented so far sound great. I can't get vcredist_x86 to run manually; it says "A newer version of Microsoft Visual C++ 2010 Redistributable has been detected on the machine."

And I get this after launch aborts:

QA Timing INIT: 000115ms
D3BFG 1.1400 win-x86 Nov 9 2012 10:38:21
2400 MHz AMD CPU with MMX & 3DNow! & SSE & SSE2 & SSE3 & HTT
5888 MB System Memory
256 MB Video Memory
Winsock Initialized
Found interface: {4DD19DCB-6758-44F5-8901-73FEDCEA6E2B} JMicron PCI Express Gigabit Ethernet Adapter - 0.0.0.0 NULL netmask - skipped
Found interface: {9C3BDBA2-0620-46E1-B305-97B8D9A9AB3A} Microsoft Virtual WiFi Miniport Adapter - 0.0.0.0 NULL netmask - skipped
Found interface: {FA9A2592-346C-4554-891C-B96C5116BE32} Atheros AR9285 Wireless Network Adapter - 192.168.1.129/255.255.255.0
Sys_InitNetworking: adding loopback interface
doom using MMX & SSE for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded resource file _common.resources
Loaded resource file _ordered.resources
Loaded resource file _sound_pc.resources
Loaded resource file _sound_pc_en.resources
Reading resource CRCs...
Current search path:
C:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition/base
C:\Users\will123\Saved Games\id Software\DOOM 3 BFG/base
file system initialized.
--------------------------------------
WARNING: Unable to open resource file maps/_startup.resources
----- Initializing Decls -----
------------------------------
Couldn't open journal files
execing default.cfg
couldn't exec D3BFGConfig.cfg
couldn't exec autoexec.cfg
----- R_InitOpenGL -----
Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
X..WGL_EXT_swap_control_tear not found
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: ATI Mobility Radeon HD 4200
StateFlags : 0x5
DeviceID : PCI\VEN_1002&DEV_9712&SUBSYS_1B621043&REV_00
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{6DC952D7-2F8D-4915-BC35-767FB654521F}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\CMO1593\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1366
dmPelsHeight : 768
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...calling CDS: ok
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: ATI Mobility Radeon HD 4200
StateFlags : 0x5
DeviceID : PCI\VEN_1002&DEV_9712&SUBSYS_1B621043&REV_00
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{6DC952D7-2F8D-4915-BC35-767FB654521F}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\CMO1593\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1280
dmPelsHeight : 720
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...created window @ 0,0 (1280x720)
Initializing OpenGL driver
...creating GL context: failed to create OpenGL 3.2 context
created OpenGL 2.0 context
succeeded
...making context current: succeeded
X..WGL_EXT_swap_control_tear not found

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
freespace_version: 0.6
0 freespace devices
------------------------------------
OpenGL Version: 2.1
OpenGL Vendor : ATI Technologies Inc.
OpenGL GLSL : 1.3
...using GL_ARB_multitexture
X..GL_EXT_direct_state_access not found
...using GL_ARB_texture_compression
...using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_filter_anisotropic
maxTextureAnisotropy: 16.000000
...using GL_EXT_texture_lod_bias
X..GL_ARB_seamless_cube_map not found
...using GL_ARB_framebuffer_sRGB
...using GL_ARB_vertex_buffer_object
...using GL_ARB_map_buffer_range
...using GL_ARB_vertex_array_object
X..GL_ARB_draw_elements_base_vertex not found
...using GL_ARB_fragment_program
X..GL_ARB_uniform_buffer_object not found
X..GL_EXT_depth_bounds_test not found
X..GL_ARB_sync not found
...using GL_ARB_occlusion_query
X..GL_ARB_timer_query not found
X..GL_EXT_timer_query not found
X..GL_ARB_debug_output not found
--------- Game Map Shutdown ----------
--------------------------------------
0: Speakers (High Definition Audio Device)
2 channels, 44100 Hz
Front Left and Front Right
Default Console Device, Multimedia Device, Communications Device, and Game Device
Using device 0
********************
ERROR: GL_ARB_draw_elements_base_vertex not available
********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL

I don't have anything saved in the "Saved Games" folder either.

Haven't been able to run it once.
z_day_24_7 30 nov 2012 om 7:48nm 
From Microsoft's website, I downloaded x86 and x64 versions of Visual C++ 2010 and only one installed and I think it's because the machine OS is 64-bit. It's running Win 7 Service Pack 1 on AMD Turion II P540 Dual-Core 2.4Ghz
Jackerz59 30 nov 2012 om 9:14nm 
I never bought this game off steam because it was $20 more than were I got it from, I guess getting the hard copy of this game that ties to Steam is the better one
Jackerz59 30 nov 2012 om 9:47nm 
If link is down, tell me
http://www.multiupload.nl/JFFLXSU6G2

This will fix 99% of problems
=)(==Penetrator==> 1 dec 2012 om 10:28vm 
OMG, i have a fresh Window 7 Pro, and Steam installed, my first download game is doom 3 bfg and i cant run it..
AyezRed 1 dec 2012 om 10:30vm 
I'm running the game jsut fine with an Asus G74, I gotta say that it is unfortunate that people can't get this game to run. I love it. +1 for helping people try to figure out how to get this game going on thier pc's.
=)(==Penetrator==> 1 dec 2012 om 11:11vm 
OK I got my BFG to run by install the following programs below.

Install this one first
http://www.microsoft.com/en-us/download/details.aspx?id=5555

Install this one next
http://www.microsoft.com/en-us/download/details.aspx?id=35

After you have installed this programs and your BFG still doesnt work, sorry i cannot help you.

My current PC environment
Fresh install of Windows 7 Pro x64
Fresh install of Steam and BFG Edition.

Good luck fellow gamers.
Your fellow penetrator.


Laatst bewerkt door =)(==Penetrator==>; 1 dec 2012 om 11:11vm
jimht 1 dec 2012 om 11:43vm 
FYI, BOTH of those installers are in the game folder in C:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition folder. The first screwup with this game is that these installers are not automatically launched at first run.

HOWEVER, I've tried this game on two diffrent Win 7 systems, and the game runs on neither of them. Black screen, then light grey screen, and then a notice that the game has crashed.
jimht 1 dec 2012 om 11:47vm 
Origineel geplaatst door jackerz59:
If link is down, tell me
http://www.multiupload.nl/JFFLXSU6G2

This will fix 99% of problems

Uh... yeah.... you're going to have to give me more to go on than that...
z_day_24_7 1 dec 2012 om 1:54nm 
I DL'd the Jackerz59 and WinRAR came back saying the zip was corrupt so I rebuilt it and extracted the x64 versions of the cabs in there. Now what?
Jackerz59 1 dec 2012 om 3:37nm 
ok instructions for before were in the nfo.txt file after you download it, the files are off the legit disk copy as it also states in the nfo
Jackerz59 1 dec 2012 om 3:37nm 
Origineel geplaatst door z_day_24_7:
I DL'd the Jackerz59 and WinRAR came back saying the zip was corrupt so I rebuilt it and extracted the x64 versions of the cabs in there. Now what?
read the nfo.txt under instructions
1-15 van 22 reacties weergegeven
< >
Per pagina: 15 30 50
Geplaatst op: 30 nov 2012 om 8:58vm
Aantal berichten: 22