SMichaelReeves 26 de May, 2013 a las 17:48
DooM 3 BFG And ATI Graphics Cards
I know alot of users are having this issue so let me tell you what I have done.. I started with my first system with a Intel 550ti graphics card. I bought BFG on disk, installed it on my Windows XP machine, it works as expected, no issues. I installed this on TWO machines with a ATI HD5770 card, different motherboards, different ram, and BFG WILL NOT RUN!! I then went out and bought a ATI 7850 and same dam thing happened. After all this fighting, I installed an old Intel / Geforce 8800 graphics card on one of the machines that had a ATI 5770 previously installed on it and it ran like a champ!!! NO ISSUES !!!! ( AWSOME RIGHT? )

BFG SEEMS TO NOT RUN ON ATI CARDS!! ATI DOES NOT SUPPORT OPENGL THEREFOR IT WONT RUN! IF YOU ARE GOING TO PLAY THIS GAME, SAVE YOUSELF ALOT OF TIME, EFFORT AND HEARTACHE AND USE AN INTEL / NVIDIA CARD IF YOU ALREADY HAVE ONE.!!
Mostrando 1-8 de 8 comentarios
< >
Deltagram 27 de May, 2013 a las 11:17 
Catalyst 13.4 has OpenGL 4.3. It's just flawed or something.
KillerAtWar 27 de May, 2013 a las 12:11 
It actually does work with ATI cards I`m sure I found the fix on these forums a few weeks ago.
Start a multiplayer game then quit it then start campaign.
Might have to do that everytime you want to start campaign though.
Hopefully that will have it working for you.
I run it on a 6870 Cat 13.4 drivers.
burialfaith 27 de May, 2013 a las 13:54 
Publicado originalmente por KillerAtWar:
It actually does work with ATI cards I`m sure I found the fix on these forums a few weeks ago.
Start a multiplayer game then quit it then start campaign.
Might have to do that everytime you want to start campaign though.
Hopefully that will have it working for you.
I run it on a 6870 Cat 13.4 drivers.

nice that "fixed" the game for me! I thank you!
SMichaelReeves 27 de May, 2013 a las 18:49 
when I go to start the game, the game tried to lod and then a command box ( sort of like the one that windows uses) pops up with alot of info and the game does not even start ssssooo as far as starting a multiplayer or even a single player game, that is not heppening.
KillerAtWar 27 de May, 2013 a las 21:48 
Publicado originalmente por SMichaelReeves:
when I go to start the game, the game tried to lod and then a command box ( sort of like the one that windows uses) pops up with alot of info and the game does not even start ssssooo as far as starting a multiplayer or even a single player game, that is not heppening.
Try going into windows control panel to your sound options & change it to 16bits 48000 Hz dvd quality aswell or lower.
ie if its realtek..etc
quake4ever2007 21 de Jun, 2013 a las 16:20 
Publicado originalmente por SMichaelReeves:
I know alot of users are having this issue so let me tell you what I have done.. I started with my first system with a Intel 550ti graphics card. I bought BFG on disk, installed it on my Windows XP machine, it works as expected, no issues. I installed this on TWO machines with a ATI HD5770 card, different motherboards, different ram, and BFG WILL NOT RUN!! I then went out and bought a ATI 7850 and same dam thing happened. After all this fighting, I installed an old Intel / Geforce 8800 graphics card on one of the machines that had a ATI 5770 previously installed on it and it ran like a champ!!! NO ISSUES !!!! ( AWSOME RIGHT? )

BFG SEEMS TO NOT RUN ON ATI CARDS!! ATI DOES NOT SUPPORT OPENGL THEREFOR IT WONT RUN! IF YOU ARE GOING TO PLAY THIS GAME, SAVE YOUSELF ALOT OF TIME, EFFORT AND HEARTACHE AND USE AN INTEL / NVIDIA CARD IF YOU ALREADY HAVE ONE.!!


Try this. Right click on Doom3BFG.exe located in Steam\steamapps\common\DOOM 3 BFG Edition. Select properties then compatibility then check the box for "Run this program in compatibility for" and select Windows XP (Service Pack 3). Click apply then ok. Start up Doom 3 BFG from steam. If it still doesn't work try a lower verison of Windows "Windows ME". For more help on Doom 3: BFG Edition go HERE
Última edición por quake4ever2007; 22 de Jun, 2013 a las 14:56
Rockhead Gaz 23 de Jun, 2013 a las 17:34 
AMD drivers obviously have OpenGL support. If they didn't, nobody would use OpenGL, because they'd be potentially cutting their userbase in half. Total misinformation going on here.

Just as an aside, I played this and Rage, both OpenGL games, on two different AMD cards. How is this madness possible, given that they allegedly don't have any OpenGL support?
CBRN 26 de Jun, 2013 a las 16:14 
http://support.amd.com/us/kbarticles/Pages/AMDCatalyst132BetaDriver.aspx

Install the 13.2 beta drivers from Feb this year. They work perfectly fine and I got a few hours of gameplay without problem
Mostrando 1-8 de 8 comentarios
< >
Por página: 15 30 50
Publicado el: 26 de May, 2013 a las 17:48
Mensajes: 8