DOOM 3: BFG Edition

DOOM 3: BFG Edition

Mike 2013 年 10月 12 日 @ 下午 3 時 29 分
Grey Screen?
First time ever running it when i got it a few months back it ran flawlessly, no grey screen or anything but i installed it again today and all of a sudden i get a grey screen followed by a black one followed by a flickering option to choose 3 of the games, once clicked it just has sounds, anyone find a fix for this that doesn't require downloading files from people?
< >
目前顯示第 1-10 則留言,共 10
motorsep 2013 年 10月 12 日 @ 下午 7 時 31 分 
Maybe downloading new drivers will help?
Mike 2013 年 10月 12 日 @ 下午 9 時 27 分 
i have the latest one, tried everything from compatibility, verifying integrity cache, uninstall/reinstall nothing to avail :/
motorsep 2013 年 10月 12 日 @ 下午 11 時 21 分 
by latest you mean what version?
Fietsenboer 2013 年 10月 13 日 @ 上午 6 時 19 分 
I have the exact same thing. It used to run just fine. Running an HD7970 with cat 13.11 beta 1

Fixed it by following the steps from
Simple .dll file for opengl.
最後修改者:Fietsenboer; 2013 年 10月 13 日 @ 上午 6 時 33 分
Mike 2013 年 10月 13 日 @ 上午 7 時 55 分 
Motorsep, 13.11 beta 1 like Fietsenboer stated. and i prefer to not download files from websites i don't know of :/
motorsep 2013 年 10月 13 日 @ 上午 9 時 45 分 
openg32.dll is in the driver's package, you just need to copy it from where it is on your HDD to your Doom 3 BFG folder, where .exe is.

Alternatively, you can try rolling back to 13.9 driver and see it that works.
Fietsenboer 2013 年 10月 13 日 @ 上午 11 時 39 分 
What Motorsep said. The file can be obtained by installing an older official driver and copy it from there to the doom3 dir. No need to download scary files from unknown sources.
Mike 2013 年 10月 13 日 @ 上午 11 時 46 分 
Well motorsep and Fietsenboer it worked thanks again :) basically re-rolled back to 13.9 and copied the old meta file and it worked
motorsep 2013 年 10月 13 日 @ 下午 6 時 01 分 
So let's clear it up - using 13.9 works, using 13.11 doesn't and all that without copying opengl32.dll into BFG's dir?

What is meta file?

The reason I am asking is that I know a guy who AMD's unofficial Linux tester and thanks to him some bugs get fixed. So I need to make sure I can report this as accurately as I can, as he makes test cases for us, BFG gamers from time to time.

Could you post your hardware/software configuration? (exact CPU, GPU, OS models)
Mike 2013 年 10月 13 日 @ 下午 6 時 18 分 
Basically yeah reverting back to 13.9 Works and i've tested two options

1. Driver 13.11 (Newest One) with the Installed files of Oct 13 2013 that method resulted into failure.

2. (Success) Revert back to 13.9 , Meta file as in the first time i ever played it i've read up on these problems therefore i made a backup of those files and copied those into the current folder and replaced all the (Newly Installed ones), that worked flawlessly.

< >
目前顯示第 1-10 則留言,共 10
每頁: 15 30 50

張貼日期: 2013 年 10月 12 日 @ 下午 3 時 29 分
回覆: 10