blood_Sam 11. Okt. 2013 um 14:23 Uhr
[Solved] Game is blurry on Intel HD4000
It looks like this:

http://cloud.steampowered.com/ugc/846966879108938126/E4331485BE9FEA099ED39E270E4E03700BD27477/

On the AMD GPU, the game is sharp, but it stutters, like Rage, thanks to the crappy idTech 5.
Anyone knows how to fix this ?
Zuletzt bearbeitet von blood_Sam; 12. Okt. 2013 um 4:32 Uhr
Beiträge 1 - 7 von 7
< >
motorsep 11. Okt. 2013 um 15:35 Uhr 
eeh, your header says it gets blurry on Intel GPU, yet in the body of text you say "AMD GPU". Please make up your mind.

Btw, idTech 5 isn't crappy, it's either your hardware or your hands ;)

EDIT: Try rs_enable 0, that should stop BFG engine from downscaling picture to maintain 60 fps framerate (but please don't complain about low fps with crappy Intel hardware).
Zuletzt bearbeitet von motorsep; 11. Okt. 2013 um 16:07 Uhr
blood_Sam 12. Okt. 2013 um 3:49 Uhr 
I have a laptop with switchable graphics, that's why I can run games on Intel graphics or AMD GPU.

And idTech 5 is a shame. Almost no customizable option in menus, performance problems on a lot of computers... For me, games made with idTech 5 stutter with the AMD GPU, and I can't find why. Maybe AMD is fautive with its drivers or the "Enduro" technology, but the engine is a part of the problem. I tried several solutions, without success...

The only solution working is running the games with the Intel graphics, it's still playable but in Doom 3, the resolution isn't right, that's why I'm posting here.
However, thanks for the command, I will try that later and post if it's working or not :)
blood_Sam 12. Okt. 2013 um 4:32 Uhr 
Well, it's fully working !
Indeed the framerate is a bit lower, but I can use "r_skipPostProcess 1", to improve it.
Thanks a lot :)
motorsep 12. Okt. 2013 um 10:29 Uhr 
Glad it worked!

idTech 5 supplied with Rage is a bit raw, but has no issues with Nvidia hardware. Which means AMD just simply can't manage to get good video drivers going.

Try setting your laptop to performance mode in power saver option. This way it will have AMD GPU on at all times. Then istall AMD 13.10beta driver and turn off Catalyst AI. That should do it.
Zuletzt bearbeitet von motorsep; 12. Okt. 2013 um 10:29 Uhr
blood_Sam 12. Okt. 2013 um 11:49 Uhr 
I can't use the computer with only the AMD GPU running (some laptop have this option in BIOS), but I can assign a GPU to every game/application I have, in the CCC.
I already tried without Catalyst AI, in vain.

Nevermind, these games are not really heavy, and the iGP can run them pretty well.
motorsep 12. Okt. 2013 um 12:47 Uhr 
Right, I know that. I am saying that in such laptops as yours, when you switch off power saving and go into performance mode, the system switched to AMD GPU automatically, permanently, until you set energy saving option back on.
blood_Sam 12. Okt. 2013 um 14:19 Uhr 
I think this is the "Powerplay" option in the CCC, but it doesn't automatically swith to the AMD GPU in my case (and I always play in High Power mode).
But maybe it works like that if the laptop works in Fixed mode ; there is two switchable graphics mode, depending of the laptop:
- Fixed mode: the switch between iGP and GPU depends of the power source (so maybe power plan also).
- Dynamic mode: it works the way I described before, my laptop uses this mode.

More informations here: http://h10025.www1.hp.com/ewfrf/wc/document?cc=fr&lc=fr&dlc=fr&docname=c03048374#N139
Some laptops allow the two modes in the BIOS, some also allow to completely disable the iGP (essentially high-end laptops such as MSI, Alienware...).

This technology was problematic when updating drivers, but it seems to be a bit better now, we can finally update Intel and AMD drivers independantly (atleast with a recent configuration, not sure if it works with older processors and graphic cards...)
Beiträge 1 - 7 von 7
< >
Pro Seite: 15 30 50
Geschrieben am: 11. Okt. 2013 um 14:23 Uhr
Beiträge: 7