DOOM 3: BFG Edition

DOOM 3: BFG Edition

View Stats:
Ghost Man Nov 12, 2013 @ 7:43pm
Stupid crash of Hell
I bought Doom 3 BFG edition sometime in july and it worked fine when I first played it. but starting around October the game has been crashing on the start up. When the Bethesda logo pops up it pauses at the B and then crashes. I have to Alt f4 to get out. So i try setting the start up command to skip the intro videos. now it just freezes at the copyright stuff. Sometimes the screen some how gets to the part where it tells you to select your game, you know the part where it asks to choose either to play doom 1, doom 2, or doom 3 then it crashes. I'm trying all sorts of ideas on fixes for this but no luck. If anyone has any ideas how to fix this I will greatly appreciate it.

My pc rig is

Intel core i3 cpu 550 3.2 Ghz
Windows 7 Home Premium 64 bit
6 gb ram
Intel HD graphics core i3
< >
Showing 1-6 of 6 comments
motorsep Nov 12, 2013 @ 7:51pm 
Tried updating video drivers from Intel's website?
Ghost Man Nov 12, 2013 @ 8:03pm 
I looked up Intel website and did a scan to see for any updates. They said my driver is up to date. But now that i did that, I remember when I first launched left 4 dead and I got a message screen saying valve has no record of my video driver in their data base. Could that possibly be a reason why my game is acting up, or is it just my graphic card sucks.
motorsep Nov 12, 2013 @ 9:57pm 
Your GPU sucks (specifically for OpenGL), without a doubt :) Based on this your GPU is ancient. You might not be able to run BFG at all. But, give it a spin with this driver:*&DownloadType=Drivers
Ghost Man Nov 13, 2013 @ 7:23am 
Didn't work, I still am wondering how the game worked before though. When I first downloaded the game and played, it worked fine but it just suddenly started crashing after 2 months. I'm gonna browse around intel's website and see if they have any drivers for OpenGL
motorsep Nov 22, 2013 @ 10:50am 
It could be as simple as BFG got some changes with the patch that was released shortly after the game's release and in newer drivers Intel has no support for your GPU (for OpenGL). That's why you can't run it.

Try setting launch option +set r_useOpenGL32 2 or +set r_useOpenGL32 0 and see if that helps at all.

You should probably just save ~$80 and buy dedicated video card, something like this (just as an example) (probably will be cheaper on Black Friday). 128-bit bus is not as good as 256bit, but definitelly better than you Intel GPU :)
Ghost Man Nov 22, 2013 @ 11:30am 
Unfortunately that also didn't work. Well now the only way for me to play the game is either
1. Wait for a patch for the game that has compatibility for my video card
2. Intel updates the drivers to match Doom 3 BFG's requirement
3. Just buy a better video card

Well anyway, thanks for helping me out with this issue
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: Nov 12, 2013 @ 7:43pm
Posts: 6