FuscusNight May 13 @ 12:57pm
The micro stuttering , dear god the micro stuttering
I allready made a thread about this a while ago when i bought the game and i thought the issue got fixed when i turned on Vsync but it didn't, it just went away for a while and than came back full force.
What trigers it ? Have no idea, i might play the game for 5 minutes(or more) without any stuttering and than suddenly it starts having these weird micro stutters every few seconds or minute and even the audio files starting to emit static or even cut off for a brief moment and continue playing again.
Jesus christ this BFG edition is a huge mess, no game iv'e played so far had such a huge issue with stuttering, they market it as a "smooth" 60 or 120 FPS experience yet it keeps diping to 1 FPS randomly for a split of a second which is driving me insane.

I seriously doubt this is an issue with my PC, i'm not experiencing any problems with the other current games iv'e been playing lately (except for Doom 3 BFG of course) , iv'e checked my temperatures and they bearly hit 60 c when playing BFG.

My specs :
Intel 4670k 3.40 ghz
8GB of DDR3 RAM 1600Mhz
Nvidia 760 GTX 2 GB
Windows 8.1 64-bit

Is there no fix to this ? Iv'e googled the problem and all i found is one or two threads reporting the same problem back in 2013 with no valid fixes for the problem.

*update*
I tried one last thing and it seems it helped so far, turning off vsync in the game and than forcing it via Nvidia's controll pannel seems to reduce the amount of stuttering.
I simply forced Adaptive vsync and turned on Triple Buffering and so far the game has been running much better allthought it still occasionaly stutters but it primarly happens when the game is trying to load a new section of a level.

Still this unacceptable , specially since it's a game made by ID and it's an old game yet it has this weird issue that's present in it and never got fixed.
*sigh* i hope, i hope Doom 4 won't have these techincal issues ,if that game flops both from a gameplay aspect and a techincal aspect ID will just lose all of the respect they gained from me back in the late 90s and early 2000s.
Still, I'll finish the game + the expansion since i'm really in a mood for Doom 3 however i really don't feel like uninstalling BFG and trying to find my old ♥♥♥ copy of Doom 3 to install and start all over again just because of this.
Last edited by FuscusNight; May 13 @ 1:38pm
Showing 1-7 of 7 comments
< >
geko95gek May 13 @ 2:01pm 
its been working fine for me on my AMD Radeon HD8970M 4GB after I enabled Vsync.

Do you have the latest Nvidia drivers?
FuscusNight May 13 @ 2:11pm 
Originally posted by geko95gek:
its been working fine for me on my AMD Radeon HD8970M 4GB after I enabled Vsync.

Do you have the latest Nvidia drivers?

Yes, GeForce 337.50 Driver
I also noticed Doom 3 BFG for some reason keeps installing some sort of Microsoft package everytime i run it which is strange.
Last edited by FuscusNight; May 13 @ 2:12pm
geko95gek May 13 @ 2:17pm 
Originally posted by FuscusNight:
Originally posted by geko95gek:
its been working fine for me on my AMD Radeon HD8970M 4GB after I enabled Vsync.

Do you have the latest Nvidia drivers?

Yes, GeForce 337.50 Driver
I also noticed Doom 3 BFG for some reason keeps installing some sort of Microsoft package everytime i run it which is strange.

Hmm strange, the only thing I can advise is try some earlier WHQL drivers for a change.

For me it installed the Microsoft package only once before I started the game
FuscusNight May 13 @ 2:30pm 


Originally posted by geko95gek:
Originally posted by FuscusNight:

Yes, GeForce 337.50 Driver
I also noticed Doom 3 BFG for some reason keeps installing some sort of Microsoft package everytime i run it which is strange.

Hmm strange, the only thing I can advise is try some earlier WHQL drivers for a change.

For me it installed the Microsoft package only once before I started the game

Figure out the Microsoft package thing, it's a steam bug that sometimes happens in some games and is easilly fixed by renaiming the installpreparation script in a game's steam app common folder.
The stuttering however i still have no idea, sometimes i can play for 30 minutes with no problems and than it starts stuttering randomly every few seconds or minute and than goes away again and than comes back some time later. It seems compleatly random, maybe increasing the frame rate cap to 120 will fix this but I'll try that later tomorow when i get some free time again.
geko95gek May 13 @ 2:33pm 
Yeah your card should easily handle 120, that was the first thing I set when I ran the game first time.
FuscusNight May 14 @ 4:09am 
Originally posted by geko95gek:
Yeah your card should easily handle 120, that was the first thing I set when I ran the game first time.

And today it's gone, like i just finished the original campaign and had no stuttering in my last few hours and so far in RoE expansion no stuttering too, man so nice and smooth now, i really think it's gone for good now because it's been a few hours now without any issues.

*update*
After about 4 hours it came back, it seems the only way to fix it is to reboot the game and than it's fine for a while untill it starts again.
Last edited by FuscusNight; May 14 @ 4:41am
Indianapolis Jones Jul 18 @ 5:45pm 
This is a disgrace. Seems like the game is smooth only when it wants to. That microstuttering is driving me nuts. I can't believe this is acceptable.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50