Gandalf The Fabulous Apr 17 @ 7:09am
Set-Up won't work
Ok, so my problem with the game is that it won't set up, I've tried guides, downloads, updating hardware and all I get is nothing. Everytime I start the Set-up, a window pops up and says "Unable to initialize OpenGL" and the errors are:


QA Timing INIT: 000129ms
D3BFG 1.1400 win-x86 Nov 9 2012 10:38:21
3400 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & HTT
8128 MB System Memory
-1024 MB Video Memory
Winsock Initialized
Found interface: {9FF718D3-12E2-47C7-8DE2-44E75715D9B9} ASUS PCE-N53 300Mbps 11n Dual band Wireless LAN PCI-E Card - 10.0.1.24/255.255.255.0
Found interface: {04590408-AAB7-430E-9C51-F7D48A20C789} Realtek PCIe GBE Family Controller - 10.0.1.22/255.255.255.0
Sys_InitNetworking: adding loopback interface
doom using MMX & SSE for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded resource file _common.resources
Loaded resource file _ordered.resources
Loaded resource file _sound_pc.resources
Loaded resource file _sound_pc_en.resources
Reading resource CRCs...
Current search path:
E:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition/base
C:\Users\Brendan\Saved Games\id Software\DOOM 3 BFG/base
file system initialized.
--------------------------------------
WARNING: Unable to open resource file maps/_startup.resources
----- Initializing Decls -----
------------------------------
Couldn't open journal files
execing default.cfg
couldn't exec D3BFGConfig.cfg
couldn't exec autoexec.cfg
----- R_InitOpenGL -----
Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
...using WGL_EXT_swap_control_tear
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: AMD Radeon R9 200 Series
StateFlags : 0x5
DeviceID : PCI\VEN_1002&DEV_6798&SUBSYS_27751462&REV_00
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{17A37707-F4ED-48B5-A091-743033A7AFA2}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\MEIA096\{4d36e96e-e325-11ce-bfc1-08002be10318}\0014
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0014
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1920
dmPelsHeight : 1080
dmDisplayFlags : 0x2
dmDisplayFrequency: 30
...calling CDS: failed, bad mode
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): failed
...shutting down QGL
...unloading OpenGL DLL
Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
...using WGL_EXT_swap_control_tear
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: AMD Radeon R9 200 Series
StateFlags : 0x5
DeviceID : PCI\VEN_1002&DEV_6798&SUBSYS_27751462&REV_00
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{17A37707-F4ED-48B5-A091-743033A7AFA2}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\MEIA096\{4d36e96e-e325-11ce-bfc1-08002be10318}\0014
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0014
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1920
dmPelsHeight : 1080
dmDisplayFlags : 0x2
dmDisplayFrequency: 30
...calling CDS: failed, bad mode
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): failed
...shutting down QGL
...unloading OpenGL DLL
Unknown command 'vid_restart'
Unable to initialize OpenGL
Shutting down OpenGL subsystem
...shutting down QGL

Can someone please tell me how to fix this? Thankyou!!!
Showing 1-15 of 59 comments
< >
Luke Ainsworth (Banned) Apr 17 @ 10:23am 
Wait...wait wait...first off do you mean the game won't run after the install? Because this sounds like a start crash issue not an install issue. Second off, what chipset is your motherboard? Third, what is your GPU? Is it Intel, Nvidia, or AMD? I'm seeing a lot of Intel in, so that sounds like either chipset data transfer issue, or possibly an Intel HD issue[the GPUs that have the MOST issues running this game. Wait, I saw an R9 NVM on the GPU! Um, you did the catalyst driver update that was pushed out recently correct? I know you said HW update, but did you mean driver or physical?
Last edited by Luke Ainsworth; Apr 17 @ 10:24am
hailjake Apr 17 @ 10:52am 
Agreed with Vash, what were you trying to do when this happened? Click Play? Click Install?
More personal info rather than all that you posted.

A side note but this has been happening to me alot. Steam has been giving me "Failed to initialize Direct X, or Failed to initialize OpenGL" when trying to play games such as Doom 3 BFG and Ys1&2 Chronicles.
Not saying this will fix your problem but turning off Steam Cloud can fix the problem "Failed to initialize DirectX, Failed to initialize OpenGL.
I turned mine off and my games are now loading fine.
Seems to be a problem with corrupted save data on the steam cloud.

Just wanted to put this since you said your error was "Unable to intialize OpenGL"
Gandalf The Fabulous Apr 17 @ 11:25am 
Yeah, it was probably a crash. Sorry for not being so helpful, I do not know much about my computer since it was originally my cousin's. I do know I have and AMD Prosscesser. So for not knowing anything about computers.PS the AMD is 32bit
Last edited by Gandalf The Fabulous; Apr 17 @ 4:16pm
Gandalf The Fabulous Apr 17 @ 11:32am 
@RPGMachine Yah you're probably right about that..I am just going to complain to Bethesda Support...if support will let me
The Denton Project Apr 17 @ 3:42pm 
I get the exact same Open GL error message! Help Please!! I have a Win 7 64-bit OS
Gandalf The Fabulous Apr 17 @ 4:27pm 
I did a litttle more research, and apperently AMD cards don't work with DOOM 3 BFG....Whats wrong with you Bethesda?
Gandalf The Fabulous Apr 17 @ 4:27pm 
If anyone has a solution to this, please help
steeve Apr 17 @ 4:51pm 
Originally posted by Wicky:
If anyone has a solution to this, please help

if you have an ati card then my solution was to put atioglxx.dll file in the steamapps\doom 3 bfg folder. there is a post on the forum about it's download
Gandalf The Fabulous Apr 17 @ 5:28pm 
Yah, I found it, but unfortunatley the 32 bit link is broken...FFFFFFFFFF
Luke Ainsworth (Banned) Apr 17 @ 5:39pm 
Originally posted by Wicky:
Yah, I found it, but unfortunatley the 32 bit link is broken...FFFFFFFFFF
Well, you need the latest catalyst driver update from AMD's site as well as the ATI update. :s The catalyst will only get you so far though.
steeve Apr 17 @ 5:40pm 
Originally posted by Wicky:
Yah, I found it, but unfortunatley the 32 bit link is broken...FFFFFFFFFF

friend me and i'll email to you if u need.
steeve Apr 17 @ 5:42pm 
:D vash to the rescue.. you following me V >>?? lol
Luke Ainsworth (Banned) Apr 17 @ 5:43pm 
Originally posted by steve:
:D vash to the rescue.. you following me V >>?? lol
Lol yes I'm your secret stalker this season! :D
steeve Apr 17 @ 5:44pm 
Eeeeek !!
Showing 1-15 of 59 comments
< >
Per page: 15 30 50
Date Posted: Apr 17 @ 7:09am
Posts: 59