DOOM 3: BFG Edition

DOOM 3: BFG Edition

View Stats:
Problem at start.
I bought it on CD and installed it on Steam, and when I try to launch, it opens, but the screen stays balck, and after, white. I can ear sounds, but can't see s***. Can anyone help me? My system info:

Windows Version: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit

Processor: Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz

Graphics Card: ATI Radeon HD 5450

Total RAM: 5.9 GB
< >
Showing 1-9 of 9 comments
Wolfwood (Banned) Apr 7, 2014 @ 2:03pm 
Is your GPU driver up to date? There was a new cataylst update a few weeks ago.
Last edited by Wolfwood; Apr 7, 2014 @ 2:48pm
I'll go check
i have basicly a mirror system to you..could try running it as admin or mess with the res..just my little tip i guess
Thank you Vash, it worked.
Thank you too Stone, but my problem is fixed now :p
Wolfwood (Banned) Apr 7, 2014 @ 2:49pm 
Originally posted by Machine Gun Joe™:
Thank you Vash, it worked.
No problem.
Wolfwood (Banned) Apr 7, 2014 @ 2:52pm 
Also, since you're using Radeon you might wanna add this; https://docs.google.com/file/d/0Bx2MiVpEaYRqaHJOLXphQ096OVk/edit , to your Doom 3 BFG folder in the steam common apps folder....otherwise you might find other problems while playing.
lol no prob...but our PC's differ on ram...seriously thats the only thing, mine worked fine for some reason
can t run doom
QA Timing INIT: 000938ms
D3BFG 1.1400 win-x86 Nov 9 2012 10:38:21
1995 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & HTT
3952 MB System Memory
512 MB Video Memory
Winsock Initialized
Found interface: {54E32D70-8CFA-44B8-990D-4A75530B8AA9} JMicron PCI Express Gigabit Ethernet Adapter - 192.168.2.52/255.255.255.0
Sys_InitNetworking: adding loopback interface
doom using MMX & SSE for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded resource file _common.resources
Loaded resource file _ordered.resources
Loaded resource file _sound_pc.resources
Loaded resource file _sound_pc_gr.resources
Reading resource CRCs...
Current search path:
F:\BASE\Valve\operaceflashpoint\steamapps\common\DOOM 3 BFG Edition/base
C:\Users\NN\Saved Games\id Software\DOOM 3 BFG/base
file system initialized.
--------------------------------------
WARNING: Unable to open resource file maps/_startup.resources
----- Initializing Decls -----
------------------------------
Couldn't open journal files
execing default.cfg
couldn't exec D3BFGConfig.cfg
couldn't exec autoexec.cfg
----- R_InitOpenGL -----
Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
X..WGL_EXT_swap_control_tear not found
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: ATI Mobility Radeon HD 5470
StateFlags : 0x5
DeviceID : PCI\VEN_1002&DEV_68E0&SUBSYS_1BF21043&REV_00
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{4B55A3AA-913E-4594-9185-D9BF628F8E0D}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\SEC3046\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1366
dmPelsHeight : 768
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...calling CDS: ok
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: ATI Mobility Radeon HD 5470
StateFlags : 0x5
DeviceID : PCI\VEN_1002&DEV_68E0&SUBSYS_1BF21043&REV_00
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{4B55A3AA-913E-4594-9185-D9BF628F8E0D}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\SEC3046\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1280
dmPelsHeight : 720
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...created window @ 0,0 (1280x720)
Initializing OpenGL driver
...creating GL context: created OpenGL 3.2 context
succeeded
...making context current: succeeded
X..WGL_EXT_swap_control_tear not found

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
freespace_version: 0.6
0 freespace devices
------------------------------------
OpenGL Version: 3.2
OpenGL Vendor : ATI Technologies Inc.
OpenGL GLSL : 1.5
...using GL_ARB_multitexture
X..GL_EXT_direct_state_access not found
...using GL_ARB_texture_compression
...using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_filter_anisotropic
maxTextureAnisotropy: 16.000000
...using GL_EXT_texture_lod_bias
...using GL_ARB_seamless_cube_map
...using GL_ARB_framebuffer_sRGB
...using GL_ARB_vertex_buffer_object
...using GL_ARB_map_buffer_range
...using GL_ARB_vertex_array_object
X..GL_ARB_draw_elements_base_vertex not found
...using GL_ARB_fragment_program
...using GL_ARB_uniform_buffer_object
X..GL_EXT_depth_bounds_test not found
...using GL_ARB_sync
...using GL_ARB_occlusion_query
X..GL_ARB_timer_query not found
...using GL_EXT_timer_query
Couldn't find proc address for: glGetQueryObjectui64vARB
X..GL_ARB_debug_output not found
--------- Game Map Shutdown ----------
--------------------------------------
0: Speakers (Conexant CX20671 SmartAudio HD)
2 channels, 44100 Hz
Front Left and Front Right
Default Console Device, Multimedia Device, Communications Device, and Game Device
Using device 0
********************
ERROR: GL_ARB_draw_elements_base_vertex not available
********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL

< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Date Posted: Apr 7, 2014 @ 1:06pm
Posts: 9