Living Tribunal (Banned) Mar 15 @ 5:22pm
I'm gunna bump this for people having OpenGL and other issues
Possible Solution 1: Run the game as ‘Run as Administrator’ by right clicking. If you are using Steam then navigate to:

32bit – C:\Program Files\Steam\steamapps\common\Doom3BFG.exe
64bit – C:\Program Files (x86)\Steam\steamapps\common\Doom3BFG.exe
Right click on game.exe and select “Run as Administrator”.

Possible Solution 2: If game doesn’t launch, make sure you’re connected to the internet and try restarting Steam/your computer.

Possible Solution 3: Also, you can try to lower the game’s settings by disabling VSync and multi-sampling and turning down environment detail levels.

Possible Solution 4: Try to Update Your Graphics Cards and Motherboard Drivers.

Possible Solution 5: Try different resolution options on your PC.

Possible Solution 6: For NVidia users, go into NVidia control panel and add your game.exe and make it "use NVidia GPU" to resolve this issue. And also try this, go to NVidia control panel and check if game.exe has to instances. If there are two instances, set both to use your specific GPU instead of automatic.

Another thing to consider...can you actually run it? Go to either systemrequirementlab or game-debate, and see if you can actually run the game at all.
Date Posted: Mar 15 @ 5:22pm
Posts: 0