Doom 3 BFG crashes on launch
After the game crashed, a gray and blue error message appears with the following:
QA Timing INIT: 000158ms
D3BFG 1.1400 win-x86 Nov 9 2012 10:38:21
2294 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & HTT
3488 MB System Memory
64 MB Video Memory
Winsock Initialized
Found interface: {12E3D53F-E47A-4235-BF66-313C94E08DB3} Bluetooth Device (Personal Area Network) - 0.0.0.0 NULL netmask - skipped
Found interface: {80632964-83CF-4016-9827-2DADFE2A0270} Dell Wireless 1702 802.11b/g/n - 192.168.1.6/255.255.255.0
Found interface: {C20025C6-C348-4F08-A8E8-B3E55386C447} Realtek PCIe FE Family Controller - 0.0.0.0 NULL netmask - skipped
Sys_InitNetworking: adding loopback interface
doom using MMX & SSE for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded resource file _common.resources
Loaded resource file _ordered.resources
Loaded resource file _sound_pc.resources
Loaded resource file _sound_pc_en.resources
Reading resource CRCs...
Current search path:
E:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition/base
C:\Users\Username\Saved Games\id Software\DOOM 3 BFG/base
file system initialized.
--------------------------------------
WARNING: Unable to open resource file maps/_startup.resources
----- Initializing Decls -----
------------------------------
Couldn't open journal files
execing default.cfg
couldn't exec D3BFGConfig.cfg
couldn't exec autoexec.cfg
----- R_InitOpenGL -----
Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
X..WGL_EXT_swap_control_tear not found
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: Intel(R) HD Graphics Family
StateFlags : 0x5
DeviceID : PCI\VEN_8086&DEV_0116&SUBSYS_05041028&REV_09
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{0945BF46-3356-4497-8A8C-6CD504885AE2}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\AUO22EC\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1366
dmPelsHeight : 768
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...calling CDS: ok
display device: 0
DeviceName : \\.\DISPLAY1
DeviceString: Intel(R) HD Graphics Family
StateFlags : 0x5
DeviceID : PCI\VEN_8086&DEV_0116&SUBSYS_05041028&REV_09
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Video\{0945BF46-3356-4497-8A8C-6CD504885AE2}\0000
DeviceName : \\.\DISPLAY1\Monitor0
DeviceString: Generic PnP Monitor
StateFlags : 0x3
DeviceID : MONITOR\AUO22EC\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
DeviceKey : \Registry\Machine\System\CurrentControlSet\Control\Class\{4d36e96e-e325-11ce-bfc1-08002be10318}\0001
dmPosition.x : 0
dmPosition.y : 0
dmBitsPerPel : 32
dmPelsWidth : 1280
dmPelsHeight : 720
dmDisplayFlags : 0x0
dmDisplayFrequency: 60
...created window @ 0,0 (1280x720)
Initializing OpenGL driver
...creating GL context: failed to create OpenGL 3.2 context
created OpenGL 2.0 context
succeeded
...making context current: succeeded
X..WGL_EXT_swap_control_tear not found

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
freespace_version: 0.6
0 freespace devices
------------------------------------
OpenGL Version: 3.0
OpenGL Vendor : Intel
OpenGL GLSL : 1.3
...using GL_ARB_multitexture
X..GL_EXT_direct_state_access not found
...using GL_ARB_texture_compression
...using GL_EXT_texture_compression_s3tc
...using GL_EXT_texture_filter_anisotropic
maxTextureAnisotropy: 16.000000
...using GL_EXT_texture_lod_bias
X..GL_ARB_seamless_cube_map not found
...using GL_ARB_framebuffer_sRGB
...using GL_ARB_vertex_buffer_object
...using GL_ARB_map_buffer_range
...using GL_ARB_vertex_array_object
X..GL_ARB_draw_elements_base_vertex not found
...using GL_ARB_fragment_program
X..GL_ARB_uniform_buffer_object not found
X..GL_EXT_depth_bounds_test not found
X..GL_ARB_sync not found
...using GL_ARB_occlusion_query
X..GL_ARB_timer_query not found
X..GL_EXT_timer_query not found
X..GL_ARB_debug_output not found
--------- Game Map Shutdown ----------
--------------------------------------
0: Speakers / Headphones (IDT High Definition Audio CODEC)
2 channels, 48000 Hz
Front Left and Front Right
Default Console Device, Multimedia Device, Communications Device, and Game Device
1: Communications Headphones (IDT High Definition Audio CODEC)
2 channels, 48000 Hz
Front Left and Front Right
Using device 0
********************
ERROR: GL_ARB_draw_elements_base_vertex not available
********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL

Has anyone experienced this, and is there a solution? The game worked on this system before I restored it, I'm not sure what is the problem now.
Showing 1-9 of 9 comments
< >
Striker Jan 28 @ 2:43pm 
Try verifying files for Doom 3 on Steam, if isn't on Steam try reinstalling.
In tried it before, but it said that all files are verified. Reinstalling did nothing as well.
Striker Jan 28 @ 2:59pm 
I'm guessing you're on a laptop with intel on-board graphics, in which case you might need to update your display drivers or maybe you're unable to run the game at all. Your current problem seems to be the game failing to load OpenGL 3.2 and that might work if you update your display driver and it might not if the card doesn't support it...

Also, you can try checking if your computer can run the game here: http://www.systemrequirementslab.com/cyri
Doom 3 BFG is on the list.
Technically speaking, the laptop isn't fit to run it according to that site. But before I restored my PC, the game ran perfectly. I guess I'll look for the integrated GPU drivers.
Striker Jan 28 @ 3:55pm 
If you used Doom 3 before and are now using Doom 3 BFG that explains it, Doom 3 used Open GL 2.0 I think while BFG uses 3.2...
No, it was still BFG.
furrytomato Jan 31 @ 7:55pm 
Try opening a private multiplayer game and then quit it. After this open the campaign mode. It somehow works for me.
Thanks for the advice furrytomato, but at the time the game wouldn't even let me into the menu before it crashed.

My problem has finally been solved, and the video card drivers were the solution. Thank you Striker!
ScummyMcDirtbag Feb 2 @ 2:53pm 
my would just go grey screen but when i went in to properties and unchecked the steam in hame community it worked so i hope this help u guys
Showing 1-9 of 9 comments
< >
Per page: 15 30 50