HeYYiTzPaT Jun 16 @ 12:35pm
Doom 3 Crashing on Loading Screen
I've already tried Doom and Doom II and they both work fine. Doom 3, however, is a different story. I go to load up the single player campaign for the first time. The cinematic video plays perfectly. But when it gets to the loading screen of the first level, it freezes up then crashes. My computer will say "Doom 3 has stopped responding and had to close" or something like that. Any idea on how to fix this?

Thanks
Showing 1-15 of 27 comments
< >
Luke Ainsworth (Banned) Jun 16 @ 1:45pm 
Originally posted by HeYYiTzPaT:
I've already tried Doom and Doom II and they both work fine. Doom 3, however, is a different story. I go to load up the single player campaign for the first time. The cinematic video plays perfectly. But when it gets to the loading screen of the first level, it freezes up then crashes. My computer will say "Doom 3 has stopped responding and had to close" or something like that. Any idea on how to fix this?

Thanks
Specs, and uh are you in beta mode?
HeYYiTzPaT Jun 16 @ 6:20pm 
Beta Mode I am not.

CPU is an AMD FX-4100 Quad-Core 3.6 GHz CPU
8GB RAM DDR3
XFX Core Radeon HD 7770 Graphics Card
Windows 7 Ultimate 64-bit
Luke Ainsworth (Banned) Jun 16 @ 6:37pm 
Ever update your drivers?
HeYYiTzPaT Jun 16 @ 6:38pm 
Always do. I haven't lately tho. I'll try it and get back to you.
Luke Ainsworth (Banned) Jun 16 @ 6:54pm 
Originally posted by HeYYiTzPaT:
Always do. I haven't lately tho. I'll try it and get back to you.
Okay.
Luke Ainsworth (Banned) Jun 16 @ 7:09pm 
A fix from ID, "
1. If you wouldn't mind for me, please navigate to C:\Users\<username>\Saved Games\id Software\DOOM 3 BFG\base. You will find a file called D3BFGConfig.cfg there.

2. Open this file using your preferred text editor program (Wordpad, Notepad, Word, etc.)

3. Scroll down until you find a command line that says set r_fullscreen "1" . This is going to sound strange, but you want to change the 1 to a 0 (set r_fullscreen "0") and this will force the game to run in Windowed mode. If this still doesn't work, you can try using values "3" and "4". These values will trick the game into running in different "monitors" and this should resolve the issue."

Another method for that is setting the launch options to "+set r_fullscreen 0" without the quotes.

You can also try putting this in the doom 3 bfg folder http://originaldll.com/file/atioglxx.dll/8919.html
HeYYiTzPaT Jun 21 @ 7:43pm 
So far no luck. I found one where you launch a Private Match in Multiplayer, exit out, then go to single player. That worked, but you have to do it every time. I'm going to try the Atioglxx.dll file now and see if that helps. Does that go in "C:\Program Files\Steam\SteamApps\common\Doom 3 BFG Edition" or in "C:\Users\<username>\Saved Games\id Software\Doom 3 BFG"
HeYYiTzPaT Jun 21 @ 7:58pm 
Ok. I put the file you gave me in the first directory I posted in the last comment, and it worked. However, when the game starts, its laggy as ♥♥♥♥. I lowered the resolution. It worked a little, but not much.
Luke Ainsworth (Banned) Jun 21 @ 9:49pm 
Originally posted by HeYYiTzPaT:
Ok. I put the file you gave me in the first directory I posted in the last comment, and it worked. However, when the game starts, its laggy as ♥♥♥♥. I lowered the resolution. It worked a little, but not much.
Disable vsync, turn off motion blur, turn off AA, and change the FPS.
HeYYiTzPaT Jun 21 @ 10:43pm 
Vsync, motion blur, and AA i'll try. FPS I only get the choices of 60 and 120, which I keep on 60.
HeYYiTzPaT Jun 21 @ 10:45pm 
Tried it. Still laggy =/

I think it hates me
Luke Ainsworth (Banned) Jun 21 @ 10:45pm 
Originally posted by HeYYiTzPaT:
Vsync, motion blur, and AA i'll try. FPS I only get the choices of 60 and 120, which I keep on 60.
Okay also force vsync off in CCC under the game settings menu in catalyst command center.
JXZ Jun 22 @ 3:17am 
I am also having this exact same problem.

Current;y its laggy as hell. No amount of messing with the settings seem to work....


I also don't seem to have anything labeled "catalyst command center" in the game or any where else on my desktop.
Last edited by JXZ; Jun 22 @ 3:21am
Luke Ainsworth (Banned) Jun 22 @ 3:32am 
Originally posted by JXZ:
I am also having this exact same problem.

Current;y its laggy as hell. No amount of messing with the settings seem to work....


I also don't seem to have anything labeled "catalyst command center" in the game or any where else on my desktop.
If you're a radeon user right click on the desktop. That's where CCC is...it should be installed.
Luke Ainsworth (Banned) Jun 22 @ 3:39am 
I also found this "Hi,

I have since found that these two settings in the default.cfg file, complete resolve my lag problems on this system.

rs_enable 0
r_skipPostProcess 1

Both of these settings makes it all good and smooth!

Any further feedback on why, welcome.

Paul."
Showing 1-15 of 27 comments
< >
Per page: 15 30 50
Date Posted: Jun 16 @ 12:35pm
Posts: 27