DOOM 3: BFG Edition

DOOM 3: BFG Edition

View Stats:
LethalByDesign Jul 5, 2014 @ 10:42am
Game launches on wrong monitor
I have 2 monitors and 1 TV hooked into my computer, when I start D3:BFG it always launches on the TV which is not my main monitor. The TV is the right most screen and is connected via HDMI and the monitors are connected via DVI. I can't even use Display Fusion to get the game to move over to my main monitor. I can only play the game if I disconnect the TV and start the game. Please fix this.
< >
Showing 1-7 of 7 comments
Vindicator Jul 6, 2014 @ 10:45pm 
If you have multiple video cards try switching the monitor plugged into each.
Replicators Jul 7, 2014 @ 7:45pm 
1. Open the D3BFGConfig.cfg located in your user’s home folder\Saved Games\id Software\DOOM 3 BFG\base in a text editor.

2. Look for the line r_fullscreen. It is initially set to 1. By changing it to 2 or 3, you are able to move the game to different displays.

3. Now to fix the resolution, first change r_vidMode to –1, and then set the values of r_customHeight and r_customWidth to your desired resolution. In my case the settings are:

set r_customHeight “1080″
set r_customWidth “1920″
set r_fullscreen “2″
set r_vidMode “-1″
LethalByDesign Jul 8, 2014 @ 10:36am 
Originally posted by Replicators:
1. Open the D3BFGConfig.cfg located in your user’s home folder\Saved Games\id Software\DOOM 3 BFG\base in a text editor.

2. Look for the line r_fullscreen. It is initially set to 1. By changing it to 2 or 3, you are able to move the game to different displays.

3. Now to fix the resolution, first change r_vidMode to –1, and then set the values of r_customHeight and r_customWidth to your desired resolution. In my case the settings are:

set r_customHeight “1080″
set r_customWidth “1920″
set r_fullscreen “2″
set r_vidMode “-1″

My file path differs from yours, I assume you are on Linux since you referenced the home folder. My file path is SteamLibrary\SteamApps\common\DOOM 3 BFG Edition\base. Once I get into the Base folder the only config files I see are: default (Keyboard and Mouse bindings), joy_360_0 (Xbox controller bindings) and then 3 other random controller bindings.

I have searched various other folders to try to find other config files but I cant seem to track any down.
Phils Jul 19, 2014 @ 8:50am 
Originally posted by Replicators:
1. Open the D3BFGConfig.cfg located in your user’s home folder\Saved Games\id Software\DOOM 3 BFG\base in a text editor.

2. Look for the line r_fullscreen. It is initially set to 1. By changing it to 2 or 3, you are able to move the game to different displays.

3. Now to fix the resolution, first change r_vidMode to –1, and then set the values of r_customHeight and r_customWidth to your desired resolution. In my case the settings are:

set r_customHeight “1080″
set r_customWidth “1920″
set r_fullscreen “2″
set r_vidMode “-1″
Thanks Replicators.
This worked for me as I was having a similar issue with Big Picture Mode on a second monitor (a HDTV) where Doom 3 (BFG edition) was displaying on my primary desktop monitor when launched from the socond monitor in Big Picture Mode. Other games in Big Picture Mode weren't doing this as I have Steam's Big Picture Mode setup up to switch monitors for more relaxed gaming with a 360 controller. Thanks for providing the fix for this.
Last edited by Phils; Jul 19, 2014 @ 8:51am
Phils Jul 19, 2014 @ 9:03am 
Originally posted by LethalByDesign:
My file path differs from yours, I assume you are on Linux since you referenced the home folder. My file path is SteamLibrary\SteamApps\common\DOOM 3 BFG Edition\base. Once I get into the Base folder the only config files I see are: default (Keyboard and Mouse bindings), joy_360_0 (Xbox controller bindings) and then 3 other random controller bindings.

I have searched various other folders to try to find other config files but I cant seem to track any down.
Not Linux, its Windows 7 and not in your SteamApps folder either.
Click MS Start button, then click on your name at the top and right-side of that menu under your logo, then go to folders Saved Games, then id Software, then DOOM 3 BFG, then base, and the config file is in there.
Britallica101 Feb 13, 2016 @ 9:56am 
Originally posted by Replicators:
1. Open the D3BFGConfig.cfg located in your user’s home folder\Saved Games\id Software\DOOM 3 BFG\base in a text editor.

2. Look for the line r_fullscreen. It is initially set to 1. By changing it to 2 or 3, you are able to move the game to different displays.

3. Now to fix the resolution, first change r_vidMode to –1, and then set the values of r_customHeight and r_customWidth to your desired resolution. In my case the settings are:

set r_customHeight “1080″
set r_customWidth “1920″
set r_fullscreen “2″
set r_vidMode “-1″

Nice one
I would like to add something to this. I know this thread is old, but I just happened by this and found it helpful. However, I had to do something different, and would like to share, in hopes that if anyone else is confused by what makes sense, instead consider what does not make sense.

2. Look for the line r_fullscreen. It is initially set to 1. By changing it to 2 or 3, you are able to move the game to different displays.

Very true. But in my case, the DoomBFG r_fullscreen was already set to 1, and in my display options, windows also recognized the display as 1. The other display it recognized as 2. Windows is goofy sometimes, and what I had to do was set that number 1 to 2 in the settings 2 for 1 so that doom would send 2 to monitor 1.... oh good lord is this confusing....

SOOOO if in the settings file it is already set to "r_fullscreen '1'" and your windows display settings also "Identify" (the button to click to identify monitors) Identifies the monitor as 1 but for some reason Doom keeps loading up on monitor 2 (What windows is saying is number 2) well in the settings, even though it says r_fullscreen "1" change it to 2 anyways for monitor 2... it worked for me and now Doom is loading on monitor 1... despite the windows display settings...

Holy COW windows can be so dumb...

If this happens to anyone else, this is what fixed it for me.

Hope this helps anyone who was as confused as me when this happened.

UPDATE: I found out why this happens! DirectX in windows saw my monitor as 1, in spite of the display settings.... it was directX that the game read data from and therefore that is why!!! So, that explains it! The game was getting its info from DirectX and that is why, even though the windows display settings saw this as monitor "1" it was actually monitor "2" because direct X said so.... if this makes sense. So... the game was just basing it off what DIRECTX was saying, and NOT what windows display settings was saying! Get it? Hope this helps further... windows display settings was saying one thing, but directX was saying OTHERWISE.....
Last edited by classicgamelover85; May 17 @ 9:03pm
< >
Showing 1-7 of 7 comments
Per page: 15 30 50