[GGS]PureCruncher Jan 12, 2013 @ 1:42pm
Multiplayer battles
When I play multi-player battles with my friends there is a very poor design choice/bug that completely kills the game for me. At the beginning of the round 3 battle icons pop
up. When I select the first one, I choose what to do (i.e. manual/ auto, what cards etc). I select manual. When the battle has finished I get a notification telling me that there were 2 other battles that timed out while I was in the 1st battle. As I didn't tell the computer what to do it just put it down as a loss (normally I lose half the fleet too).
What the hell is this??? It is not an isolated incident. It happens frequently and is quite pathetic. I understand there are timers to stop multiplayer dragging but the next battle timer should not start until the previous battle has finished.
Another issue is the fact that pending battles don't appear at the beginning of the round. I have often been in my planet window and noticed when I came out that there was a battle that had auto-resolved while I was busy (in the middle of the turn).
Is there an option to disable this rubbish in the settings or something. I find it very hard to believe that everyone is happy with this. Other than this problem the game is excellent, I am not hitting the game but merely this pre-battle mess.
Showing 1-3 of 3 comments
< >
GamersCircle Jan 12, 2013 @ 2:46pm 
Turn off the multi player battle timer, that might help.
[GGS]PureCruncher Jan 12, 2013 @ 2:57pm 
OK thanks for pointing that out for me. I was hoping there would be a simple solution. Is it in my options or that of the lobby?
S.  [developer] Jan 14, 2013 @ 5:48am 
You can turn off the MP battle timer in the lobby > Advanced Game Settings[i.imgur.com].
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Jan 12, 2013 @ 1:42pm
Posts: 3