StrayConfusion Dec 31, 2012 @ 8:52pm
Mac Resolution Fix
On my Mac, this game starts at a resolution of 840x525. I can go into settings, but can't click on the accept changes button because it is below the bottom of the screen. Windows PCs have a workaround that can be found on the game's support page, but the Mac version does not. Is anyone aware of a way to force a resolution change on the OSX version of this game?
Showing 1-14 of 14 comments
< >
Sid Jan 1, 2013 @ 3:56am 
Check in "/Users/USERNAME/Library/Application Support/Endless Space/". The "Registry.xml" file has resolution settings. (I haven't tried this myself, but what would speak against it?)
StrayConfusion Jan 1, 2013 @ 8:53am 
I thought about that at first, but didn't find that folder path. Presumably it may not have shown up because the game hasn't created any save data yet, so I'll try to create the file path anyway. I'll post later with the results.
XiaoJun Jan 4, 2013 @ 7:20am 
My MAC cannot play, is the same with your situation.if your mac can play the game,plz tell me thx.
StrayConfusion Jan 4, 2013 @ 9:07am 
Sorry, looks like creating that file structure didn't work. I'm still looking for alternative solutions.
Sid Jan 4, 2013 @ 3:33pm 
Okay, I just did a test drive (renamed my Registry.xml), and apparently, the file is created after you (save and?) quit your first game and leave to the desktop. Here is the more or less barebones file that I got through this process - maybe your manually created file just got the XML hierarchy/syntax wrong somewhere?

<?xml version="1.0" encoding="utf-8"?>
<Registry xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<Options>
<Audio>
<Master>
<Volume>1</Volume>
</Master>
<Music>
<Volume>1</Volume>
</Music>
<SFX>
<Volume>1</Volume>
</SFX>
<GUISFX>
<Volume>1</Volume>
</GUISFX>
<Ambiance>
<Volume>1</Volume>
</Ambiance>
</Audio>
<Video>
<VSyncCount>1</VSyncCount>
<Fullscreen>False</Fullscreen>
<RefreshRate>60</RefreshRate>
<Resolution>1920x1080 (60)</Resolution>
<QualityLevel>Fastest</QualityLevel>
<TargetFrameRate>100</TargetFrameRate>
</Video>
</Options>
</Registry>
StrayConfusion Jan 4, 2013 @ 7:35pm 
Okay, I'm dumb. My excuse is I'm new to Mac and didn't realize the Library directory would be hidden. After finally finding the correct file path I found the Registry.xml file and was able to successfully change the resolution.

To help others, the way I found the correct file path was by right clicking on Endless Space through Steam, clicking on the tab "Local Files", and selecting "Browse Local Files...". That took me to "/Users/USERNAME/Library/Application Support/Steam/SteamApps/common/EndlessSpace/". From there I backed out to "/Users/USERNAME/Library/Application Support/" and found the Endless Space directory. The Registry.xml file was there waiting for me.

Problem Solved.
Dorok Jan 5, 2013 @ 7:07am 
Cool I knew where are libraries folders (take care there's a general folder and one for each user) but no way I knew the trick of "local files". That's really excellent, well done Steam.
kidpython Jan 5, 2013 @ 10:06am 
Can I use this approach to set the resolution to a value higher than the highest setting offered within the game? I sill have some extra screen room when I play on the highest resolution with the external monitor hooked up to my Mac. Anyone have a larger size they have tried that worked out OK?
StrayConfusion Jan 5, 2013 @ 11:00am 
I'm on a 15-inch Retina Macbook, so the maximum resolution my computer can run at is 2880x1800. The game seems to run fine at that resolution if that's what you're asking.
Dorok Jan 6, 2013 @ 6:10am 
I don't understand the question I just tried a resolution offered by game for my video card and monitor: 2560*1600 and the game is full-screen and use all the screen. I don't understand how you can have extra screen not used.

Otherwise the possible resolutions also depend of the video card and of the monitor. On a Mac the game seems offer only all 16/10 possible resolutions, my monitor is 16/10. It could have offer various other resolutions I have potentially, both stretched or with borders. For example 4/3 or 16/9 with borders of stretched.
Dorok Jan 6, 2013 @ 6:17am 
One point, on Mac, Command-F switch from window to full-screen or the reverse. and command H hide the application if it is in window mode.

I wonder if your troubles aren't because you want use window mode but you could try full-screen instead.
Last edited by Dorok; Jan 6, 2013 @ 6:18am
kidpython Jan 6, 2013 @ 4:44pm 
I am playing on a Macbook Pro and the greatest resolution offered by the game is 1440x900. I use that resolution in a window and drag the game to another monitor in my 2 monitoe setup. On that monitor I have more room available, but the game doesn't seem to know that.
Kahdir Jan 12, 2013 @ 2:03am 
thanks for the info, it was helpful.
frequentbeef Feb 22, 2013 @ 11:10pm 
Thanks - this finally got the game working for me, too.

One more question - anyone know what the number in paranthesis after the screen resolution stands for? It was (0) for all my displayed resolutions, and I left it at that when editing the XML file.
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Dec 31, 2012 @ 8:52pm
Posts: 14