timun Dec 4, 2012 @ 2:11am
Bug with selecting buttons using the mouse
Is anyone else having this problem? I have to click MANY MANY TIMES on buttons, ships, planets just to select it. It is just me or is this a feature for the game? I'm actually getting very tired of it, I click the mouse for this game more than I do for Diablo, and that's not a compliment.
Showing 1-8 of 8 comments
< >
Steph(✿◠‿◠)  [developer] Dec 4, 2012 @ 6:11am 
Hmm, do you have an example of button that is causing you trouble?
timun Dec 4, 2012 @ 7:06pm 
Unfortunately, all the buttons, planets and fleets. I even have to click like crazy all over the next turn button to get to the next turn and that's a big button.
denis.perov Dec 30, 2012 @ 9:59pm 
I experience the same problem on my Mac OS, but it starts only after ~150 turns. Also information windows starts disappearing immideately after displaying. I don't experience any problems at game beggining.
timun Dec 31, 2012 @ 7:37am 
I figured out it has something to do with the OS, it works fine with my XP machine but doesn't work at all with the Windows 7.
Kilnahard Jan 1, 2013 @ 5:01am 
I changed graphics options this morning after a couple days of frustration with mouse clicks. Set graphics to "Fast" in startup options. Bang! Zipping through the game now with no discernable degradation in game images.

Might help if you try that.
Vexov Jan 2, 2013 @ 11:29am 
Likely the problem is just sort of lag. As Kilnahard did: turning down the graphics will likely prevent this, also reducing galaxy size. I want to say the problem is with the game, I got a i5 2500k and a 690. My problem is at around 120-150 the CPU ships start lagging, soon as its my turn its like i gotta wait to make sure they all finish moving, so im assuming its the same for some of you or even at greater effect. Seems simular to when I was playing Civ5 when my pc was more outdated.
origimist Aug 12, 2013 @ 7:01pm 
I have the exact same problem. It's with the trackpad on my Mac Book Pro. If you have it set for "Tap to Click", and you try to tap the trackpad, it works like 1 out of 10 times when running Endless Space. If you click the trackpad with a physical hard click, it works every time.

Note, this only happens with Endless Space, regardless of graphics setting or full screen mode, etc. I've never had anything like this happen with any other program.

Makes the game basically unplayable on a post 2008 MacBook Pro without an external mouse. My guess is they used a bad hardware emulator port from the Windows version.
Last edited by origimist; Aug 12, 2013 @ 7:02pm
Astasia Aug 13, 2013 @ 1:42am 
It's lag caused by the AI's taking their turn and moving their ships. Very late game on the largest galaxies with 7 AIs and a ridiculous number of ships moving around I sometimes have to click a couple times to get my click to register. If you have a better CPU you might never see this issue (I have a AMD FX6300 running at 3.8ghz x6), if you have a lower end CPU it will probably be a lot more obvious and you might have to play on smaller galaxies or against fewer AIs if it annoys you enough.

Edit: Wow, necro. @origimist: I have no idea what your issue is.
Last edited by Astasia; Aug 13, 2013 @ 1:43am
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Dec 4, 2012 @ 2:11am
Posts: 8