richieberry Jun 23, 2013 @ 11:46pm
Odd Bug
When I start playing, everything seems normal and all the controls work. I select new game and then I spin the pink ball around and select Larva. Then the seven balls connected by lines that kind of look like the Big Dipper appear. I can select any level and when I do the whole "constellation" does this sort of half turn around the ball I selected like the level is about to start, but then nothing happens. It just keeps showing the seven balls. No keys or mouse clicks do anything, the level doesn't start, just nothing. It's not frozen, the little particle things still wiggle around the screen and the music is still playing, it just doesn't progress.

I tried installing the beta, but when I tried to start that, it just crashed on start-up. I've also tried deleting and re-installing the game and deleting the clientregistry.blob, neither did anything.

I'm running this on a Mac OS 10.5.8 from 2008. It has 2 GB of RAM and an Intel processor. The graphics card thing is ATI, RadeonHD2600, if any of that helps.

Any idea on what might be causing this? It's pretty strange.
Last edited by richieberry; Jun 23, 2013 @ 11:46pm
Showing 1-12 of 12 comments
< >
increpare  [developer] Jun 26, 2013 @ 3:42am 
Try the testing/beta branch again - the version there was only up to date in the windows version.
Last edited by increpare; Jun 26, 2013 @ 3:42am
richieberry Jun 26, 2013 @ 4:01am 
I just redownloaded the beta and it still crashes on start-up.
increpare  [developer] Jun 26, 2013 @ 7:10am 
by crashing on startup, you mean, even before the resolution picker/input configuration window appears?

Could you run the Console app (in application/utilities), and check for any unity/english country tune related logs there? (should be in ~/Library/Logs/Unity/Player.log) If you find them, could you paste them in somewhere like pastebin.com + link me, or mail them to me at analytic@gmail.com ?

Thanks for bearing with me. This is a pretty mysterious bug, but I hope, with your kind assistence, that we can track it down :)
richieberry Jun 26, 2013 @ 9:29pm 
Yes, it crashes before the resolution/input window appears when I have the beat installed.

I'm not sure if these are English Country Tune realted, but here's a paste of everything that was in ~/Library/Logs/Unity/Player.log in the Console app.

http://pastebin.com/LFrQmXD1
Last edited by richieberry; Jun 26, 2013 @ 9:29pm
increpare  [developer] Jun 27, 2013 @ 2:56am 
hmm, there's nothing there of help - i take it you didn't play WoodleTreeAdventures between trying to launch English Country Tune and pasting in the log?

try running the game again, then could you look at system.log in console and search to see if theresn't anything english country tune related? (a search for the word english should suffice).

Q: what language is your operating system running in - english?
richieberry Jun 27, 2013 @ 11:20pm 
No, I played Woodle Tree the day before I tried to launch English Country Tune.

I tried running it several times, and I also deleted all local files for English Country Tune and reinstalled it and tried running it, nothing new appeared in player.log... but then I reallized you were asking about the system.log. There was a lot about English Country Tune in the system.log. Some of it may be redundant, since I opened it about ten times, but I'll post it all here.

In this first one here: http://pastebin.com/tS149B7e it looks like I run it a couple times and then I delete all local files. The part at the beginning might be it completing the installation of the beta. I had earlier tested uninstalling the beta and reinstalling it to see if that had an effect on the player.log, but it looks like the system.log deleted everything at midnight, so the data I have starts at midnight and goes from there.

This second one here: http://pastebin.com/V10GMqmQ starts with the the installation of English Country Tune and goes to the end of the system.log, which has it running three or four times, I think.

Yeah, I'm running in English.
Last edited by richieberry; Jun 27, 2013 @ 11:21pm
increpare  [developer] Jun 28, 2013 @ 12:58am 
there are crash logs in this directory
/Users/Richie/Library/Logs/CrashReporter/English Country Tune_2013-06-28-014819_Macintosh.crash

could you zip them up and send them to me? (the one above and its similarly-named siblings) analytic@gmail.com

if you have trouble finding the directory, see here, for instance
http://support.kaspersky.com/8427

thanks :)

S
richieberry Jun 29, 2013 @ 12:04am 
OK, I just sent it (the title of the email is English Country Tunes Crash Logs). I've never zipped anything up like that before, but it seemed to work properly.
increpare  [developer] Jun 29, 2013 @ 1:31am 
That was perfect. Okay, I've made a super simple test project - don't run it in fullscreen, it does nothing, and you'll have to quit it, if it runs, by pressing cmd+q

http://ded.indiefaqs.com/~locus/testbuilds.zip

there are two versions, try running both, let me know which works, and then send me the crash logs with this sort of path

/Users/Richie/Library/Logs/CrashReporter/testproject_XXXXXXXXX_macintosh.crash

(I have a suspicion this is related to you running osx 10.5 - I don't know yet how fixable it is, but hopefully can sort something out)
richieberry Jun 29, 2013 @ 3:41am 
Alright, I tested them both, and both crashed on start-up. I emailed the crash logs for them both as well.
Last edited by richieberry; Jun 29, 2013 @ 3:41am
increpare  [developer] Jun 29, 2013 @ 4:11am 
Hmm. This is a pretty unfortunate problem - let me summarise -

-I used a game engine called Unity 3D to make this
-so the current official version, made with an older version of Unity 3D, of the game runs, but has a weird bug that's stopping you getting past level select
-the beta version, built with a newer version, doesn't work at all. Even blank projects crash - so, it's a problem in the underlying game engine, that I can't fix by myself.

I can't downgrade to an older version of unity and fix and older version of the game - seriously, that would drive me nuts. So I've logged a bug report with the people who make the game engine - this bug has appeared in at least one other game, where they said, *incorrectly*, that the engine doesn't support OSX 10.5 - http://forum.kerbalspaceprogram.com/showthread.php/32120-KSP-0-20-don-t-start-on-MAC?p=403471&viewfull=1#post403471

Anyway, the long and the short of it is this:
I can't fix the bug myself. Unity can, but they are a biiig and slow company, if they fix this bug at all, it'll be at their own pace, and I have basically no influence over that (but I'll post here if/when they do fix it) - could be weeks, or months, or never.

If you have an iOS device I can give you a free copy of the iOS version, if that might substitute, but other than that, the best I can do is recommend you contact the merchant you bought the game off and ask for a refund (you can refer them to this thread and say I recommended it).

Thanks so much for helping me out with crash reports and testing - I know this stuff takes time, and I'm super sorry I amn't able to fix it myself.
richieberry Jun 29, 2013 @ 6:16am 
Actually an iOS version would work perfectly. I've got an iPad, and English Country Tune seems like a game that would work quite well with a touch screen.
Showing 1-12 of 12 comments
< >
Per page: 15 30 50