g051051 Jun 4, 2013 @ 6:14pm
Can;t get controls to work [ FIXED, see comments ]
Nothing works when I start the game. It just sits there at the New Game prompt, and nothing I do with the mouse, keyboard, or controller makes any difference. The launch dialog doesn't allow me to change any of the key bindings, either. When I double click to change one, it just sits there and doesn't accept any keystrokes. Anyone know how to solve this?
Last edited by increpare; Jun 6, 2013 @ 12:30pm
Showing 1-11 of 11 comments
< >
increpare  [developer] Jun 5, 2013 @ 12:32am 
Hi, I'm the developer - that doesn't sound good! sorry to hear you're having this problem.

( One piece of advice: do not go near or modify the input manager - that screen is due to the engine I'm using rather than something I would make myself, and very funky. )

What operating system are you running?

can you still press esc to quit?

I can guess one problem - that maybe the input bindings screwed themselves up - in that case the solution is to delete the settings file -

on windows, it's in the registry here: HKCU\Software\increpare games\English Country Tune

on OSX it's this file ~/Library/Preferences/unity.increpare games.english country tune

on windows, you have to use regedit to delete the file, on osx, you'll probably have to use the terminal. let me know if you want detailed instructions how to do this - the solution, if this is the problem, is hairier than I'd like - for which I apologise.
g051051 Jun 5, 2013 @ 6:49am 
Thanks for the response. After I posted here, I went back to the old forums and found your previous posts on the matter. It was odd because it seemed like a good diagnostic thing was going on and then just suddenlt stopped. Basically, I have the exact same problem as that other one.

I had already tried a few of the things you mentioned above, plus the things in the previous thread. The first beta crashes on startup, the second beta has the exact same problems. Basically, the Steam overlay works, but nothing else does. If I start the game, the only way out is to either kill it with Task Manager, or Alt-F4.

I grabbed the non Steam version from humblebundle, and it works somewhat with the keyboard, but not with my gamepad.

I'm a programmer myself, and pretty handy with things, so if you want to try more technical stuff to debug this, just let me know.
increpare  [developer] Jun 5, 2013 @ 5:52pm 
Hey, thanks for getting back to me -

You're on windows?

The game doesn't have gamepad support (okay, it has accidental gamepad support in some scenes, that's confusing I know! )

I have a newer version of the game I can try pushing to a test branch, to see if that fixes things (It is quite likely to, actually), but I'll not have it ready until tomorrow - I'll post another message here then to let you know.

just as a warning: the standalone version's savegames are not compatible with the steam version's.
g051051 Jun 5, 2013 @ 6:06pm 
I'm using Windows 7 64 bit. OK, let me know about the beta and I'll test it. What game engine are you using? I've seen a few games with similar directory structures, and Mono and C# references, but don't recall any of them having similar issues.
increpare  [developer] Jun 6, 2013 @ 7:27am 
Hi -

Thanks so much for the info(and for generally being comprehensive in your trawlings). The game is made with unity - it's good to know it's me rather than something I can just throw my hands up at and blame the engine :P

I've put a newer windows build of the game up in the test branch. In your library list in steam, right click on the game entry, then select properties, then select the betas tab. From there, select the branch called "testing - bug fixing". You might have to uninstall (right click on it in the library view -> delete local content) and reinstall the game (hit the install button after selecting the new beta).

Let me know if it works - I sure hope it works :)

Peace,

S
g051051 Jun 6, 2013 @ 10:17am 
Yes, that seems to have fixed it. While the gamepad still doesn't work (and based on your other comments isn't expected to), the keyboard is fine and the game is now playable.
increpare  [developer] Jun 6, 2013 @ 12:30pm 
Wonderful! I'll probably not release that build officially for a while (it has some minor graphical kinks I'd like to iron out), but it's nice to have a working version I can direct affected people towards in the interim. Thanks so much for helping me test it out :)
g051051 Jun 6, 2013 @ 12:34pm 
Thanks for the amazing response. Can you share what the problem was? Like I said, I've quite a few Unity based games, and have never seen this behavior. Feel free to ping me for more testing if you like.
increpare  [developer] Jun 6, 2013 @ 12:38pm 
No idea what the problem was. The new version was just compiled with a newer version of unity and a set of steam API bindings by someone else rather than my really nasty home grown ones. So it's a case of time passing and things magically working. Which is fine by me!
g051051 Jun 16, 2013 @ 2:44pm 
Has this fix been pushed out of Beta yet?
increpare  [developer] Jun 17, 2013 @ 9:41am 
No, it's not a priority to get it out, so long as I can direct the few people who're experiencing it to the instructions above.
Showing 1-11 of 11 comments
< >
Per page: 15 30 50