Archeblade > General Discussions > Topic Details
Rohamcs1ga May 24, 2013 @ 1:26pm
cant connect to any server
"your connection to the host has timed out" it says after i tried to connect to a game... i set the graphics to the lowest and still cant connect anywhere... training works fine btw. anyone know what to do?
Showing 1-8 of 8 comments
< >
himmelskye May 24, 2013 @ 3:39pm 
same problem...
Job May 25, 2013 @ 12:33am 
Happens to me too. After the patch this started to happen ocassionally. I'll speak with a developer to get this fixed ASAP.
Maestromind May 25, 2013 @ 2:11am 
Senfbrothel May 25, 2013 @ 8:47am 
I forwarded all 6 ports, but the problem still occurs for me.
Rohamcs1ga May 25, 2013 @ 10:41am 
nope still cant connect
Job May 25, 2013 @ 12:28pm 
Originally posted by Maestromind:
Have you already tried the following?

http://steamcommunity.com/app/207230/discussions/10/828935361023430272/
Maestromind, it's a bug. It appeared after the last patch. I informed Jay.
EpicLapfox™ Jul 21 @ 3:28pm 
THE SAME PROBLEM!!!!
Ricyn Jul 25 @ 1:03am 
There are already a lot of such Threads and here is your solution atleast worked for the people in the Thread even if that is really strange but we will never know from Codebrush how this could happen:
http://steamcommunity.com/app/207230/discussions/0/43099721562102071/?tscn=1405757523
you are welcome ;)
Last edited by Ricyn; Jul 25 @ 1:04am
Showing 1-8 of 8 comments
< >
Per page: 15 30 50