Archeblade > General Discussions > Topic Details
Mirrorcle May 23, 2013 @ 8:28pm
Cant connect to any server?
So today, i got a new hp envy laptop, a dv7 7333cl. its a pretty ok specs and i though u should run Archeblade with no problems at all and i was right, UNTIL i tried to join a server. It just stay at trying to connect the server. I tried servers with ppl in them and servers that are empty and both still stays at connecting to server. Training works however so i have no idea whats going on...Help would be much appreciated. Thanks for your time.
Last edited by Mirrorcle; May 23, 2013 @ 8:29pm
Showing 1-15 of 21 comments
< >
Emonium May 23, 2013 @ 8:34pm 
Its been doing the same for me too. After a few relaunches it seems to fix itself
Last edited by Emonium; May 23, 2013 @ 8:34pm
Mirrorcle May 23, 2013 @ 8:48pm 
i relaunched the game multiple times as in 7 or 8 times and its still not letting me connect
SilverSil May 23, 2013 @ 11:12pm 
same issue here. relaunched game several times, stuck attempting to connect to servers.
SilverSil May 23, 2013 @ 11:23pm 
it really is an annoying bug. i know its not my connection as other games are working normally. game launches just fine, but when i got to join a server (any server) it stuck on the connecting screen.
Sazonde May 23, 2013 @ 11:33pm 
So im not the only one who is having this. For a minute I though my connection wa slaggin which is not likely lol.
SilverSil May 23, 2013 @ 11:35pm 
i know the feelin bro. alot of people i know are having this same issue ever since the new patch.
Last edited by SilverSil; May 23, 2013 @ 11:35pm
Mirrorcle May 24, 2013 @ 1:08am 
i was all happy for a moment thinking i can finally play ArcheBlade in all its glory...then this happens...
Last edited by Mirrorcle; May 24, 2013 @ 11:36am
SilverSil May 24, 2013 @ 2:19am 
new patch prob broke somthing. I sent in a support ticket hopefully i get a response. i linked this thred in it. so if anyone has anything to contribute to this prob let em know i guess?
Last edited by SilverSil; May 24, 2013 @ 2:30am
SilverSil May 24, 2013 @ 2:45am 
i manged to get in 1 room in 4 hours. and the guy who was in that room ragequit after i killed his sewon with my frenny =/

now im back to sqaure one of the non-connection issue...
Last edited by SilverSil; May 24, 2013 @ 2:52am
SilverSil May 24, 2013 @ 4:25am 
6 hours and only able to connect to one server for 10 minutes. =/
Newnie May 24, 2013 @ 5:42pm 
Wow... They still havent fixed this? SMH It's been 3 months since I've came back to check on this. This is bad for your fans... No support and not handling the situation is making a lot of your fans dismiss the game completely.
o_O May 24, 2013 @ 7:36pm 
i cant see any server on the server list... i doubt theres no one playing this game and i tried to play it in different hours...

its a pain in the butt that i cant create any server...
Job May 25, 2013 @ 12:36am 
I will let the developers know. We'll get this fixed.
Maestromind May 25, 2013 @ 2:11am 
SilverSil May 25, 2013 @ 2:33am 
the problem is i already have the ports forwarded and all that good stuff. and this problem still occurs often. its intermittent though as sometimes the game will work and sometimes it wont.
Last edited by SilverSil; May 25, 2013 @ 2:33am
Showing 1-15 of 21 comments
< >
Per page: 15 30 50
Date Posted: May 23, 2013 @ 8:28pm
Posts: 21