Midgert Dec 27, 2012 @ 2:54pm
Techincal issues with game at startup
bough game today installed it and when I launch it the game constantly crashes immediately before loading screen. says it is a software error with the error log containing this

[string "Config.lua"]:0: bad argument #1 to 'match' (string expected, got nil)
stack traceback:
[C]: in function 'match'
[string "Config.lua"]: in function 'parseResolution'
[string "Config.lua"]: in function 'load'
[string "Grimrock.lua"]: in function 'init'
[string "Grimrock.lua"]: in main chunk
[C]: in function 'require'
init.lua: in main chunk

OS Version 6.2

OEM ID: 0
Number of processors: 8
Page size: 4096
Processor type: 586

Total memory: 8081 MB
Free memory: 4375 MB

Display device 0:
Device name: \\.\DISPLAY1
Device string: Intel(R) HD Graphics 4000
State flags: 00000005

Display device 1:
Device name: \\.\DISPLAY2
Device string: Intel(R) HD Graphics 4000
State flags: 00000000

Display device 2:
Device name: \\.\DISPLAY3
Device string: Intel(R) HD Graphics 4000
State flags: 00000000

Display device 3:
Device name: \\.\DISPLAY4
Device string: NVIDIA GeForce GT 650M
State flags: 00000000

I have tried validating the files and I have deleted the .cfg file and nothing has changed. any help would be greatly appreciated
Showing 1-5 of 5 comments
< >
Midgert Dec 27, 2012 @ 3:32pm 
currently I no longer get the software error but now I see the loading screen for half a second then it says grimrock.exe has stopped working then closes
srr_64 Dec 27, 2012 @ 5:29pm 
I can't play this either, bought it on 27th Dec and it wont launch .... any ideas ???
Hrothgar Dec 27, 2012 @ 5:31pm 
i cant play either... i started up the game but i was laggy, i changed the graphics to medium and when i applied, the game crashed and don't start anymore... i tried to reinstall it but the same error ocurred
Didz Dec 28, 2012 @ 12:31am 
The game would not load. I just got the 'Preparing to load' screen and nothing else. I checked the Steam support forum and there are instructions for loading the security and DXdirect components seperately. Did that and its now loading successfully.

The instructions can be found here:
https://support.steampowered.com/kb_article.php?ref=1509-PGJK-9514


wondermech Dec 31, 2012 @ 11:33am 
Originally posted by Obliviσи:
i changed the graphics to medium and when i applied, the game crashed and don't start anymore...
This seems to be a fairly common problem, but luckily you can manually edit the config file which is found in your user account's Documents folder on Windows or simply delete it and a new one will be created. You might not be able to get the graphical settings you were hoping for, but at least you'll be able to play the game :)
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Dec 27, 2012 @ 2:54pm
Posts: 5