Legend of Grimrock

Legend of Grimrock

View Stats:
Billhelm_II Jun 24, 2014 @ 12:50pm
Error when attempting to run
Google has nil on this issue, and I don't have any idea how to fix it. When I try starting the game, I get this error:

[string "Config.lua"]:0: attempt to index a nil value stack traceback:

[string "Config.lua"]: in function 'autoDetectResolution'
[string "Grimrock.lua"]: in function 'init'
[string "Grimrock.lua"]: in main chunk
[C]: in function 'require'
init.lua: in main chunk

I've tried uninstalling and reinstalling to no avail. I suddenly cannot play this game on this PC, even though I've beaten it once before on the very same computer. If anyone knows what I can do to fix it, I'd much appreciate it.
< >
Showing 1-6 of 6 comments
Dr.Disaster Jun 24, 2014 @ 5:37pm 
Either the gfx in your system changed or the games config file grimrock.cfg got corrupted. It's located in "My Documents" -> Almost Human -> Legend of Grimrock -> grimrock.cfg

You can try either deleting or manually fixing it with a text editor.
Billhelm_II Jun 24, 2014 @ 6:31pm 
There isn't any such file. I tried making one with proper resolution settings in it, but it didn't help. Same error. It's... strange.
Dr.Disaster Jun 25, 2014 @ 5:38am 
If you played the game before there has to be this file. The game even re-creates it on start-up if it's not there.
Billhelm_II Jun 25, 2014 @ 11:09am 
I wish that were the case. https://www.dropbox.com/s/2pkmicsal5r5ytm/this_is_confusing.PNG

I'm beyond puzzled.
Kyatto Jun 27, 2014 @ 8:28pm 
Have you tried emailing it to them as they suggest in the error message? All I can think of is to get someone to give you the .lua config file for you to replace. You've verified game cache I trust?

Most confusing is the C:\ (Backslash) foldername/ (Forwardslash) ... um, oops?
Dr.Disaster Jun 28, 2014 @ 1:58am 
If the error would be that .lua file it would be a corrupt game file but since OP already reinstalled we can prolly scratch that.

The point is: the game can't recreate it's main config file grimrock.cfg.

According to the error message i'd say that the game can't read the resolution set on your system so i would check display driver and settings; eventually re-installing the driver.
Last edited by Dr.Disaster; Jun 28, 2014 @ 2:00am
< >
Showing 1-6 of 6 comments
Per page: 15 30 50