Professor Pew Aug 19, 2013 @ 3:07pm
Saints Row IV - Bugs and technical issues thread
Bugs in my open world game? Impossible!! Sometimes something weird does show up in the real world when a game is out in the wild, even after the lab has cleansed the game of bugs for months and months on end.

We tested this game on a wide variety of PC setups, but you cannot test every possible PC setup in the world. Do you know how many possible combinations there are? A lot.

The vast majority of you should have little to no problems in their gameplay experience, but if you do encounter a technical issue or a bug after release, and would like it fixed sooner rather than later, you are in luck! We would like to fix it too, and we'd rather be prepared. Help us help you, so to say!

We've launched quite a few PC games on Steam this year, and have always had a very positive experience with Steam users who want the same result as we do: fix things. Before you can fix something, you need to find out what makes it break, though. A thread like this can be helpful to QA and other dev teams to find that out, so please follow the below instructions if you do encounter a problem.

This is how you do report a problem
1. Make sure you match the minimum requirements listed on the Store page.

2. Describe your issue with as much detail as possible. Maybe this one random thing doesn't seem important to you, but it could be the randomest thing in the world that causes some super weird thing to happen. If you have already tried various things to fix something, let us know as well!

3. Leave as many technical details about your PC as you are willing to share. We understand you probably don't want to paste your entire DxDiag in a comment. But listing these things will help us pin down a possible problem if there end up being any:

- CPU
- Motherboard
- Amount and type of RAM
- Graphics card
- Graphics driver version
- Monitor set up and connection to display (HDMI, DVI, VGA)
- Audio card or onboard audio chipset
- Headphone brand and model if you use headphones
- Anything else you might think is relevant, even if it doesn't make sense (SSD RAID archive setup, a GTX Titan in a PCIe 1x slot, etc.)

4. Don't quote someone's giant comment and add "I have the same." Please cut down the quote a bit so it will keep the thread readable.

5. Please keep this thread dedicated to reporting technical problems for PC.

But I'm not playing on PC
What are you doing on this Steam thread? You can contact our tech support at techsupport@deepsilver.com for other problems.
Last edited by Professor Pew; Aug 30, 2013 @ 9:36am
Showing 1-15 of 2,290 comments
< >
n050up4u Aug 19, 2013 @ 4:51pm 
*Note* Anyone who had issues with inauguration station.. Upgrade drivers (if on nvidia, not sure about AMD)
Veav Aug 19, 2013 @ 5:05pm 
The only issue I had with inauguration station is it didn't actually save my upload to the site. It's not exactly a dealbreaker, I'll just make it in-game (and fast, since I know what I'm going for now), but it's a teeny tiny hitchy start.
Lain Aug 19, 2013 @ 6:18pm 
Any word on Nvidia specific drivers? Total Biscuit reported serious FPS drops using SLI Titans and a i7.
sirwunderbar Aug 19, 2013 @ 9:09pm 
the game wont launch says missing executable
Synapt Aug 19, 2013 @ 9:11pm 
Originally posted by sirwunderbar:
the game wont launch says missing executable

To you and anyone else having this issue, restart steam, looks like the post-load update didn't "trigger" right, but restarting will snag the binaries.
­­Δ👽 Louna 👽Δ­­ Aug 19, 2013 @ 9:14pm 
The game isn't supporting 5.1.


Even on a G35 it's only work in stereo.

In Surround it's cut 1/2 of the sound.

Hope this will get fixed!
ZarX Aug 19, 2013 @ 9:15pm 
Game won't accept remapped mouse binds.... As in I go to remap a mouse key and it acts like it accepts it but it doesnt.
Last edited by ZarX; Aug 19, 2013 @ 9:17pm
ddaydj Aug 19, 2013 @ 9:19pm 
Launched the game, got to the main menu. Went to New Game, picked difficulty, game crashed. Retried and same thing happened. I was running AMD 13.4 drivers, I upgraded to 13.8 Beta and am still experiencing issues. I was also having a very similar issue with the character creator. Please help me fix this :( I really wanna play.

DxDiag - {LINK REMOVED - Please don't spam, and be wary of scams.}http://goo.gl/DhojyC
Crash Information - {LINK REMOVED - Please don't spam, and be wary of scams.}http://goo.gl/iFF30U
Synapt Aug 19, 2013 @ 9:19pm 
Originally posted by ZarX:
Game won't accept remapped mouse binds.... As in I go to remap a mouse key and it acts like it accepts it but it doesnt.

Delete the original bind first (I just ran into the same issue), then re-bind it to what you want, worked for me.
Deception Aug 19, 2013 @ 9:19pm 
When I try to unlock the game, it says "Failed to update Saints Row IV (disk write error)" help?
Polyh3dron Aug 19, 2013 @ 9:19pm 
After the Deep Silver, Volition and AMD logo splashes, the screen turns black and freezes. It is then in a "Not Responding" state and I have to quit it through Task Manager. The same thing happened to me on Inauguration Station and I reported it in that forum too, without any response.

- Motherboard: Retina MacBook Pro
- OS: Windows 7 x64 Ultimate SP1 with all updates
- RAM: 16GB 1600MHz DDR3L
- Graphics card: Nvidia GeForce GTX 650M
- Graphics driver version: Latest Beta
- Monitor set up and connection to display (HDMI, DVI, VGA): HDMI
- Audio card or onboard audio chipset: NVIDIA High Definition Audio through HDMI
- Headphone brand and model if you use headphones: None
- Anything else you might think is relevant, even if it doesn't make sense (SSD RAID archive setup, a GTX Titan in a PCIe 1x slot, etc.): Steam is installed on an external USB 3.0 HDD, game is installed inside Steam folder in default game installation folder. My C: drive with Windows installed on it is a small SSD partition

UPDATE: This issue also exists on my brother's 2012 iMac with a GeForce 680MX, 16GB RAM and similar setup with Steam also installed externally. I tried moving the game to his internal C: drive since he actually has space available on there unlike me and it works. So I've basically confirmed that unlike Saints Row The Third, this game has taken a step backwards in terms of compatibility and does not support being installed on any drive but the C drive, regardless of where Steam is installed.

Volition: Do you intend to fix this? Because if the game has to be installed on the C drive for it to work then I can not play the game I have purchased. I have a small SSD as my C drive, my Windows partition is barely big enough to hold the OS itself and I run Steam from an external drive.

UPDATE 2: I managed to free up enough space on my C: drive (aforementioned small SSD partition) and moved Saints Row IV over there. Now it works. I don't want it on my C: drive though, I'd prefer to be able to run it from my external drive where my other 150 Steam games work just fine.

Also, this same issue happens with Far Cry 3 and Blood Dragon, so maybe you guys could compare notes or something. Those are the only 3 games in my rather large Steam library that exhibit this problem.
Last edited by Polyh3dron; Aug 22, 2013 @ 2:54am
zpelfresne Aug 19, 2013 @ 9:28pm 
Every time I try to start the game it starts and I can hear things playing but my screen stops getting a signal from my GPU..

Intel Core i7 950 OCd 3.8 GHz
12 GB 1333MHz RAM
Asus P6T Deluxe v2
Nvidia GeForce GTX 580 OCd
23 in monitor using DVI connection
All drivers up to date

Update: It ended up working when I messed with the plug for a bit so I'm not sure what happened there.
Last edited by zpelfresne; Aug 22, 2013 @ 9:20pm
Science! Aug 19, 2013 @ 9:35pm 
The game starts fine. However, after the opening cinematic, when I am given control of the character, he starts running right as if the "D" key has been depressed and held. I've unplugged my keyboard a few times but that did not help. I've checked the cache and reinstalled as well to no avail.

Another funny thing is that when navigating the menus before starting or continuing a game, the button keys keep flashing between XBOX360 buttons and keyboard buttons. For example, when I press the down key to navigate to "Options," the key located at the bottom keeps flashing between the "Enter" key and the green "A" button from the XBOX controller. After navigating the menus, the menus get stuck. I can still move the cursor and move the mouse around but clicking the left button to choose a menu item doesn't register and nor does any keyboard commands. This is crazy considering SR3 worked great on my PC. Specs below:

- i7 2600K
- Asus Z77 Sabertooth
- 16GB of Kingston RAM running at 800Mhz
- Sparkle Caliber Nividia GTX 680
- 326.19
- DVI running at 120Mhz
- Soundblaster Z
- Sennheiser HD555/Bose 2.0 Desktop speakers
- Logitech 710+ mechanical keyboard and G9x Mouse.

-Mike
AllyorHopes Aug 19, 2013 @ 9:39pm 
My game starts off with a really long black screen then will show the game logos. i can skip the first logo but then sometimes if i skip the second logo the game stops running

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130708-1532)
Language: English (Regional Setting: English)
System Manufacturer: Alienware
System Model: M14xR1
BIOS: InsydeH2O Version 1.0 A03
Processor: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz (8 CPUs), ~2.0GHz
Memory: 6144MB RAM
Available OS Memory: 6092MB RAM
Page File: 4644MB used, 7537MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

------------
DxDiag Notes
------------
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Input Tab: No problems found.

-


Last edited by AllyorHopes; Aug 19, 2013 @ 9:45pm
Achiel Aug 19, 2013 @ 9:41pm 
Game starts fine, however if I force skip the beginning scenes or any scenes. The game crashes. The game also crashes on Trying to Open up the In-game Steam UI. I have set the game to run on The NVIDIA card in the Nvidia Control panel already.

- i7-3610QM
- Unknown (It's an MSI-GT60 0NC laptop
- 12 GB of RAM
- NVIDIA Geforce GTX 670M
- Geforce Driver 320.49
- Laptop screen, around 17"
- Realtek Audio HD (onboard sound)

EDIT: It also crashes at certain points with a single press of any keyboard button. Including trying to login to the Community.

EDIT 2: [ISSUE FIXED] I fixed my crashing. All I had to do was set my keyboard back to English IME.
Last edited by Achiel; Aug 19, 2013 @ 9:59pm
Showing 1-15 of 2,290 comments
< >
Per page: 15 30 50
Date Posted: Aug 19, 2013 @ 3:07pm
Posts: 2,290