Chaosvex Nov 26, 2012 @ 7:33pm
[Updated] Unofficial FPS/slow loading patch
I purchased JSR this evening and found I couldn't get beyond the initial loading screen without waiting for a lengthy period of time, given that the game was running at 1 FPS for whatever reason. I noticed that quite a few players are having the same or similar FPS/loading issues.

Since there's no patch and I get the feeling that there won't be, I've created an unofficial patch to try and sort the issue out.

It's only a quick fix so it comes with the caveat that you need to set the refresh rate for the game to 30hz otherwise the game will run too quickly. See instructions at the end of the post for information on how to do this.

Copy the patched exe linked below to your Steam folder, ensuring you back the original up for safekeeping.
Download patched exe[www.mediafire.com]

Default Steam folder (remove the x86 for 32 bit Windows):
C:\Program Files (x86)\Steam\steamapps\common\Jet Set Radio

Click here for the VirusTotal scan for reassurance.[www.virustotal.com]

I offer no guarantees regarding the efficacy of this patch given that it's a quick hack.

Instructions for forcing the game to 30 FPS after applying the patch:
For Nvidia users with a 60hz refresh rate, this can be done in Nvidia's control panel by creating a profile for the game (or editing the global one) by setting vertical sync to 'adaptive (half refresh rate).

Click for settings example for Nvidia users.[i.imgur.com]

Solutions for everybody else:

MSI Afterburner
  • Grab it from here[event.msi.com]
  • After installing, start the "MSI Afterburner On-Screen Display Server" (OSD)
  • Add a profile for jetsetradio.exe by clicking the plus icon at the bottom left or just use the global settings.
  • Click the spanner icon near the top right and change the framerate limit option from 0 to 30.

Dxtory
  • Grab it from here[dxtory.com]. The free version can limit the FPS perfectly fine, I believe.
  • Start it up and click 'Advanced' (GPU chip icon)
  • The last option allows you to enter your desired FPS limit. Enter 30 and make sure the box is ticked.

Bandicam
  • Grab it from here[www.bandicam.com]
  • Look at the options here[www.bandicam.com]

There are other options but the three above should be enough.

On a side note, I've noticed that even the game's load times are dictated by its 30 FPS cap. Uncap the framerate and suddenly the 10-15 seconds loading times drop to sub 1 second. That's shoddy porting for you I guess.
Last edited by Chaosvex; May 1, 2013 @ 6:37pm
Showing 1-15 of 26 comments
< >
Hem Nov 27, 2012 @ 12:58pm 
Hey Chaosvex, and thanks a lot for your work on that matter. It still doesnt work for me, though... Same problem: jetsetradio.exe has stopped working during the loading screen... I must mention that in the Nvidia settings (the ones you asked to paste from here :http://i.imgur.com/wmuKv.png ), I could not put the Vertical Sync to Adaptive (half) as requested because the only options I can find there are Use Global Settings, Use 3D Application Settings, Off and On... I doubt THAT little minor difference there would be the reason why I still can't launch the game, though...
Cheers...
Chaosvex Nov 27, 2012 @ 1:32pm 
Sounds like you're having a different issue than the one the patch was created to alleviate (issue being the game's timing code is incorrect). I'm sure it could be solved but unless I can reproduce it, it'd be slightly tricky. ;)

As for the vertical sync thing, you might be using old drivers/control panel (> 6 months or so).

Supported models, apparently:
GeForce 8000 and later for the desktop.
GeForce 8M, 9M, 100M, 200M, 300M, 400M, 500M and 600M-series notebook GPUs.
Quadro 5010M, 5000M, 4000M 3000M, 2000M and 1000M notebook GPUs.
Quadro NVS-series notebook GPUs (only those that support DirectX 10 or higher).
Quadro FX-series notebook GPUs (only those that support DirectX 10 or higher).
NVS-series notebook GPUs (only those that support DirectX 10 or higher).
Brendover Nov 28, 2012 @ 7:57pm 
Still not fixing my issue of the game loading for one second and crashing.
Chaosvex Nov 28, 2012 @ 8:11pm 
As I said, this patch wasn't made to fix crashing since I can't make any attempt to fix it without being able to see the problem myself.
Last edited by Chaosvex; Nov 28, 2012 @ 8:12pm
CERBERUS ALPHA Nov 29, 2012 @ 3:43am 
Does anyone know how to do this refresh rate fix for ATI? The OP claims it's in the control center options but I don't see such an option anywhere, nor has googling helped me at all.
Supercalifragilis Nov 29, 2012 @ 4:41am 
I don't know as for ATI but in my case with Nvidia I don't have the option either... It seems with the latest driver they removed it. And previously I didn't had the choice to do it too. OP can you specify which drivers you currently are using ? In my case it's 306.97
Chaosvex Nov 29, 2012 @ 7:34am 
I'm using 301.42 so I'm not sure why you don't have the option, assuming your card is on the supported list.

Never fear though, there are other ways to do this.

MSI Afterburner
  • Grab it from here[event.msi.com]
  • After installing, start the "MSI Afterburner On-Screen Display Server" (OSD)
  • Add a profile for jetsetradio.exe by clicking the plus icon at the bottom left or just use the global settings.
  • Click the spanner icon near the top right and change the framerate limit option from 0 to 30.

Dxtory
  • Grab it from here[dxtory.com]. The free version can limit the FPS perfectly fine, I believe.
  • Start it up and click 'Advanced' (GPU chip icon)
  • The last option allows you to enter your desired FPS limit. Enter 30 and make sure the box is ticked.

Bandicam
  • Grab it from here[www.bandicam.com]
  • Look at the options here[www.bandicam.com]

There are other options but the three above should be enough.

On a side note, I've noticed that even the game's load times are dictated by its 30 FPS cap. Uncap the framerate and suddenly the 10-15 seconds loading times drop to sub 1 second. That's shoddy porting for you I guess.
Last edited by Chaosvex; Nov 29, 2012 @ 7:50am
Supercalifragilis Nov 29, 2012 @ 10:33am 
My card is supposed to be on the list, it's a 540m... Well i'll try Dxtory
Supercalifragilis Nov 29, 2012 @ 11:37am 
Okay, it seems to work just like a charm. Great work man, thank you very much ! :D I've set up Dxtory 30FPS, the game runs constant and the loadings are not slow anymore. (they're still a bit stuttering though, not a big deal) and my PS2 controller still works with the xbo360ce.
I recommend.
Chaosvex Nov 29, 2012 @ 12:00pm 
No problem, glad to be of service. ;)
2Mello Nov 30, 2012 @ 12:02pm 
You're awesome for making this patch, but unfortunately it's not for my problem, a loading screen crash. I haven't even gotten to see the main menu yet. Saw the title for this thread, the "loading fix" bit and got excited, not knowing it was about slow loading. Might want to clarify there, as this other problem with the loading screen definitely exists.
Chaosvex Nov 30, 2012 @ 1:21pm 
Clarified. :)

Out of interest, does the crash dialogue give you any information if you hit the 'more information' (or similar) option? If so and if a few people posted their crash info, it might be possible to figure out what's responsible.
Brendover Dec 1, 2012 @ 10:20am 
Originally posted by Chaosvex:
Clarified. :)

Out of interest, does the crash dialogue give you any information if you hit the 'more information' (or similar) option? If so and if a few people posted their crash info, it might be possible to figure out what's responsible.

When it crashes, a dialogue box just says the game has crashed and there is a button to close the program. No crash info is given unfortunately.
Chaosvex Dec 1, 2012 @ 2:11pm 
There should be a "View problem details" button in the bottom left.
Joker222 Dec 4, 2012 @ 8:31am 
SEGA or Blit must fixed this, you guys can´t do nothing to make them run again.
Here works ok, the only one can´t work is the pirate version.
Cheers.
Showing 1-15 of 26 comments
< >
Per page: 15 30 50